Redirecionamento de impressora não é aplicado a computadores cliente que se conectar a um servidor de serviços de Terminal com Windows Server 2008 R2 SP1

Traduções de Artigos Traduções de Artigos
Artigo: 2662585 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • Você tem um servidor de serviços de Terminal que esteja executando o Windows Server 2008 R2 Service Pack 1 (SP1).
  • Configurar o servidor de serviços de Terminal para usar o driver de impressora do Terminal Services Easy Print para redirecionamento de impressora.
  • Um usuário cria uma sessão do terminal server para o servidor de serviços de Terminal de um computador cliente.
Nesse cenário, o redirecionamento de impressora não é aplicado ao computador cliente. Portanto, o usuário não é possível imprimir para recursos locais usando uma impressora redirecionada do protocolo RDP (Remote Desktop) ou uma impressora redirecionada do Terminal Services Easy Print.

Causa

Esse problema ocorre porque um valor de tempo limite infinito causa um deadlock no spooler de impressão.

Resolução

Informações sobre hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplica esse hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos de suporte normais se aplicarão a perguntas de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows Server 2008 R2 SP1.

Para obter mais informações sobre como obter um service pack do Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
976932Informações sobre o Service Pack 1 para Windows 7 e Windows Server 2008 R2

Informações do registro

Para aplicar o hotfix neste pacote, não é necessário fazer alterações no registro.

Requisito de reinicialização

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do arquivo

A versão global deste hotfix instala arquivos que tenham os atributos listados nas tabelas a seguir. As datas e horários para esses arquivos estão listados no tempo Universal Coordenado (UTC). As datas e horários para esses arquivos no computador local são exibidos em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e horas podem ser alterados quando você realizar algumas operações nos arquivos.
Observações de informações de arquivo do Windows Server 2008 R2 SP1
Importante Hotfixes do Windows 7 e os hotfixes do Windows Server 2008 R2 estão incluídos nos mesmos pacotes. No entanto, os hotfixes na página solicitação de Hotfix são listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Consulte a seção "Aplica-se A" nos artigos para determinar o sistema operacional real que cada hotfix se aplica para sempre.
  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn), e ramificação do serviço (LDR, GDR) pode ser identificada ao examinar os números de versão do arquivo conforme mostrado na tabela a seguir.
    Reduzir esta tabelaExpandir esta tabela
    VersãoProdutoSR_LevelRamificação do serviço
    6.1.760 1. 21xxxWindows Server 2008 R2SP1LDR
  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "informações de arquivo adicionais para o Windows Server 2008 R2". MUM e arquivos de MANIFESTO e os arquivos de catálogo (. cat) de segurança associadas, são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos de catálogo de segurança para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x64 do Windows Server 2008 R2 SP1
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Tsprint datafile.datNão aplicável38905-Nov-201001: 56Não aplicável
Tsprint pipelineconfig.xmlNão aplicável27505-Nov-201001: 56Não aplicável
Tsprint.dll6.1.7601.21896157,18412-Jan-201206: 28x64
Para todas as versões compatíveis de IA 64?based do Windows Server 2008 R2 SP1
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Tsprint datafile.datNão aplicável38905-Nov-201001: 54Não aplicável
Tsprint pipelineconfig.xmlNão aplicável27505-Nov-201001: 54Não aplicável
Tsprint.dll6.1.7601.21896386,04812-Jan-201205: 29IA-64

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
Para obter mais informações sobre impressão de serviços de Terminal, visite o seguinte site da Microsoft:
Informações gerais sobre a impressão dos serviços de Terminal

Informações de arquivo adicionais

Informações de arquivo adicionais para o Windows Server 2008 R2 SP1

Arquivos adicionais para todas as versões baseadas em x64 do Windows Server 2008 R2 SP1
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoAmd64_tsprint.inf_31bf3856ad364e35_6.1.7601.21896_none_ca510f48754b8f46.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo3,456
Data (UTC)12-Jan-2012
Hora (UTC)07: 29
Arquivos adicionais para todas as 64?based IA versões com do Windows Server 2008 R2 SP1
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoIa64_tsprint.inf_31bf3856ad364e35_6.1.7601.21896_none_6e3417babcec270c.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo3,452
Data (UTC)12-Jan-2012
Hora (UTC)07: 17

Propriedades

Artigo: 2662585 - Última revisão: 16 de fevereiro de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 R2 Service Pack 1 nas seguintes plataformas
    • Windows Server 2008 R2 Standard
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 Datacenter
    • Windows Server 2008 R2 for Itanium-Based Systems
Palavras-chave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2662585 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2662585

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com