Les utilisateurs ne peuvent plus accéder Office 365 après avoir exécuté l'applet de commande MSOLDomaintoFederated de convert pour convertir un domaine existant

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PROBLÈME

Lors de l'installation de single sign-on (SSO) dans Microsoft Office 365, vous exécutez l'applet de commande MSOLDomaintoFederated de convert pour convertir un domaine existant à partir de l'authentification standard d'authentification fédérée. Toutefois, après cela, les utilisateurs qui sont associés à ce domaine ne peuvent plus accéder Office 365.

CAUSE

Ce problème se produit si Office 365 SSO n'est pas configuré correctement ou si le programme d'installation n'est pas achevée.

Remarque : Office que 365 SSO n'est pas pris en charge pour Office 365 Small Business et Office 365 pour les petites entreprises (pré-mise à niveau).

Avertissement  Il s'agit d'une meilleure pratique de Microsoft dans Office 365 ont toujours au moins un administrateur des ID d'utilisateur qui est associé au domaine par défaut afin que d'un accès administratif à l'organisation n'est pas perdu si l'authentification de l'authentification unique est compromise.

SOLUTION

Pour résoudre ce problème, appliquez l'une des méthodes suivantes, selon votre situation.

Méthode 1: Résoudre les problèmes d'installation de l'authentification unique

Utilisez cette méthode uniquement si toutes les conditions suivantes sont remplies :
  • Le problème n'est pas dû à une interruption de service.
  • Restauration immédiatement l'accès des utilisateurs n'est pas obligatoire.
  • Le compte est un Office 365 pour le compte d'entreprises.
Pour diagnostiquer et résoudre les problèmes d'installation de l'authentification unique, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
2530569Dépanner l'installation d'authentification unique dans Office 365

Méthode 2: Inverse le domaine fédéré des paramètres d'authentification pour le domaine de compte Office 365 si l'AD FS 2.0 server est disponible

Utilisez cette méthode uniquement si toutes les conditions suivantes sont remplies :
  • Le problème est dû à une interruption de service qui exige la restauration immédiatement l'accès utilisateur ou le compte est un compte (pré-mise à niveau) de petites entreprises Office 365.
  • Les Services de fédération Active Directory (AD FS) server 2.0 est disponible.
Si ces conditions sont remplies, restaurez les paramètres d'authentification pour le domaine d'authentification standard. Pour ce faire, procédez comme suit :
  1. Démarrez le Module de Active Directory de Windows Azure pour Windows PowerShell. Pour ce faire, cliquez sur Début, pointez sur Tous les programmes, cliquez sur Windows Azure Active Directory, avec le bouton droit Module de Active Directory de Windows Azure pour Windows PowerShell, puis cliquez sur Exécuter en tant qu'administrateur.
  2. Exécutez les commandes suivantes dans l'ordre dans lequel elles sont présentées. Appuyez sur ENTRÉE après chaque commande.
    1. $cred = Get-Credential
      Lorsque vous êtes invité, entrez les informations d'identification administrateur Office 365 qui ne sont pas compatibles SSO.
    2. Connect-MsolService ?credential $cred
    3. Set-MsolADFSContext ?Computer <AD FS 2.0 server name>
      Remarque : Dans cette commande, l'espace réservé <AD fs="" 2.0="" server="" name="">représente le nom de la publicité principale serveur FS 2.0.</AD>
    4. Convert-MSOLDomainToStandard ?DomainName <federated domain name> -SkipUserConversion [$true|$false] -PasswordFile c:\userpasswords.txt
      Remarque : Dans cette commande, l'espace réservé <federated domain="" name="">représente le nom du domaine pour lequel l'authentification unique ne fonctionne pas.</federated>

      Cette commande supprime les informations d'approbation tiers reposent le service de fédération de système d'authentification Office 365 et les locaux AD FS 2.0 service de fédération. -PasswordFile paramètre indique le chemin d'accès du fichier texte qui contient le mot de passe temporaire nouvellement créé de compte de chaque utilisateur fédéré auparavant.

      Si le -SkipUserConversion: $true paramètre est utilisé, aucun fichier de mot de passe est généré et les comptes d'utilisateurs qui sont associés au domaine sont inutilisables. Autrement dit, les comptes d'utilisateurs n'ont pas accès aux ressources d'Office 365 jusqu'à ce que les conditions suivantes sont remplies :
      • Le domaine est converti précédent pour utiliser l'authentification fédérée à l'aide de la Convertir MSOLDomainToFederated applet de commande.
      • Chaque compte d'utilisateur est converti pour utiliser l'authentification standard à l'aide de la Convertir MSOLFederatedUser applet de commande.

Méthode 3: Inverse le domaine fédéré des paramètres d'authentification pour le domaine d'Office 365 si l'AD FS 2.0 server n'est pas disponible

Utilisez cette méthode uniquement si toutes les conditions suivantes sont remplies :
  • Le problème est dû à une interruption de service qui exige la restauration immédiatement l'accès utilisateur ou le compte est un compte (pré-mise à niveau) de petites entreprises Office 365.
  • L'AD FS 2.0 server n'est pas disponible.
Si ces conditions sont remplies, réinitialisez le paramètre d'authentification pour le domaine et pour chaque compte d'utilisateur pour utiliser l'authentification standard. Pour ce faire, procédez comme suit :
  1. Démarrez le Module de Active Directory de Windows Azure pour Windows PowerShell. Pour ce faire, cliquez sur Début, cliquez sur Tous les Programmes, cliquez sur Windows Azure Active Directory, avec le bouton droit Module de Active Directory de Windows Azure pour Windows PowerShell, puis cliquez sur Exécuter en tant qu'administrateur.
  2. Pour convertir le domaine, exécutez les commandes suivantes dans l'ordre dans lequel elles sont présentées. Appuyez sur ENTRÉE après chaque commande.
    1. $cred = Get-Credential
      Lorsque vous êtes invité, entrez les informations d'identification administrateur Office 365 qui ne sont pas compatibles SSO.
    2. Connect-MsolService ?credential $cred
    3. Set-MSOLDomainAuthentication -Authentication Managed -DomainName <federated domain name>
      Remarque : Dans cette commande, l'espace réservé <federated domain="" name="">représente le nom du domaine pour lequel Office 365 SSO ne fonctionne pas.</federated>
  3. Pour chaque utilisateur qui possède un suffixe de nom principal (UPN) d'utilisateur qui est associé au domaine, exécutez la commande suivante :
    Convert-MSOLFederatedUser -UserPrincipalName <string>
    Remarque : Dans cette commande, l'espace réservé <string>représente la valeur de l'UPN de l'utilisateur qui est en cours de conversion.</string>

PLUS D'INFORMATIONS

Important : Dans les scénarios dans le dernier administrateur d'organisation de services de cloud Microsoft affecté du suffixe de domaine d'un domaine fédéré et qui devient administrateur prenant en charge l'authentification unique, les échecs AD FS limiteront exécutant la cmdlet MSOLService se connecter et peuvent empêcher la correction des problèmes d'authentification unique. Il est recommandée de nuage Microsoft services, que les administrateurs d'organisation toujours conserver au moins un compte d'administrateur global n'est pas activé l'authentification unique pour permettre de résoudre les problèmes de l'authentification unique à l'aide de la Windows Azure Active Directory Module pour Windows PowerShell.

Si ce problème se produit, contactez le Support de Microsoft pour que la fédération de domaine inversée temporairement afin que l'administrateur (qui n'est plus compatibles SSO) peut de nouveau accéder pour résoudre les problèmes d'authentification unique.

Besoin d'aide ? Accédez à la Communauté Office 365 (site Web).

Propriétés

Numéro d'article: 2662960 - Dernière mise à jour: samedi 1 juin 2013 - Version: 13.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
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Mots-clés : 
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