Użytkowników można już zalogować się po uruchomieniu polecenia convert MSOLDomaintoFederated do konwersji istniejącej domeny

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 2662960 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

PROBLEM

Podczas konfigurowania rejestracji jednokrotnej (SSO) w usłudze chmura Microsoft Office 365, Microsoft Azure lub Windows Intune można uruchomić polecenie cmdletMSOLDomaintoFederated konwersji do konwersji istniejącej domeny z uwierzytelniania standardowego uwierzytelniania federacyjnych. Jednak po wykonaniu tej czynności użytkowników, którzy są skojarzone z tą domeną dłużej korzystać usługa w chmurze.

PRZYCZYNA

Ten problem występuje, jeśli usługa rejestracji Jednokrotnej nie jest poprawnie skonfigurowany lub instalacja nie jest ukończona.

OstrzeżenieJest najlepszym rozwiązaniem zawsze ma identyfikator użytkownika co najmniej jednego administratora, skojarzonej z domyślną domenę tak, że dostęp administracyjny do organizacji nie zostanie utracony, jeśli jest zagrożona usługa rejestracji Jednokrotnej firmy Microsoft.

ROZWIĄZANIE

Aby rozwiązać ten problem, należy użyć jednej z następujących metod, odpowiedniej do konkretnej sytuacji.

Metoda 1: Rozwiązywanie problemów z instalacją usługi rejestracji Jednokrotnej

Tej metody należy używać tylko wtedy, gdy są spełnione wszystkie następujące warunki:
  • Ten problem nie jest spowodowany przez awarię usług.
  • Natychmiast przywrócić dostęp użytkownika nie jest wymagane.
Diagnozowanie i rozwiązywanie problemów z instalacją usługi rejestracji Jednokrotnej, zobacz następujący artykuł z bazy wiedzy Microsoft Knowledge Base:
2530569Rozwiązywanie problemów ustawienia rejestracji jednokrotnej w usłudze Office 365, Windows Intune lub Azure

Metoda 2: Przywrócić Federacji domeny powrót do standardowego uwierzytelnienia, jeśli serwer AD FS nie jest dostępny

Tej metody należy używać tylko wtedy, gdy są spełnione wszystkie następujące warunki:
  • Przyczyną problemu jest awaria usługi wymagającej natychmiast przywrócić dostęp użytkownika.
  • Serwer programu AD FS jest niedostępny.
Jeśli te warunki są spełnione, należy zresetować ustawienia uwierzytelniania dla domeny i dla każdego konta użytkownika do korzystania z uwierzytelniania standardowego. Aby to zrobić, wykonaj następujące kroki:
  1. Uruchom moduł Azure usługi Active Directory środowiska Windows PowerShell. Aby to zrobić, kliknij przyciskStart, kliknij polecenie wszystkie programy, kliknij przycisk Windows Azure Active Directory, kliknij prawym przyciskiem myszy Windows Azure Active Directory modułu dla Windows PowerShell, a następnie kliknij Uruchom jako administrator.
  2. Aby przekonwertować domeny, uruchom następujące polecenia w kolejności, w jakiej są przedstawione. Naciśnij klawisz Enter po wpisaniu każdego polecenia.
    1. $cred = Get-Credential
      Gdy zostanie wyświetlony monit, wprowadź poświadczenia administratora usługi chmury, które nie są włączone usługi rejestracji Jednokrotnej.
    2. Connect-MsolService –credential $cred
    3. Set-MSOLDomainAuthentication -Authentication Managed -DomainName <federated domain name>
      Uwaga W tym poleceniu symbol zastępczy <federated domain="" name="">reprezentuje nazwę domeny, dla którego nie działa usługa rejestracji Jednokrotnej.</federated>
  3. Dla każdego użytkownika, który ma sufiks głównej nazwy (UPN) użytkownika, który ma skojarzone z domeną uruchom następujące polecenie:
    Convert-MSOLFederatedUser -UserPrincipalName <string>
    Uwaga W tym poleceniu symbol zastępczy <string>reprezentuje wartość UPN dla użytkownika, który jest konwertowany.</string>

WIĘCEJ INFORMACJI

WażneW scenariuszach, w którym ostatni administrator organizacji usług Microsoft cloud przypisano sufiks domeny w domenie federacyjnej i która staje się administratorem włączona usługa rejestracji Jednokrotnej, kolejne błędy programu AD FS ograniczy uruchomione polecenie cmdletPołączyć połączenia i może uniemożliwić Korygowanie problemów rejestracji Jednokrotnej. To najlepsze zalecenie praktyki chmura Microsoft zawsze services administratorzy organizacji zachować co najmniej jedno konto administratora globalnego, która nie jest włączona usługa rejestracji Jednokrotnej umożliwiające rozwiązywanie problemów rejestracji Jednokrotnej za pomocą Azure Active Directory moduł dla środowiska Windows PowerShell.

Jeśli występuje ten problem, należy skontaktować się z Microsoft Support mieć Federacji domeny tymczasowo wycofane, aby administrator (który nie jest już włączona usługa rejestracji Jednokrotnej) może odzyskać dostęp do rozwiązywania problemów dotyczących usługi rejestracji Jednokrotnej.

Nadal potrzebujesz pomocy? Przejdź do Społeczności użytkowników usługi Office 365witryny sieci Web lubFora Azure usługi Active Directory witryny sieci Web.

Właściwości

Numer ID artykułu: 2662960 - Ostatnia weryfikacja: 26 czerwca 2014 - Weryfikacja: 17.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Azure
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Office 365 Identity Management
Słowa kluczowe: 
o365 o365a o365022013 after upgrade o365062011 pre-upgrade o365e o365m kbmt KB2662960 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.
Anglojęzyczna wersja tego artykułu to: 2662960

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com