Mevcut bir etki alanını dönüştürmek için Convert-MSOLDomaintoFederated komutunu çalıştırdıktan sonra kullanıcılar artık oturum açamıyor

Bu makalede, mevcut bir etki alanını standart kimlik doğrulamasından federasyon kimlik doğrulamasına dönüştürmek için komutu çalıştırdıktan Convert-MSOLDomaintoFederated sonra kullanıcıların artık Office 365, Azure veya Microsoft Intune erişememesi sorununu giderme hakkında bilgi sağlanır.

Özgün ürün sürümü: Cloud Services (Web rolleri/Çalışan rolleri), Microsoft Entra ID, Microsoft Intune, Azure Backup Office 365 Kimlik Yönetimi
Özgün KB numarası: 2662960

Not

Azure AD ve MSOnline PowerShell modülleri 30 Mart 2024 itibarıyla kullanım dışı bırakılmıştır. Daha fazla bilgi edinmek için kullanımdan kaldırma güncelleştirmesini okuyun. Bu tarihten sonra bu modüllere yönelik destek, Microsoft Graph PowerShell SDK'sına geçiş yardımı ve güvenlik düzeltmeleriyle sınırlıdır. Kullanım dışı bırakılan modüller Mart 30 2025'e kadar çalışmaya devam edecektir.

Microsoft Entra ID (eski adıyla Azure AD) ile etkileşime geçmek için Microsoft Graph PowerShell'e geçiş öneririz. Sık sorulan geçiş soruları için Bkz. Geçiş SSS. Not: MSOnline'ın 1.0.x sürümleri 30 Haziran 2024'den sonra kesintiye neden olabilir.

Belirtiler

Office 365, Microsoft Azure veya Microsoft Intune gibi bir Microsoft bulut hizmetinde çoklu oturum açma (SSO) kurulumu sırasında, var olan bir etki alanını standart kimlik doğrulamasından federasyon kimlik doğrulamasına dönüştürmek için komutunu çalıştırırsınızConvert-MSOLDomaintoFederated. Ancak, bunu yaptıktan sonra, bu etki alanıyla ilişkilendirilmiş kullanıcılar artık bulut hizmetine erişemez.

Neden

Bu sorun, SSO doğru ayarlanmadıysa veya kurulum tamamlanmamışsa oluşur.

Uyarı

Varsayılan etki alanıyla ilişkilendirilmiş en az bir yönetici kullanıcı kimliğine sahip olmak, SSO'nun gizliliği ihlal edilirse kuruluşa yönetici erişiminin kaybolmaması için Microsoft'un en iyi uygulamasıdır.

Çözüm

Bu sorunu çözmek için, durumunuz için uygun olan aşağıdaki yöntemlerden birini kullanın.

Yöntem 1: SSO kurulumu sorunlarını giderme

Bu yöntemi yalnızca aşağıdaki koşulların tümü doğruysa kullanın:

  • Sorunun nedeni hizmet kesintisi değildir.
  • Kullanıcı erişiminin hemen geri yüklenmesi gerekmez.

SSO kurulumunu tanılamak ve gidermek için bkz. Office 365, Intune veya Azure'da çoklu oturum açma kurulumu sorunlarını giderme.

Yöntem 2: AD FS sunucusu kullanılamıyorsa etki alanı federasyonunu standart kimlik doğrulamasına geri döndürme

Bu yöntemi yalnızca aşağıdaki koşulların tümü doğruysa kullanın:

  • Sorun, kullanıcı erişiminin hemen geri yüklenmesini gerektiren bir hizmet kesintisi nedeniyle oluşur.
  • AD FS sunucusu kullanılamıyor.

Bu koşullar doğruysa, etki alanı ve her kullanıcı hesabının standart kimlik doğrulamasını kullanması için kimlik doğrulama ayarını sıfırlayın. Bunu yapmak için şu adımları uygulayın:

  1. Windows PowerShell için Azure Active Directory modülünü başlatın. Bunu yapmak için Başlat'ı seçin, Tüm Programlar'ı seçin, Windows Azure Active Directory'yi seçin, Windows PowerShell için Windows Azure Active Directory modülü'ne sağ tıklayın ve ardından Yönetici olarak çalıştır'ı seçin.

  2. Etki alanını dönüştürmek için aşağıdaki komutları sunuldukları sırayla çalıştırın. Her komutu yazdıktan sonra Enter tuşuna basın.

    $cred = Get-Credential
    

    İstendiğinde, SSO etkin olmayan bulut hizmeti yöneticisi kimlik bilgilerini girin.

    Connect-MsolService -credential $cred
    
    Set-MSOLDomainAuthentication -Authentication Managed -DomainName <federated domain name>
    

    Not

    Bu komutta, yer tutucu <federasyon etki alanı adı> , SSO'nun çalışmadığı etki alanının adını temsil eder.

  3. Etki alanıyla ilişkilendirilmiş bir kullanıcı asıl adı (UPN) soneki olan her kullanıcı için aşağıdaki komutu çalıştırın:

    Convert-MSOLFederatedUser -UserPrincipalName <string>
    

    Not

    Bu komutta, yer tutucu <dize> dönüştürülen kullanıcının UPN değerini temsil eder.

Daha fazla bilgi

Önemli

Son Microsoft bulut hizmetleri kuruluş yöneticisine federasyon etki alanının etki alanı soneki atandığı ve bu yöneticinin SSO etkin olduğu senaryolarda, sonraki AD FS hataları connect-MSOLService komutunun çalıştırılmasını sınırlandırır ve SSO sorunlarının düzeltilmesini engelleyebilir. Microsoft bulut hizmetleri kuruluş yöneticilerinin, Windows PowerShell için Azure Active Directory modülünü kullanarak SSO sorunlarını gidermeye olanak sağlamak için her zaman SSO etkin olmayan en az bir genel yönetici hesabı tutmaları önerilir.

Bu sorun oluşursa, yöneticinin (artık SSO etkin olmayan) SSO ile ilgili sorunları gidermek için yeniden erişim kazanabilmesi için etki alanı federasyonunun geçici olarak ters çevrilmesi için Microsoft Desteği başvurun.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.