Cannot connect to Microsoft Dynamics CRM server because we cannot authenticate your credentials

Article ID: 2666080 - View products that this article applies to.
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Symptoms

When you try to configure the Microsoft Dynamics CRM Client for Outlook with a Dynamics CRM Online organization, you get the following error:

"Cannot connect to Microsoft Dynamics CRM server because we cannot authenticate your credentials. Check your connection or contact your administrator for more help."

In the configuration log the following error is shown:

 
Error| Error connecting to URL: https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc Exception: Microsoft.Crm.CrmException: Logon failed because credentials are invalid ---> Microsoft.Crm.Passport.IdCrl.IdCrlException: GetAuthState() - Request Status:
   at Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.LogonOrgId(String policy, String partner, LOGON_FLAG logonFlag)
   at Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.Logon(String userName, String password, String partner, String policy, String& memberName)
   at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider`1.SignIn()
   --- End of inner exception stack trace ---
   at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.RetrieveUserCredentialsAndSignIn(Uri endPoint, Credential credentials, Form parentWindow, Boolean retryOnError, IClientOrganizationContext context)
   at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
   at Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
   at Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Cause

The cause of this issue is due to not having your Windows Live ID verified. When you sign up for a Windows Live ID and you are not using a @outlook.com or a @live.com email address, you will need to verify the e-mail address before it can be used to configure the Microsoft Dynamics CRM Client for Outlook.

Resolution

After the creation of your Windows Live ID, an email is sent to the email address you created as your Windows Live ID. You will need to login to that email account and click on the link in the email to verify the email address. Once that is complete, you will be able to continue the configuration of the Microsoft Dynamics CRM Client for Outlook.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2666080 - Last Review: September 12, 2013 - Revision: 2.0
Applies to
  • Microsoft Dynamics CRM Online Professional Edition
Keywords: 
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