Unter "Software" werden die installierten Programme nicht korrekt angezeigt

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Problembeschreibung

Beim Installieren oder Deinstallieren von Programmen werden in der Systemsteuerung unter Software möglicherweise die installierten Programme nicht korrekt angezeigt. Das Feld Zurzeit installierte Programme enthält möglicherweise nur eine einzelne Zeichenfolge oder es wird dort ein größerer Leerbereich vor den Programmeinträgen angezeigt. Möglicherweise werden auch überhaupt keine Programme in der Liste angezeigt. Es kann auch eine der folgenden Fehlermeldungen angezeigt werden:

Meldung 1
Unerwarteter Fehler. Klasse nicht registriert.
res://appwiz.cpl/listbox.htc
Zeile: 225
Meldung 2
Das Objekt unterstützt diese Eigenschaft oder Methode nicht: res://appwiz.cpl/default.hta.
Zeile: 75

Ursache

Dieses Problem tritt möglicherweise auf, wenn die Deinstallationsroutine eines Programms Registrierungseinträge entfernt, die von Windows für das Anzeigen installierter Programm benötigt werden.

Lösung

Wichtig Dieser Abschnitt bzw. die Methoden- oder Aufgabenbeschreibung enthält Hinweise zum Ändern der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung der Registrierung eine Sicherungskopie erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 Sichern und Wiederherstellen der Registrierung in Windows


Wenn Sie das Problem automatisch beheben lassen möchten, lesen Sie den Abschnitt "Problem automatisch beheben". Wenn Sie das Problem lieber selbst beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Problem automatisch beheben



Um das Problem automatisch zu beheben, klicken Sie auf die Fix it-Schaltfläche oder den Link Problem beheben. Klicken Sie im Dialogfeld Dateidownload auf Ausführen, und befolgen Sie die Schritte im Fix it-Assistenten.


Problem beheben
Microsoft Fix it 50542

Hinweise
  • Wenn das Tool Software nach dem Ausführen der Fix it-Lösung immer noch nicht richtig funktioniert, führen Sie ein direktes Upgrade aus. Weitere Informationen zum Ausführen eines direkten Upgrades finden Sie im Abschnitt "Weitere Informationen".
  • Dieser Assistent ist möglicherweise nur in Englisch verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.
  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem USB-Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.

Lesen Sie anschließend den Abschnitt "Wurde das Problem behoben?".



Problem manuell beheben

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie anschließend CMD ein.
  2. Geben Sie an der Eingabeaufforderung REGSVR32 APPWIZ.CPL ein.
  3. Sollte dies fehlschlagen, suchen Sie nach den unten aufgeführten Registrierungseinträgen. Überprüfen Sie die Registrierung auf die folgenden Schlüssel und Werte hin. Erstellen Sie fehlende Schlüssel oder Werte neu. Beachten Sie, dass bei diesen Schlüsseln der Laufwerkbuchstabe des Systemlaufwerks verwendet wird. Möglicherweise müssen diese Einträge an die Konfiguration Ihres Computers angepasst werden.
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}]
      "ADODB.Recordset"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
      "C:\Programe\Gemeinsame Dateien\System\ado\msado15.dll"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32]
      "ThreadingModel"="Apartment"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.5"
    • [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\VersionIndependentProgID]
      "ADODB.Recordset"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}
      "Microsoft OLE DB Row Position Library"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\InprocServer32
      "C:\Programme\Gemeinsame Dateien\System\Ole DB\oledb32.dll" "ThreadingModel"="Both"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\ProgID
      "RowPosition.RowPosition.1"
    • HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\VersionIndependentProgID
      "RowPosition.RowPosition"
    • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
      "%SystemRoot%\System32\appwiz.cpl"
  4. Wenden Sie je nach der von Ihnen verwendeten Konfiguration eines der folgenden Verfahren an, und überprüfen Sie, ob sich das Problem dadurch beheben lässt. Wenn das Problem behoben wurde, überspringen Sie die verbleibenden Schritte. Wenn das Problem weiterhin besteht, fahren Sie mit Schritt 5 fort.
    • Reparieren Sie zum Beheben dieses Problems Internet Explorer 6.0, falls auf dem Computer Internet Explorer 6.0 installiert ist:
      1. Klicken Sie auf Start und anschließend auf Ausführen.
      2. Kopieren Sie den folgenden Befehl, und fügen Sie ihn in das Feld Öffnen ein. Klicken Sie anschließend auf OK.
        rundll32 setupwbv.dll,IE6Maintenance "C:\Programme\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt
        Bei diesem Befehl wird zwischen Groß- und Kleinschreibung unterschieden, daher empfiehlt es sich, den Befehl aus diesem Artikel zu kopieren und dann in das Feld Öffnen einzufügen.
    • Reparieren Sie zum Beheben dieses Problems Internet Explorer 5.0 bzw. 5.5, falls auf dem Computer Internet Explorer 5.0 oder 5.5 installiert ist:
      1. Klicken Sie auf Start und anschließend auf Ausführen.
      2. Kopieren Sie den folgenden Befehl, und fügen Sie ihn in das Feld Öffnen ein. Klicken Sie anschließend auf OK.
        rundll32 setupwbv.dll,IE5Maintenance "C:\Programme\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt
        Bei diesem Befehl wird zwischen Groß- und Kleinschreibung unterschieden, daher empfiehlt es sich, den Befehl aus diesem Artikel zu kopieren und dann in das Feld Öffnen einzufügen.
  5. Führen Sie ein direktes Upgrade durch:

    Hinweis Bevor Sie ein direktes Upgrade durchführen, sollten Sie eine Sicherungskopie Ihrer Daten erstellen. Weitere Informationen zu den Risiken eines direkten Upgrades finden Sie im Abschnitt "Weitere Informationen".
    1. Führen Sie "Winnt32.exe" im Verzeichnis "\I386" auf der Windows 2000-Installations-CD aus.
    2. Klicken Sie auf Auf Windows 2000 aktualisieren, wenn der Setupbildschirm von Windows 2000 angezeigt wird.
    3. Warten Sie, bis die Installation abgeschlossen ist.
Falls unter "Software" die installierten Programme noch immer noch korrekt angezeigt werden, oder wenn Sie das Problem ohne eine Aktualisierung von Internet Explorer beheben möchten, vergewissern Sie sich, dass die folgenden Registrierungsschlüssel Einträge enthalten:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\ARPCache
Hinweis Wenn diese Registrierungsschlüssel leer sind, werden möglicherweise auch unter Software keine Programme angezeigt.

Registrieren Sie mit dem Befehl [Pfad\Dateiname] die folgenden Dateien:
%systemroot%\System32\Appwiz.cpl
%systemroot%\System32\Mshtml.dll
%systemroot%\System32\Jscript.dll
%systemroot%\System32\Msi.dll
Programme\Gemeinsame Dateien\System\Ole DB\Oledb32.dll
Programme\Gemeinsame Dateien\System\Ado\Msado15.dll
%systemroot%\System32\Msdart32.dll [nicht registrierbar]
%systemroot%\System32\Mshtmled.dll
%systemroot%\System32\Mswstr10.dll [nicht registrierbar]
Wenn unter Software keine oder nur einige der Informationen angezeigt werden, überprüfen Sie die Datumsangaben der Dateien. Wenn möglich, registrieren Sie die folgenden Dateien:
%systemroot%\System32\Gdi32.dll [nicht registrierbar]
%systemroot%\System32\User32.dll [nicht registrierbar]
%systemroot%\System32\Msvcrt.dll [nicht registrierbar]
%systemroot%\System32\Ole32.dll
%systemroot%\System32\Shlwapi.dll [nicht registrierbar]
%systemroot%\System32\Imm32.dll [nicht registrierbar]
%systemroot%\System32\Indicdll.dll [nicht registrierbar]
%systemroot%\System32\Urlmon.dll
%systemroot%\System32\Version.dll [nicht registrierbar]
%systemroot%\System32\Lz32.dll [nicht registrierbar]
%systemroot%\System32\Comctl32.dll [nicht registrierbar]
%systemroot%\System32\Clbcatq.dll
%systemroot%\System32\Oleaut32.dll
%systemroot%\System32\Mlang.dll
%systemroot%\System32\Shell32.dll
%systemroot%\System32\Shdoclc.dll [nicht registrierbar]
%systemroot%\System32\NetapI32.dll [nicht registrierbar]
%systemroot%\System32\Secur32.dll [nicht registrierbar]
%systemroot%\System32\Netrap.dll [nicht registrierbar]
%systemroot%\System32\Samlib.dll [nicht registrierbar]
%systemroot%\System32\Ws2_32.dll [nicht registrierbar]
%systemroot%\System32\Ws2help.dll [nicht registrierbar]
%systemroot%\System32\Wldap32.dll [nicht registrierbar]
%systemroot%\System32\Dnsapi.dll [nicht registrierbar]
%systemroot%\System32\Wsock32.dll [nicht registrierbar]
%systemroot%\System32\Plugin.ocx
%systemroot%\System32\Wininet.dll [nicht registrierbar]
%systemroot%\System32\Crypt32.dll [nicht registrierbar]
%systemroot%\System32\Msasn1.dll [nicht registrierbar]
%systemroot%\System32\Msls31.dll [nicht registrierbar]
%systemroot%\System32\Imgutil.dll
%systemroot%\System32\Cscui.dll
%systemroot%\System32\Cscdll.dll [nicht registrierbar]
Falls die Benutzeroberfläche unter Software korrekt angezeigt wird, aber keine installierten Programme aufgeführt sind, überprüfen Sie, ob in der Registrierung der folgende Schlüssel vorhanden ist:
HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32
Kopieren Sie, falls dieser Schlüssel fehlt, den folgenden Text in eine Textdatei, speichern Sie die Datei mit der Dateierweiterung ".reg", und doppelklicken Sie dann auf dem betroffenen Computer auf die Datei, um die fehlenden Registrierungseinträge wiederherzustellen.

Windows Registrierungs-Editor Version 5.00:
[HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,61,00,70,00,70,00,77,00,69,00,7a,00,2e,00,63,00,70,00,6c,00,00,00
"ThreadingModel"="Apartment"

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Es folgt eine Liste aller Registrierungsschlüssel, die von Windows für das Anzeigen der installierten Programme verwendet werden. Diese Schlüssel müssen durch das Registrieren von "Appwiz.cpl" gesetzt werden. Sie sind jedoch hier aufgeführt, damit Sie überprüfen können, ob die Registrierung erfolgreich war.
  • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}]
    @="%DESC_ShellAppMgr%"
  • [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"
  • [HKEY_CLASSES_ROOT\CLSID\{0B124F8C-91F0-11D1-B8B5-006008059382}]
    @="Installed Apps Enumerator"
  • [HKEY_CLASSES_ROOT\CLSID\{0B124F8F-91F0-11D1-B8B5-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"

    Hinweis Dieser Schlüssel ist nur in Microsoft Windows XP verfügbar.
  • [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}]
    @="Darwin App Publisher"
  • [HKEY_CLASSES_ROOT\CLSID\{CFCCC7A0-A282-11D1-9082-006008059382}\InProcServer32]
    @="SystemRoot%\System32\appwiz.cpl" (REG_EXPAND_SZ)
    "ThreadingModel"="Apartment"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{352EC2B7-8B9A-11D1-B8AE-006008059382}"="Shell Application Manager"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{0B124F8F-91F0-11D1-B8B5-006008059382}"="Installed Apps Enumerator"

    Hinweis Dieser Schlüssel ist nur in Microsoft Windows XP verfügbar.
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\App Management\Publishers\Darwin App Publisher]
    @="{CFCCC7A0-A282-11D1-9082-006008059382}"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
    "{CFCCC7A0-A282-11D1-9082-006008059382}"="Darwin App Publisher"
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\InProcCPLs]
    "appwiz.cpl"=""

    Registrierungseinträge, die während der Ausführung von ARP verwendet werden

  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppInstallPath
    Liest eine INF-Datei. Code liest Namen der INF-Datei.Verwendeter Abschnitt in INF-Datei: "AppInstallList"
  • HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer\Terminal Server\EnableAdminRemote
    Während des Ausführens von ARP auf "1" gesetzt.Hinweis für TS, dass ARP ausgeführt wird.
    Wird beim Beenden von ARP auf "0" gesetzt.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Management\Publishers Zählt Herausgeber von Anwendungen auf.
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Wx86\cmdline
    Zeigt an, ob Wx86 aktiviert ist.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\NewShortcutHandlers
    Wird aufgezählt, um Liste der Handler für neue Verknüpfungen zu erhalten.Diese Handler fügen möglicherweise Verknüpfungen mit bestimmten Elementen hinzu, z. B. mit dem Startmenü, dem Desktop oder anderen Elementen.
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Shutdown\ForceReboot
    Zeigt an, ob nach dem Ausführen von Setup ein Neustart notwendig ist.
    Das Vorhandensein des Werts bedeutet, dass ein Neustart erforderlich ist.
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\MS-DOSOptions

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
265829 Das Systemprogramm "Software" funktioniert nach Installation von Internet Explorer 5.5 oder Internet Explorer 6 auf Windows 2000 eventuell nicht
315341 Ausführen eines direkten Upgrades (Neuinstallation) von Windows XP
292175 Ausführen eines direkten Upgrades von Windows 2000

Wurde das Problem behoben?

  • Testen Sie, ob das Problem behoben ist. Wenn das Problem beseitigt ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem noch nicht behoben ist, wenden Sie sich an den Support.
  • Ihr Feedback ist uns wichtig. Um uns Ihr Feedback zu übermitteln oder uns über Probleme mit dieser Lösung zu informieren, schreiben Sie einen Kommentar im "Fix it for me"-Blog, oder senden Sie uns eine E-Mail.

Eigenschaften

Artikel-ID: 266668 - Geändert am: Samstag, 14. Mai 2011 - Version: 4.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
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