XL : Comment calculer la somme et mettre en forme une plage d'heures, de minutes ou de secondes

Traductions disponibles Traductions disponibles
Numéro d'article: 266691 - Voir les produits auxquels s'applique cet article
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Sommaire

Résumé

Pour mettre automatiquement en forme des heures qui, une fois ajoutées les unes aux autres dépassent 24 heures, 60 minutes ou 60 secondes, vous pouvez utiliser les formats personnalisés de nombre suivants et la fonction SOMME dans Excel :
  • Heures = [h]:mm:ss
  • Minutes = [m]:ss
  • Secondes = [ss]

Plus d'informations

Dans Microsoft Excel, le format personnalisé des heures est déjà créé. Cependant, vous devez créer les formats des minutes et des secondes pour chaque classeur qui les nécessite.

Pour afficher correctement les totaux des heures supérieurs à 24 et les totaux des minutes et des secondes supérieurs à 60, appliquez les méthodes suivantes.

Exemple pour les heures

Pour mettre en forme des sommes d'heures qui sont supérieures à 24 heures, procédez comme suit :
  1. Créez une nouvelle feuille de calcul et tapez les valeurs suivantes. Assurez-vous que vous utilisez deux points (:) pour séparer les chiffres.
         A1 :      12:35:58
         A2 :      12:24:30
         A3 :      11:18:23
    					
  2. Tapez la formule suivante dans la cellule A4. Excel met en forme automatiquement et correctement les résultats si vous ajoutez des heures.
         A4 :      =SOMME(A1:A3)     
    					
Excel affiche 36:18:51 comme total.

Exemple pour les minutes et les secondes

Pour mettre en forme des sommes de minutes ou secondes qui sont supérieures à 60, procédez comme suit :
  1. Créez une nouvelle feuille de calcul et tapez les valeurs suivantes. Assurez-vous que vous insérez le zéro non significatif (00) et que vous utilisez deux points (:) pour séparer les chiffres.
         A1 :      00:42:58
         A2 :      00:19:30
         A3 :      00:37:23
    					
  2. Tapez la formule suivante dans la cellule A4 :
         A4 :      =SOMME(A1:A3)     
    						
    Excel affiche 1:39:51 comme total. Pour afficher ce total en minutes et secondes ou uniquement en secondes, procédez comme suit pour créer et appliquer le format approprié :
    1. Sélectionnez la cellule A4.
    2. Dans le menu Format, cliquez sur Cellule, puis sur l'onglet Nombre.
    3. Dans la liste Catégorie, cliquez sur Personnalisée.
    4. Dans la zone Type, modifiez les codes du format de nombre pour créer le format que vous souhaitez.
      • Pour le format des minutes, tapez [m]:ss
      • Pour le format des secondes, tapez [ss]
    5. Sélectionnez la mise en forme que vous souhaitez appliquer, puis cliquez sur OK.
    Une fois que vous avez appliqué le format des minutes, Excel affiche 99:51 comme total.

    Une fois que vous avez appliqué le format des secondes, Excel affiche 5991 comme total.
REMARQUE : lorsque vous modifiez un format intégré, Excel crée un nouveau format, mais ne remplace pas le format existant.

Procédure pour appliquer les formats aux autres cellules

Une fois que vous avez créé les formats personnalisés de minutes et de secondes, procédez comme suit pour les appliquer à toutes les autres cellules du classeur :
  1. Sélectionnez les cellules dans lesquelles vous souhaitez afficher le format qui vient d'être créé.
  2. Dans le menu Format, cliquez sur Cellule.
  3. Dans la boîte de dialogue, cliquez sur l'onglet Nombre, puis sur Personnalisée.
  4. Dans la liste personnalisée des formats, sélectionnez le format approprié, puis cliquez sur OK.

Propriétés

Numéro d'article: 266691 - Dernière mise à jour: lundi 6 décembre 2004 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 2000 Standard
  • Microsoft Excel 2002
Mots-clés : 
kbhowto KB266691
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com