O utilizador não consegue ver informações de disponibilidade para um utilizador remoto numa implementação híbrida do Exchange Server

Número original da BDC: 2667844

Nota

O assistente de Configuração Híbrida incluído no Consola de Gestão do Exchange no Microsoft Exchange Server 2010 já não é suportado. Por conseguinte, já não deve utilizar o antigo assistente de Configuração Híbrida. Em vez disso, utilize o assistente de Configuração Híbrida do Microsoft 365 que está disponível em https://aka.ms/HybridWizard. Para obter mais informações, consulte Assistente de Configuração Híbrida do Microsoft 365 para o Exchange 2010.

Sintomas

Tem uma implementação híbrida de Microsoft Exchange Server no local e Microsoft Exchange Online no Microsoft 365 em que o servidor híbrido está a ser executado Exchange Server 2010. No entanto, os utilizadores não podem ver informações de disponibilidade para um utilizador remoto. Quando um utilizador tenta ver informações de disponibilidade de um utilizador remoto, as informações de disponibilidade não são apresentadas. Em vez disso, o utilizador pode deparar-se com um ou mais dos seguintes sintomas:

  • As informações de disponibilidade do utilizador remoto são apresentadas como carateres de sinal de número (#) no Calendário.

  • No Outlook Web App, é apresentado o "erro 5037".

  • Os ficheiros FileName>-fb.log e <FileName> do Microsoft Outlook<-as.log contêm uma mensagem de erro semelhante à seguinte:

    <FreeBusyResponse><ResponseMessage ResponseClass="Error"><MessageText>O autor da chamada não tem acesso a dados de disponibilidade.</MessageText><ResponseCode>ErrorNoFreeBusyAccess</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey><MessageXml><ExceptionType xmlns="http://schemas.microsoft.com/exchange/services/2006/errors">Microsoft.Exchange.InfoWorker.Common.Availability.NoFreeBusyAccessException</ExceptionType ExceptionCode xmlns="http://schemas.microsoft.com/exchange/services/2006/errors">5037</ExceptionCode><ExceptionServerName xmlns="http://schemas.microsoft.com/exchange/services/2006/errorsServerName<>/ExceptionServerName><><ResponseSource xmlns=""http://schemas.microsoft.com/exchange/services/2006/errors>https://\<Server>.outlook.com/EWS/Exchange.asmx/WSSecurity</ResponseSource></MessageXml></ResponseMessage><FreeBusyView><FreeBusyViewType xmlns="http://schemas.microsoft.com/exchange/services/2006/typesNone></FreeBusyViewType></FreeBusyView></FreeBusyResponse>

Por exemplo, um utilizador do Microsoft 365 não consegue ver informações de disponibilidade para um utilizador no local. No entanto, outros utilizadores podem ver informações de disponibilidade para esse mesmo utilizador no local.

Causa

Este problema ocorre se o nome de domínio do endereço SMTP (Simple Mail Transfer Protocol) do utilizador que está a tentar ver as informações de disponibilidade não estiver incluído entre os nomes de domínio na relação da organização. Por exemplo, quando executa o cmdlet Test-OrganizationRelationship, é apresentado o seguinte resultado:

RunspaceId: a6c3799f-2ecd-4d79-ae4b-6c470ddd1dee
Identidade:
ID: LocalFederatedDomainsAreMissingFromTheRemoteOrganizationRelationsipDomains
Estado: Aviso
Descrição: existem domínios federados localmente que não estão presentes na lista de domínios para o objeto de relação de organização remota.
IsValid: True

Isto ocorre se o domínio SMTP não tiver sido adicionado manualmente à relação da organização. Isto também pode ocorrer se as seguintes condições forem verdadeiras:

  • A conta de utilizador do Microsoft 365 foi criada antes de atualizar o ambiente no local para Exchange Server 2010.
  • Utilizou o assistente de Configuração Híbrida no Exchange Server 2010 no ambiente no local para configurar a confiança de federação. Por exemplo, o nome de domínio do utilizador do Microsoft 365 é contoso.com.

Neste cenário, a conta de utilizador do Microsoft 365 não tem @contoso.mail.onmicrosoft.com como um dos respetivos endereços proxy. O pedido para o ambiente no local utiliza @contoso.com em vez de para a conta de @contoso.mail.onmicrosoft.com utilizador do Microsoft 365. O pedido é rejeitado porque a relação da organização no ambiente no local não contoso.com foi adicionada ao mesmo.

Resolução

Para resolver este problema, edite a relação da organização no ambiente no local para incluir o domínio SMTP do utilizador que está a ter o problema. Para tal, utilize um dos seguintes métodos:

Método 1: Utilizar Consola de Gestão do Exchange

  1. No servidor Exchange no local, abra Consola de Gestão do Exchange e, em seguida, selecione Configuração da Organização em Microsoft Exchange No Local.
  2. Selecione o separador Relações da Organização e, em seguida, veja as propriedades da relação da organização.
  3. Selecione o separador Organização Externa , escreva o nome de domínio federado na caixa Domínios federados da organização externa do Exchange e, em seguida, selecione Adicionar.
  4. Repita o passo 3 para cada domínio que pretende adicionar.
  5. Selecione OK.

Método 2: Utilizar a Shell de Gestão do Exchange

  1. No servidor no local, abra a Shell de Gestão do Exchange.

  2. Configure a relação da organização como uma variável. Por exemplo, execute o seguinte comando:

    $OrgRel = Get-OrganizationRelationship Contoso
    
  3. Adicione os nomes de domínio adicionais que pretende à variável. Por exemplo, execute o seguinte comando:

    $OrgRel.DomainNames += "contoso.com"
    
  4. Atualize a relação da organização com o novo valor de nomes de domínio. Por exemplo, execute o seguinte comando:

    Set-OrganizationRelationship $OrgRel.Name -DomainName $OrgRel.DomainNames
    

Mais informações

Para ajudar a identificar o problema no Microsoft 365, siga estes passos:

  1. Ligue ao Exchange Online através do PowerShell remoto. Para obter mais informações sobre como fazê-lo, veja Ligar ao Exchange Online PowerShell.

  2. Compare o endereço SMTP do utilizador com a relação da organização. To do this, run the following command:

    if ( (Get-OrganizationRelationship).DomainNames -contains (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1]) { write-host "The domain was found" -ForegroundColor Green } else { write-host (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1] "was not found" -ForegroundColor Yellow}
    

    Nota

    Também pode comparar cada domínio listado nos domínios aceites com os nomes de domínio que estão na relação da organização. To do this, run the following command:

    Get-AcceptedDomain | ForEach-Object { if ( (Get-OrganizationRelationship).DomainNames -contains $_.DomainName) { write-host $_.DomainName "was found" -ForegroundColor Green } else { write-host $_.DomainName "was not found" -ForegroundColor Yellow} }
    

Ainda necessita de ajuda? Aceda à Comunidade Microsoft ou os fóruns do Exchange TechNet.

Inicie o guia para resolver este problema.