MED-V URL redirection is not working and no *.mdvurl file is being created

Article ID: 2671040 - View products that this article applies to.
Expand all | Collapse all

Symptoms

Microsoft Enterprise Desktop Virtualization (MED-V 2.0) URL redirection does not work and no temporary URL file *.mdvurl is created in %localappdata%\temp (e.g. C:\Users\username\AppData\Local\Temp\tmpE38B.tmp.mdvurl).

Cause

This can occur if the URLs in the MED-V URL list are not valid.  An example would be a URL that has a trailing * such as:

http://www.msn.com*

Resolution

To resolve this , navigate to the following registry location and remove the trailing from any URL addresses listed.

HKLM\software\microsoft\medv\v2\UserExperience\RedirectUrls

More Information

The only issue relevant to this problem is addressed in the first blog post listed below, in the first section, regarding the creation of the temporary URL file containing the URL to pass the guest via RDPcopy (*.mdvurl). All the other issues that cause URL redirect failures outlined in these two articles do not exist in this scenario.

Understanding and Troubleshooting MED-V v2 URL Redirection
http://blogs.technet.com/b/medv/archive/2011/08/10/understanding-and-troubleshooting-med-v-v2-url-redirection.aspx

GPO Settings That Could Potentially Cause Issues with MED-V Features
http://social.technet.microsoft.com/wiki/contents/articles/5127.aspx#Internet_Explorer_Policies

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2671040 - Last Review: February 13, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Enterprise Desktop Virtualization 2.0
Keywords: 
KB2671040

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com