"Impossibile reimpostare la password dell'utente" quando un amministratore reimposta la password di un utente membro del dominio

Problema

Si consideri lo scenario seguente: un utente non può accedere a un servizio cloud Microsoft, ad esempio Microsoft 365, Microsoft Azure o Microsoft Intune usando un ID utente membro di un dominio del servizio cloud precedentemente configurato per l'accesso Single Sign-On (SSO). In questo scenario, quando un amministratore del servizio cloud tenta di reimpostare la password dell'utente usando il portale del servizio cloud o il modulo di Azure Active Directory per Windows PowerShell, l'amministratore riceve il messaggio di errore seguente:

Impossibile reimpostare la password dell'utente. Riprovare più tardi.

Causa

Questo problema si verifica se l'utente è membro di un dominio del servizio cloud abilitato in precedenza per l'accesso Single Sign-On (SSO) e se l'ID utente non è stato convertito per l'uso dell'autenticazione standard.

Ad esempio, questo problema può verificarsi se è stato usato il cmdlet Windows PowerShell seguente:

convert-MSOLDomainToStandard –skipuserconversion:$true 

Nota

I moduli di PowerShell di Azure AD e MSOnline sono deprecati a partire dal 30 marzo 2024. Per altre informazioni, vedere l'aggiornamento della deprecazione. Dopo questa data, il supporto per questi moduli è limitato all'assistenza per la migrazione a Microsoft Graph PowerShell SDK e alle correzioni per la sicurezza. I moduli deprecati continueranno a funzionare fino al 30 marzo 2025.

È consigliabile eseguire la migrazione a Microsoft Graph PowerShell per interagire con Microsoft Entra ID (in precedenza Azure AD). Per domande frequenti sulla migrazione, vedere Domande frequenti sulla migrazione. Nota: Le versioni 1.0.x di MSOnline potrebbero verificarsi interruzioni dopo il 30 giugno 2024.

Soluzione

Per risolvere questo problema, convertire l'ID utente in un tipo standard (non federato). A tal fine, attenersi alla seguente procedura:

  1. Nella stessa console Windows PowerShell usata per verificare il problema, digitare il cmdlet seguente e quindi premere INVIO:
    Convert-MsolFederatedUser -userprincipalname < user ID > 
    

    Nota

    In questo cmdlet l'ID> utente segnaposto < rappresenta l'ID utente.

  2. Assegnare all'utente una password temporanea. La volta successiva che l'utente accede al servizio cloud, deve modificare la password temporanea prima di poter accedere alle risorse del servizio cloud.

Ulteriori informazioni

Nota

I cmdlet Windows PowerShell in questo articolo richiedono il modulo Azure Active Directory per Windows PowerShell.

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