관리자가 도메인 구성원 사용자의 암호를 재설정할 때 "이 사용자의 암호를 재설정할 수 없습니다."

문제

사용자가 이전에 SSO(Single Sign-On)를 위해 설정된 클라우드 서비스 도메인의 구성원인 사용자 ID를 사용하여 Microsoft 365, Microsoft Azure 또는 Microsoft Intune 같은 Microsoft 클라우드 서비스에 로그인할 수 없습니다. 이 시나리오에서 클라우드 서비스 관리자가 클라우드 서비스 포털 또는 Windows PowerShell Azure Active Directory 모듈을 사용하여 사용자의 암호를 재설정하려고 하면 관리자는 다음 오류 메시지를 받습니다.

이 사용자의 암호를 재설정할 수 없습니다. 나중에 다시 시도합니다.

원인

이 문제는 사용자가 이전에 SSO(Single Sign-On)를 사용하도록 설정된 클라우드 서비스 도메인의 구성원이고 사용자 ID가 표준 인증을 사용하도록 변환되지 않은 경우에 발생합니다.

예를 들어 다음 Windows PowerShell cmdlet을 사용한 경우 이 문제가 발생할 수 있습니다.

convert-MSOLDomainToStandard –skipuserconversion:$true 

참고

Azure AD 및 MSOnline PowerShell 모듈은 2024년 3월 30일부터 더 이상 사용되지 않습니다. 자세한 내용은 사용 중단 업데이트를 참조하세요. 이 날짜 이후에는 이러한 모듈에 대한 지원이 Microsoft Graph PowerShell SDK 및 보안 수정에 대한 마이그레이션 지원으로 제한됩니다. 사용되지 않는 모듈은 2025년 3월 30일까지 계속 작동합니다.

Microsoft Entra ID(이전의 Azure AD)와 상호 작용하려면 Microsoft Graph PowerShell로 마이그레이션하는 것이 좋습니다. 일반적인 마이그레이션 질문은 마이그레이션 FAQ를 참조하세요. 참고: MSOnline 버전 1.0.x는 2024년 6월 30일 이후에 중단이 발생할 수 있습니다.

해결 방법

이 문제를 resolve 사용자 ID를 표준(페더레이션되지 않은) 형식으로 변환합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 문제를 확인하는 데 사용한 것과 동일한 Windows PowerShell 콘솔에서 다음 cmdlet을 입력한 다음 Enter 키를 누릅니다.
    Convert-MsolFederatedUser -userprincipalname < user ID > 
    

    참고

    이 cmdlet에서 자리 표시자 <사용자 ID> 는 사용자 ID를 나타냅니다.

  2. 사용자에게 임시 암호를 제공합니다. 다음에 사용자가 클라우드 서비스에 로그인할 때 클라우드 서비스 리소스에 액세스하려면 임시 암호를 변경해야 합니다.

추가 정보

참고

이 문서의 Windows PowerShell cmdlet에는 Windows PowerShell Azure Active Directory 모듈이 필요합니다.

아직 해결되지 않았습니까? Microsoft 커뮤니티 또는 Microsoft Entra 포럼 웹 사이트로 이동합니다.