Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine la siguiente situación:

  • Tiene una aplicación de terceros que establece un orden incorrecto para la lista de control de acceso de una carpeta Calendario en un buzón.

  • Mueva el buzón que contiene la carpeta Calendario a un Microsoft Exchange Server buzón de correo de 2010. La operación de movimiento se ha completado correctamente.

  • Intenta cambiar el permiso de acceso de la carpeta Calendario mediante una aplicación de Exchange Web Service (EWS) o mediante una aplicación MAPI, como Microsoft Outlook.

En este escenario, no puede cambiar los permisos de acceso de la carpeta Calendario.

Causa

Este problema se produce debido a un error cuando el almacén de Exchange valida las listas de control de acceso canónicos. Por lo tanto, la aplicación MAPI o EWS no puede recuperar la tabla de lista de control de acceso de la carpeta Calendario.

Resolución

Para resolver este problema, instale el siguiente paquete acumulativo de actualizaciones:

2685289 Descripción del paquete acumulativo de actualizaciones 3 para Exchange Server 2010 Service Pack 2 Después de instalar la actualización, puede habilitar la validación de ACL canónicos configurando una clave del
Registro. Para que habilitemos la validación de ACL canónicas para usted, vaya a la sección"Solucionarlopara mí". Si prefiere habilitar la validación de ACL canónicas usted mismo, vaya a la sección"Permítanme corregirlo yomismo".

Solucionarlo en mi lugar



Para habilitar la validación de ACL canónicas automáticamente, haga clic en el botón o vínculo Corregir. A continuación, haga clic en Ejecutar en el cuadro de diálogo Descargar archivo y siga los pasos del Asistente para corregirlo.




Notas

  • Actualización de instalación que se describe en el artículo 2685289 de Microsoft Knowledge Base (KB) antes de ejecutar esta solución Corregirla.

  • Este asistente podría estar solo en inglés. Sin embargo, la solución automática también funciona con versiones de Windows en otros idiomas.

  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarlas en el equipo donde está el problema.


A continuación, vaya a la sección "¿Sesolucionó este problema?".



Lo corrijo yo mismo

Para habilitar la validación de ACL canónicos configurando una clave del Registro, siga estos pasos:

  1. Abra el Editor del Registro. Para ello, haga clic en Inicio, escriba regedit en el cuadro Iniciar búsqueda y, después, presione Entrar.

  2. Busque y, a continuación, haga clic en la siguiente subclave del Registro:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. En el menú Editar, seleccione Nuevoy, a continuación, haga clic en Valor DWORD (32 bits).

  4. Escriba CheckCanonicalACLDuringMove y, después, presione Entrar.

  5. En el menú Editar, haga clic en Modificar.

  6. En el cuadro Datos de valor, escriba 1 y, a continuación, haga clic en Aceptar.

  7. Salga del Editor del Registro.

Una vez habilitada la característica de validación de listas de control de acceso canónico, no podrá mover carpetas en las que la lista de control de acceso no esté en un orden canónico. Además, recibirá el siguiente mensaje de error al intentar mover la carpeta:

Error: MapiExceptionInvalidParameter: No se pueden establecer propiedades en el objeto. (hr=0x80070057, ec=-2147024809)
Contexto de diagnóstico:
Tapa: 55847 EMSMDBPOOL. EcPoolSessionDoRpc llamado [length=267]
Lid: 43559 EMSMDBPOOL. EcPoolSessionDoRpc devuelto [ec=0x0][length=232][latency=0]
Lid: 23226 --- ROP Parse Start ---
Lid: 27962 ROP: ropSetProps [10]
Lid: 17082 ROP Error: 0x80070057
Lid: 3
21921 StoreEc: 0x80070057
Lid: 27962 ROP: ropExtendedError [250]
Tapa: 1494 ---- Remote Context Beg ----
Lid: 26426 ROP: ropSetProps [10]
Tapa: Tienda 21970Ec: 0x8004010F PropTag: 0x668F0040
Lid: 25000
Tapa: 24936
Tapa: 24952
Tapa: 47113
Tapa: 7915 StoreEc: 0x80070057
Lid: 5263 StoreEc: 0x80070057
Tapa: 19768
Tapa: 4559 StoreEc: 0x80070057
26849 Tapa: 1750 ---- Remote Context End ----
Lid:
26849 Lid: 21817 ROP Failure: 0x80070057
Lid: 25761
Lid: 1940 StoreEc: 0x80070057
Lid: 25297
Tapa: 21201 StoreEc: 0x80070057


¿Esta información le ha ayudado a resolver el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.

  • Valoramos sus comentarios. Para enviar comentarios o informar de cualquier problema con esta solución, deje un comentario en el blog "Solucionarlo paramí"o envíenos un correo electrónico.

Más información

Para obtener más información sobre las listas de control de acceso, vaya al siguiente sitio web de Microsoft:

Información general sobre listas de control de accesoPara obtener más información sobre las entradas de control de acceso, vaya al siguiente sitio web de Microsoft:

Información general sobre las entradas de control de accesoPara obtener más información sobre cómo usar Visual Basic y ADsSecurity.dll ordenar aces en una ACL, vaya al siguiente sitio web de Microsoft:

Cómo usar Visual Basic y ADsSecurity.dll ordenar adecuadamente las ACE en una ACL

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×