I backup pianificati non vengono eseguiti sulle unitÓ nastro autonome dopo la sostituzione del supporto

Traduzione articoli Traduzione articoli
Identificativo articolo: 267574 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato precedentemente pubblicato con il codice di riferimento I267574
IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi tuttavia di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire questa operazione, vedere l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe oppure l'argomento relativo al ripristino di una chiave del Registro di sistema in Regedt32.exe.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si pianifica un backup automatico di Windows 2000 utilizzando un'unitÓ nastro autonoma (libreria), il primo processo di backup viene completato correttamente. Quando tuttavia si sostituisce il supporto, il processo di backup successivo non effettua la copia dei file e delle cartelle desiderate. ╚ inoltre possibile che nel file di rapporto del backup venga riportato un messaggio di errore analogo a quelli riportati di seguito:
Impossibile eseguire l'operazione. Non sono disponibili supporti non utilizzati.
Oppure
Impossibile eseguire l'operazione. Impossibile trovare il supporto specificato.

Cause

Questo problema si verifica se allo strumento Gestione archivi rimovibili non viene notificata la sostituzione manuale del supporto nell'unitÓ nastro autonoma (libreria). Gestione archivi rimovibili non effettua il polling delle librerie autonome in modo da rilevare eventuali sostituzioni di supporti. Spetta al programma che riconosce tale servizio richiedere che vengano rilevate le sostituzioni di supporti sulle librerie autonome. Quando si verifica questo problema, il contenuto dei supporti nelle unitÓ nastro viene aggiornato nel database di Gestione archivi rimovibili. Quando il backup di Windows viene eseguito in modo interattivo, la rilevazione delle sostituzioni di supporti nelle unitÓ nastro viene in genere effettuata automaticamente. Quando non Ŕ in corso il backup, non esiste altro meccanismo per richiedere la rilevazione delle sostituzioni di supporti. Il processo di backup non Ŕ quindi in grado di effettuare il montaggio del nuovo nastro, in quanto tale nastro non Ŕ stato riconosciuto da Gestione archivi rimovibili, pertanto il backup non verrÓ eseguito.

Risoluzione

Per risolvere questo problema Ŕ necessario ottenere la versione pi¨ recente del Service Pack per Windows 2000. Per ulteriori informazioni, vedere il seguente articolo della Microsoft Knowledge Base (gli articoli con prefisso "Q" contengono informazioni in inglese):
260910Come ottenere il Service Pack pi¨ recente per Windows 2000
ATTENZIONE: l'errato utilizzo dell'editor del Registro di sistema pu˛ causare seri problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema possano essere risolti. L'utilizzo dell'editor del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Per informazioni su come modificare il Registro di sistema, vedere l'argomento della Guida "Modifica di chiavi e valori" nell'editor del Registro di sistema (Regedit.exe) oppure gli argomenti relativi all'aggiunta e all'eliminazione di informazioni nel Registro di sistema e alla modifica dei dati del Registro di sistema in Regedt32.exe. Si raccomanda di eseguire una copia di backup del Registro di sistema prima di modificarlo. Se si utilizza Windows NT o Windows 2000 occorre inoltre aggiornare il disco di ripristino.
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o successivi):
   Data        Ora        Versione       Dimensione  Nome file
   ---------------------------------------------------------------
   10/24/2000  6:20 PM    5.0.2195.2103  1,162,512   Ntbackup.exe
Per ulteriori informazioni su questa correzione, vedere l'articolo della Knowledge Base riportato di seguito (gli articoli con prefisso "Q" contengono informazioni in inglese):
277701 Ntbackup Cannot Restore from Backup Sets Located on Second Tape



Per risolvere il problema, utilizzare i metodi riportati di seguito finchÚ non sarÓ possibile eseguire backup automatici affidabili. Per alcune unitÓ nastro Ŕ necessario eseguire le operazioni indicate per i metodi 1 e 2 prima di poter ottenere backup affidabili.

Metodo 1

Lasciare una copia del programma di backup in esecuzione in background. In tal modo il programma verificherÓ periodicamente l'eventuale sostituzione del supporto nell'unitÓ nastro e ne permetterÓ il riconoscimento prima dell'effettiva esecuzione del processo di backup pianificato. ╚ possibile utilizzare il programma Srvinstw.exe del Resource Kit di Microsoft Windows 2000 per installare lo strumento Srvany.exe e consentire l'esecuzione di Ntbackup.exe come servizio nascosto.

Installare lo strumento Srvany.exe come servizio

  1. Copiare lo strumento Srvany.exe incluso nel Resource Kit di Windows 2000 nella cartella %SystemRoot%\System32 del computer.
  2. Avviare il programma Srvinstw.exe.
  3. Fare clic su Install a service, quindi scegliere Next.
  4. Fare clic su Local Machine, quindi scegliere Next.
  5. Digitare srvany in Service name, quindi scegliere Next.
  6. Individuare il file %SystemRoot%\System32\Srvany.exe, fare doppio clic sul nome del file, quindi scegliere Next.
  7. Fare clic su Service in it's own process, quindi scegliere Next.
  8. Fare clic su System Account, quindi scegliere Next.
  9. Fare clic su Automatic, quindi scegliere Next.
  10. Scegliere Finish.

Configurare il servizio Srvany per eseguire Ntbackup.exe come servizio

  1. Avviare l'editor del Registro di sistema (Regedt32.exe) per visualizzare la seguente chiave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY
  2. Scegliere Aggiungi chiave dal menu Modifica, digitare Parameters come nome della chiave, quindi scegliere OK.
  3. Selezionare la chiave Parameters, quindi scegliere Aggiungi valore dal menu Modifica. Immettere Application come nome del valore e utilizzare il tipo di dati REG_SZ.

    NOTA: assicurarsi di specificare il percorso completo del file NTBackup.exe. Srvany.exe non carica il programma se si utilizza la variabile %SystemRoot% nel percorso. Ad esempio:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY Application: REG_SZ: C:\Winnt\System32\Ntbackup.exe
  4. Chiudere Regedt32.exe.
  5. Una volta arrestato e riavviato il computer, il backup verrÓ eseguito come servizio in background. Ntbackup.exe dovrebbe risultare in esecuzione e visibile nella scheda Processi di Task Manager e consentire la verifica di eventuali sostituzioni di supporti nelle unitÓ nastro.

Metodo 2

Pianificare il backup utilizzando un file Backup.cmd. ╚ possibile copiare il contenuto del campo per l'esecuzione delle operazioni pianificate e incollarlo nel file batch. ╚ quindi possibile utilizzare il comando di aggiornamento Rsm.exe per consentire il riconoscimento dei supporti sostituiti. Tale comando pu˛ essere aggiunto all'inizio del file batch per il backup:
[backup.cmd]
start /wait rsm.exe refresh /lf"nome_libreria"
Comandi per il backup automatico copiato dall'operazione pianificata. Aggiungere il parametro /um se necessario.


NOTA: eseguire il comando rsm view /tlibrary per estrarre il "nome_libreria" da utilizzare con il comando sopra riportato.

Metodo 3

Pianificare un file batch Backup.cmd contenente un processo di backup breve (una cartella\file), seguito da un backup completo normale. Il primo backup, ovvero quello breve, non verrÓ eseguito in quanto nella libreria nastro non viene rilevato alcun supporto; quello successivo dovrebbe tuttavia essere eseguito in quanto la libreria nastro viene aggiornata in seguito al primo tentativo di backup non riuscito in modo da individuare un supporto utilizzabile.

Metodo 4

Utilizzare l'interfaccia grafica GUI di Gestione archivi rimovibili (Ntmsmgr.msc) per eseguire manualmente un inventario completo sulla libreria nastro dopo la sostituzione dei nastri e prima dell'inizio del successivo processo di backup.

NOTA: se si utilizza il parametro /um di Ntbackup, si consiglia di non utilizzare il parametro /n per etichettare il supporto. Adottare invece la data/ora predefinita come nome e descrizione del backup. In tal modo si eviterÓ che pi¨ nastri siano caratterizzati dallo stesso nome di etichetta e che Gestione archivi rimovibili richieda un montaggio manuale del nastro impedendo la continuazione o il completamento del backup in modalitÓ automatica.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati all'inizio di questo articolo. Questo problema Ŕ stato corretto per la prima volta nel Service Pack 2 per Windows 2000.

Informazioni

Per ulteriori informazioni su come installare contemporaneamente Windows 2000 e le relative correzioni, fare clic sul numero dell'articolo della Knowledge Base riportato di seguito (gli articoli con prefisso "Q" contengono informazioni in inglese):
249149Installazione contemporanea di Microsoft Windows 2000 e delle correzioni rapide di Windows 2000
Ulteriori articoli correlati della Knowledge Base (gli articoli con prefisso "Q" contengono informazioni in inglese):
264604 Scheduled backup jobs may not run as expected
243260 Changed Parameters for Scheduled Backup Job May Not Be Saved

ProprietÓ

Identificativo articolo: 267574 - Ultima modifica: venerdý 31 marzo 2006 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Chiavi:á
kbqfe kbhotfixserver kbbackup kbbug kbfix kbwin2000presp2fix KB267574
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com