As cópias de segurança agendadas falham em unidades de banda autónomas após a mudança de suporte

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IMPORTANTE: Este artigo contém informações sobre a edição do registo. Antes de editar o registo, certifique-se de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar este procedimento, consulte o tópico de ajuda Restaurar o registo no Regedit.exe ou o tópico de ajuda Restaurar uma chave de registo no Regedt32.exe.
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Sintomas

Quando agendar uma cópia de segurança não assistida do Windows 2000 utilizando uma unidade de banda autónoma, a primeira tarefa de cópia de segurança será concluída com êxito. No entanto, depois de mudar o suporte, a próxima tarefa de cópia de segurança agendada não efectua a cópia de segurança da pasta e dos ficheiros pretendidos. Por outro lado, poderá receber uma das seguintes mensagens de erro no ficheiro de registo do relatório de cópia de segurança:
A operação não foi efectuada uma vez que não estava disponível nenhum suporte não utilizado.
- ou -
A operação não foi efectuada uma vez que o suporte especificado não pode ser localizado.

Causa

Este problema pode ocorrer se o gestor de armazenamento amovível (RSM) não for notificado quando o suporte da unidade de banda autónoma for mudado manualmente. O gestor de armazenamento amovível não consulta unidades autónomas à procura de mudanças de suporte, sendo da responsabilidade do programa solicitar que o RSM detecte se o suporte foi mudado em unidades autónomas. Quando este problema ocorrer, o RSM actualiza o conteúdo do suporte das unidades de banda na base de dados do RSM. Normalmente, quando a cópia de segurança do Windows é executada de forma interactiva, solicita que o RSM consulte periodicamente a(s) unidade(s) de banda à procura de mudanças de suporte. Quando a cópia de segurança não está em execução, não existe nenhum mecanismo para solicitar ao RSM que detecte mudanças de suporte. A cópia de segurança não consegue emitir um pedido de montagem da nova banda, dado que o RSM não sabe da existência da nova banda, o que resulta numa falha da tarefa de cópia de segurança.

Resolução

AVISO: A utilização incorrecta do Editor de registo pode causar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.

Para obter informações sobre como editar o registo, consulte o tópico de ajuda Alterar chaves e valores no Editor de registo (Regedit.exe) ou os tópicos de ajuda Adicionar e eliminar informações no registo e Editar informações de registo do Regedt32.exe. De realçar que deve efectuar uma cópia de segurança do registo antes de o editar. Se estiver a utilizar o Windows NT ou o Windows 2000, deverá também actualizar a disquete de reparação de emergência (ERD, Emergency Repair Disk).
A Microsoft tem já disponível uma correcção para este problema; no entanto, esta correcção ainda não foi submetida a todos os testes de regressão e só deve ser aplicada a sistemas que tenham este problema específico. Se não estiver a ser gravemente afectado por este problema específico, a Microsoft recomenda que aguarde pelo próximo service pack do Windows 2000 que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone do suporte técnico da Microsoft, bem como informações sobre os custos do suporte, visite o seguinte endereço na World Wide Web:
http://www.microsoft.com/support/supportnet/overview/overview.asp
A versão inglesa desta correcção deve ter os seguintes atributos de ficheiro (ou posteriores):
   Data        Hora     Versão         Tamanho    Nome do ficheiro     
   -----------------------------------------------------------
   08/05/2000  02:44pm  5.0.2195.2103  1,162,000  Ntbackup.exe



Para resolver este problema, utilize um ou mais dos seguintes métodos de forma incremental até conseguir realizar cópias de segurança não assistidas fiáveis. Repare que algumas unidades de banda requerem os métodos 1 e 2 antes de ser possível realizar cópias de segurança fiáveis.

Método 1

Deixar uma cópia do programa de cópia de segurança a funcionar em segundo plano. A cópia de segurança deverá consultar a unidade de banda periodicamente à procura de mudanças de suporte, ajudando a que as mudanças de suporte sejam reconhecidas antes da execução da tarefa de cópia de segurança agendada propriamente dita. Pode utilizar o programa Srvinstw.exe do Microsoft Windows 2000 Resource Kit para instalar as ferramenta Srvany.exe e, em seguida, permitir que o Ntbackup.exe funcione como um serviço oculto.

Instalar a ferramenta Srvany.exe como um serviço

  1. Copie a ferramenta Srvany.exe incluída no Windows 2000 Resource Kit para a pasta %SystemRoot%\System32 do computador.
  2. Inicie o programa Srvinstw.exe.
  3. Clique em Install a service e, em seguida, clique em Next.
  4. Clique em Local Machine e, em seguida, clique em Next.
  5. Escreva srvany em Service name e, em seguida, clique em Next.
  6. Localize o ficheiro %SystemRoot%\System32\Srvany.exe, clique duas vezes no nome do ficheiro e, em seguida, clique em Next.
  7. Clique em Service in it's own process e, em seguida, clique em Next.
  8. Clique em System Account e, em seguida, clique em Next.
  9. Clique em Automatic e, em seguida, clique em Next.
  10. Clique em Finish.

Configurar o serviço Srvany para executar Ntbackup.exe como um serviço

  1. Inicie o Editor de registo (Regedt32.exe) para ver a seguinte chave no registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY
  2. No menu Editar, clique em Adicionar chave..., escreva Parâmetros para o nome da chave e, em seguida, clique em OK.
  3. Clique para seleccionar a chave Parâmetros e, em seguida, clique em Adicionar valor no menu Editar. Introduza Aplicação para o nome do valor e utilize um tipo de dados REG_SZ.

    NOTA: Certifique-se de que especifica o caminho completo para o ficheiro NTBackup.exe. Srvany.exe não carrega o programa se for utilizada a variável %SystemRoot% no caminho. Por exemplo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY Application: REG_SZ: C:\Winnt\System32\Ntbackup.exe
  4. Saia do Regedt32.exe.
  5. Depois de encerrar e reiniciar o computador, a cópia de segurança é iniciada como um serviço em segundo plano. Ntbackup.exe deverá estar a funcionar e visível no separador Processos do Gestor de tarefas, permitindo que a cópia de segurança consulte as bandas à procura de mudanças de suporte.

Método 2

Agendar a cópia de segurança utilizando um ficheiro Backup.cmd. Pode copiar o conteúdo do campo RUN das tarefas agendadas e, em seguida, copiá-lo para o ficheiro batch. Pode utilizar o comando de actualização Rsm.exe para ajudar a reconhecer os suportes mudados. Esse conteúdo pode ser adicionado ao início do ficheiro batch da cópia de segurança:
[backup.cmd]
start /wait rsm.exe refresh /lf"nome_unidade"
<Comandos da cópia de segurança não assistida copiados da tarefa agendada.....anexe o parâmetro /um se desejar.>


NOTE: Execute o comando rsm view /tlibrary para extrair o "nome_unidade" a utilizar com o comando anterior.

Método 3

Agende um ficheiro batch Backup.cmd que contenha uma tarefa de cópia de segurança breve (uma pasta\ficheiro), seguido de uma cópia de segurança completa normal. A primeira cópia de segurança (breve) falhará porque não será reconhecido nenhum suporte na unidade de banda; no entanto, a cópia de segurança seguinte deverá funcionar, dado que a unidade de banda é actualizada pela tentativa para encontrar suportes utilizáveis da primeira cópia de segurança falhada.

Método 4

Utilizar a GUI do RSM (Ntmsmgr.msc) para realizar manualmente um inventário completo da unidade de banda depois de mudar de banda e antes do início da próxima tarefa de cópia de segurança.

NOTA: Se utilizar o parâmetro /um do Ntbackup, recomenda-se que não utilize o parâmetro /n para identificar o suporte. Ao invés, permita que a cópia de segurança utilize a data/hora predefinida como nome da etiqueta e descrição. Isso elimina a possibilidade de várias bandas terem o mesmo nome de etiqueta, o que pode fazer com que o RSM solicite uma montagem manual da banda e impeça a continuação/conclusão da cópia de segurança não assistida.

Ponto Da Situação

A Microsoft confirma que este problema ocorre nos produtos referidos na secção "A informação contida neste artigo aplica-se a".

Mais Informação

Para obter informações adicionais sobre como instalar as correcções do Windows 2000 e do Windows 2000 ao mesmo tempo, clique no número de artigo existente abaixo para visualizar o artigo na Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes
Artigos relacionados adicionais da Knowledge Base:
264604Tarefas de cópia de segurança agendadas poderão não ser executadas conforme o previsto
243260Os parâmetros de comando alterados para a tarefa de cópia de segurança agendada poderão não ser guardados

Propriedades

Artigo: 267574 - Última revisão: 13 de abril de 2006 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
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