更改后独立磁带驱动器上计划的备份失败

文章翻译 文章翻译
文章编号: 267574 - 查看本文应用于的产品
重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要备份注册表,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Description of the Microsoft Windows Registry
展开全部 | 关闭全部

本文内容

症状

当您使用独立磁带驱动器(库)计划 Windows 2000 无人参予备份时,第一个备份作业可成功完成。然而,在您更换媒体之后,下一个计划的备份作业却不能备份希望的文件夹和文件。而且,您可能会在备份报告日志文件中收到下列错误消息之一:
The operation was not performed because no unused media was available.
-或-
Operation was not performed, because the specified media cannot be found.

原因

在独立磁带驱动器(库)上的媒体被手动更换但没有通知“可移动存储管理器”(RSM) 时,可能会出现此问题。“可移动存储管理器”不轮询独立磁带库以查看是否有媒体更换,请求 RSM 检测独立磁带库中的媒体是否已更换应该是可识别 RSM 的应用程序的责任。发生此问题后,RSM 将更新 RSM 数据库中的磁带驱动器媒体内容。通常,当 Windows 备份以交互方式运行时,它请求 RSM 周期性地轮询磁带驱动器以发现媒体更换情况。当备份未在运行时,便没有了请求 RSM 检测媒体更换情况的机制。备份不能够发出装载新磁带的命令,因为 RSM 不知道新磁带已存在,结果会导致备份作业失败。

解决方案

若要解决此问题,请获取用于 Windows 2000 的最新服务包。有关其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
260910 How to Obtain the Latest Windows 2000 Service Pack
警告:“注册表编辑器”使用不当可造成严重问题,这些问题可能需要重新安装操作系统。Microsoft 不保证能够解决因为“注册表编辑器”使用不当而产生的问题。使用“注册表编辑器”需要您自担风险。
该修复程序的英文版应具有如下文件属性或更新的属性:
   Date        Time     Version        Size       File name
   -----------------------------------------------------------
   10/24/2000  6:20 PM  5.0.2195.2103  1,162,512  Ntbackup.exe
				
有关此即时修复程序的更多信息,请参见以下知识库文章:
277701 Ntbackup Cannot Restore from Backup Sets Located on Second Tape



若要变通解决此问题,请顺次使用下列方法中的一种或多种,直到您能够执行可靠的无人参予备份为止。注意,某些磁带驱动器只有在执行方法 1 和方法 2 之后才能够执行可靠的备份。

方法 1

让一个备份程序副本在后台运行。备份应当周期性地轮询磁带驱动器以发现媒体更换情况,并应该在实际计划的备份作业运行之前帮助报告媒体更换的情况。您可以使用 Microsoft Windows 2000 Resource Kit 中的 Srvinstw.exe 程序来安装 Srvany.exe 工具,然后允许 Ntbackup.exe 作为隐藏的服务运行。

将 Srvany.exe 工具作为一项服务安装

  1. 把 Windows 2000 Resource Kit 中包括的 Srvany.exe 复制到计算机上的 %SystemRoot%\System32 文件夹中。
  2. 启动 Srvinstw.exe 程序。
  3. 单击 Install a service(安装一项服务),然后单击下一步
  4. 单击本机,然后单击下一步
  5. 服务名下键入 srvany,然后单击下一步
  6. 找到 %SystemRoot%\System32\Srvany.exe 文件,双击此文件名,然后单击下一步
  7. 单击 Service in it's own process(在其自已进程中的服务),然后单击下一步
  8. 单击系统帐户,然后单击下一步
  9. 单击自动,然后单击下一步
  10. 单击完成

配置 Srvany 服务以将 Ntbackup.exe 作为一项服务运行

  1. 启动注册表编辑器 (Regedt32.exe) 以查看注册表中的下面这一项:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY
  2. 编辑菜单上,单击添加项...,键入 Parameters 作为此项的名称,然后单击确定
  3. 单击以选中 Parameters 项,然后单击编辑菜单下的添加值。输入 Application 作为数值名称,并使用 REG_SZ 这一数据类型。

    备注:确保指定了 NTBackup.exe 文件的完整路径。如果您在此路径中使用 %SystemRoot% 变量,则 Srvany.exe 不加载该程序。例如:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVANY Application:REG_SZ:C:\Winnt\System32\Ntbackup.exe
  4. 退出 Regedt32.exe。
  5. 在关闭然后重启计算机之后,备份将作为后台服务启动。Ntbackup.exe 应该正在运行并可在“任务管理器”中的“进程”选项卡下看到,并允许备份轮询磁带以发现媒体更换情况。

方法 2

使用 Backup.cmd 文件计划备份。您可以复制计划任务的 RUN 字段中的内容,然后将其粘贴到批处理文件中。您可以使用 Rsm.exe 刷新命令来帮助识别更换的媒体。可以将它添加到备份批处理文件的开头:
[backup.cmd]
start /wait rsm.exe refresh /lf"library_name"
<从计划的任务中复制的无人参予备份的命令……如果愿意可以追加 /um 参数。>


备注:可以运行 rsm view /tlibrary 命令来提取将在上面列出的命令中使用的“library_name”。

方法 3

计划一个 Backup.cmd 批处理文件,让它包含一个短的备份作业(备份一个文件夹\文件),后面跟着一个常规的完全备份。第一个(短)备份会因为在磁带库中没有可识别的媒体而失败,不过第二个备份应该可以运行,这是因为第一个试图寻找可用媒体的失败的备份刷新了磁带库。

方法 4

在更改磁带之后--但在下一次备份作业开始之前--使用 RSM GUI (Ntmsmgr.msc) 对磁带库手动执行列出“完整”清单的操作。

备注:如果您使用 Ntbackup /um 参数,建议您不要使用 /n 参数给媒体加标签。您应允许备份将默认的日期/时间作为标签名称和说明。这就消除了多个磁带具有同一标签名的问题,该问题会导致 RSM 要求执行手动磁带装载,使备份不能在无人参与模式下继续或完成。

状态

Microsoft 已经确认这是在本文开头列出的 Microsoft 产品中存在的问题。 此问题最先是在 Windows 2000 Service Pack 2 中更正的。

更多信息

有关同时安装 Windows 2000 和 Windows 2000 修复程序的其他信息,请单击下面的文章编号,查看 Microsoft 知识库中的相应文章:
249149 安装 Microsoft Windows 2000 和 Windows 2000 即时修复程序
其他相关的知识库文章:
264604 Scheduled backup jobs may not run as expected
243260 Changed Parameters for Scheduled Backup Job May Not Be Saved

属性

文章编号: 267574 - 最后修改: 2006年4月3日 - 修订: 2.1
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
关键字:?
kbbug kbfix kbwin2000presp2fix kbqfe kbbackup kbhotfixserver KB267574
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com