Article ID: 2679568 - View products that this article applies to.
Expand all | Collapse all

Summary

This article provides an overview of the Microsoft Outlook 2010 auto-complete list. In addition to describing the feature, various information and step-by-step instructions are provided for advanced users to manage the list.

More Information

Outlook 2010 maintains an auto-complete list that is used by both the automatic name checking feature and the automatic completion feature. The auto-complete list, also known as the nickname cache, is generated automatically as you send email messages from Outlook. The list contains SMTP addresses, LegacyExchangeDN, and display names for people that you have sent mail to previously. Unlike earlier versions of Outlook that store the auto-complete list in a file on your computer, Outlook 2010 stores the auto-complete list as a hidden message in your primary message store.

Note The auto-complete for Outlook is specific to Outlook and is not shared by Outlook Web App (OWA). OWA will maintain its own auto-complete list.

The following sections provide information about the auto-complete feature.

Limit to the number of entries

In Outlook 2010, the number of entries that you can save in the auto-complete list is 1,000 entries. After you reach this limit, Outlook uses an internal algorithm to determine the best names to remove from the list. It does this based on a usage weighting. Therefore, you may find some names unexpectedly removed from your nickname cache. There are two general approaches you can use to avoid this situation:

  1. You can proactively remove auto-complete list entries that you no longer need. This is the preferred approach. For more information about how to do this, see the section titled "How to remove auto-complete list entries one at a time."
  2. You can increase the limit for the nickname cache. Because this configuration is untested, we do not recommend it. If you have a larger nickname cache, you could also lose a larger number of cached entries if your nickname cache becomes unusable because of corruption. For more information about how to increase the limit, see the section titled "How to change the limit for the auto-complete list."

How to enable the auto-complete feature

To enable the auto-complete feature, follow these steps:
  1. Click File, and then click Options.
  2. Select the Mail tab.
  3. Scroll approximately halfway down until you see Send messages. Make sure that the Use Auto-Complete List to suggest names when typing in the To, Cc, and Bcc lines box is checked (The screen shot for this step is listed below).

    Collapse this imageExpand this image
    The screen shot for this step

How to import .nk2 files into Outlook

For more information, click the following article number to view the article in the Microsoft Knowledge Base:  
980542 How to import .nk2 files into Outlook 2010

How to export the auto-complete mailbox message

  1. Exit Outlook, and then close Outlook Web Access or Outlook Web App (OWA) on all workstations that are connected to your mailbox.
  2. Download and install MFCMAPI from http://mfcmapi.codeplex.com.
  3. Run mfcmapi.exe.
  4. On the Session menu, click Logon.
  5. If you are prompted for a profile, select the desired profile name, and then click OK.
  6. In the top pane, locate the line that corresponds to your mailbox, and then double-click it.
  7. In the left-side navigation pane, expand Root Container, and then expand Top of Information Store or IPM_SUBTREE.
  8. Right-click the Inbox folder, and then click Open Associated Content Table. This action opens a new MFCMAPI window that contains various properties.
  9. Under the Subject column, right-click the item that has the subject IPM.Configuration.Autocomplete, and then click Export Message. This action opens the Save Message To File window.
  10. In the drop-down list, select MSG file (UNICODE), and then click OK.
  11. Select a folder location to which you want to save the message, and then click Save. Note this location.

How to import the auto-complete mailbox message

  1. Exit Outlook, and then close Outlook Web Access or Outlook Web App (OWA) on all workstations that are connected to your mailbox.
  2. Download and install MFCMAPI from http://mfcmapi.codeplex.com
  3. Run mfcmapi.exe.
  4. On the Session menu, click Logon.
  5. If you are prompted for a profile, select the desired profile name, and then click OK.
  6. In the top pane, locate the line that corresponds to your mailbox, and then double-click it.
  7. In the left-side navigation pane, expand Root - Mailbox, and then expand Top of Information Store or IPM_SUBTREE.
  8. Right-click the Inbox folder, and then click Open Associated Content Table. This action opens a new MFCMAPI window that contains various properties.
  9. To avoid duplicate entries, you must delete the existing auto-complete message.

    Note Before you delete the IPM.Configuration.Autocomplete message, you must export the message by using the steps in the "How to export the Auto-Complete cache" section.

    To delete the existing auto-complete message, follow these steps:

    1. In the Subject column, locate the item that has the subject IPM.Configuration.Autocomplete.
    2. Right-click the item, and then click Delete message. This opens the Delete Item window.
    3. In the drop-down list, select Permanent deletion (deletes to deleted item retention if supported), and then click OK.
  10. On the Folder menu, click Import, and then click From MSG.
  11. Locate the .msg file that you created in step 11 of the "How to Export the Auto-Complete List" section, and then click OK.
  12. In the Load MSG window that appears, select Load message into current folder in the Load style list, and then click OK.
The auto-complete information is imported from the IPM.Configuration.Autocomplete_<hexadecimal code>.msg, where the placeholder<hexadecimal code> represents a long string of numbers and letters.

How to remove auto-complete list entries one at a time

To remove entries from the auto-complete cache one entry at a time, follow these steps:
  1. Open a new email message.
  2. Type the first few characters of the auto-complete entry that you want to remove.
  3. When the entry appears in the list of suggested names, move your mouse pointer over the name until it becomes highlighted, but do not click the name.
  4. When the “X” icon appears next to the highlighted name, click X to remove the name from the list, or press the Delete key on the keyboard.

How to clear the entire auto-complete list

Method 1
  1. Open Outlook.
  2. On the File tab, click Options (The screen shot for this step is listed below).

    Collapse this imageExpand this image
    The screen shot for this step

  3. Click the Mail tab.
  4. Under Send Messages, click Empty Auto-Complete List (The screen shot for this step is listed below).

    Collapse this imageExpand this image
    The screen shot for this step

  5. Click Yes.

Method 2
Start Outlook by using the /CleanAutoCompleteCache switch. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. ype Outlook.exe /CleanAutoCompleteCache.

    Note If Outlook is not installed in the default location, you must point to the path of Outlook.exe.

Issues with the auto-complete cache

This section describes known issues that can occur with the auto-complete cache.
Entries are not saved
The auto-complete cache can become corrupted over time and may not save new entries. If this happens, you can try to remove individual entries from the list. To do this, see the section titled "How to remove auto-complete list entries one at a time." If that does not resolve the issue, the entire auto-complete list can be reset. To do this, see the section titled "How to clear the entire auto-complete list."

How to change the limit for the auto-complete list

Because this configuration is untested, it is not recommended. If you have a larger auto-complete list, you could also lose a larger number of cached entries if your auto-complete cache becomes unusable because of corruption. Given this disclaimer, you can use the following registry data to increase the auto-complete list limit in Outlook.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows
  1. Exit Outlook.
  2. Start Registry Editor.
    • In Windows 8.x, press the Windows key, type regedit and then press Enter.
    • In Windows 7 and Windows Vista, click Start, type regedit in the Start Search box, and then press Enter.
  3. Locate and then select the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoNameCheck

  4. On the Edit menu, point to New, and then click DWORD value.
  5. Type MaxNickNames, and then press Enter.
  6. On the Edit menu, click Modify.
  7. Type the new value for the limit, and then click OK.

    Notes
    • Make sure that you type the number in decimal form. That is the correct form in which to type the number.
    • Try increasing the limit by only a marginal amount to test the new limit. For example, to create a 20 percent increase in the limit in Outlook 2010, you would specify 1200 for the MaxNickNames value.
  8. Exit Registry Editor.
  9. Start Outlook.
Note The MaxNickNames registry value merely specifies the nondefault limit. Therefore, you can also use this value to lower the limit of the nickname cache.

Properties

Article ID: 2679568 - Last Review: September 4, 2013 - Revision: 4.0
Applies to
  • Microsoft Outlook 2010
Keywords: 
KB2679568

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com