Informazioni sull'elenco di completamento automatico di Outlook 2010

Traduzione articoli Traduzione articoli
Identificativo articolo: 2679568 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sommario

In questo articolo viene fornita una panoramica dell'elenco di completamento automatico di Microsoft Outlook 2010.Oltre a descrivere la funzionalitÓ, varie informazioni e istruzioni dettagliate sono destinate agli utenti esperti di gestire l'elenco.

Ulteriori informazioni

Outlook 2010 mantiene un elenco di completamento automatico viene utilizzato da entrambi controllo automatico del nome funzione e la funzionalitÓ di completamento automatico. L'elenco di completamento automatico, noto anche come cache del nome alternativo, viene generato automaticamente, si inviano messaggi di posta elettronica da Outlook. L'elenco contiene gli indirizzi SMTP, LegacyExchangeDN e i nomi visualizzati per gli utenti che hai inviato la posta in precedenza. A differenza delle versioni precedenti di Outlook che consentono di memorizzano l'elenco di completamento automatico in un file nel computer in uso, Outlook 2010 memorizza l'elenco di completamento automatico in un messaggio nascosto nell'archivio messaggio principale.

Nota. Il completamento automatico per Outlook Ŕ specifico di Outlook e non Ŕ condiviso da Outlook Web App (OWA). OWA manterrÓ il proprio elenco di completamento automatico.

Nelle sezioni seguenti vengono forniscono informazioni sulle funzionalitÓ di completamento automatico.

Limitare il numero di voci

In Outlook 2010, il numero di voci che Ŕ possibile salvare nell'elenco di completamento automatico Ŕ 1.000 voci. Dopo che si raggiunge questo limite, Outlook utilizza un algoritmo interno per determinare i nomi dei migliori da rimuovere dall'elenco. Questa operazione viene eseguita in base a un peso di utilizzo. Pertanto, Ŕ probabile che alcuni nomi inaspettatamente rimozione dalla cache dei nomi alternativi. Esistono due approcci generali, che Ŕ possibile utilizzare per evitare questa situazione:

  1. ╚ possibile rimuovere in modo proattivo le voci dell'elenco di completamento automatico che non Ŕ pi¨ necessario. Questo Ŕ l'approccio consigliato. Per ulteriori informazioni, vedere la sezione intitolata "Come rimuovere voci dell'elenco di completamento automatico di uno alla volta".
  2. Si canincrease il limite per la cache dei nomi alternativi. PoichÚ questa configurazione viene testata, non consigliabile. Se si dispone di una cache del nome alternativo pi¨ grande, si potrebbe perdere anche un maggior numero di voci memorizzate nella cache se la cache dei nomi alternativi diventa inutilizzabile a causa di danneggiamento. Per ulteriori informazioni su come aumentare il limite, vedere la sezione intitolata "Come modificare il limite per l'elenco di completamento automatico".

Come attivare la funzionalitÓ Completamento automatico

Per attivare la funzionalitÓ Completamento automatico, attenersi alla seguente procedura:
  1. Fare clic su Filee quindi fare clic su Opzioni.
  2. Selezionare la scheda posta elettronica .
  3. Scorri fino a circa metÓ finchÚ non viene visualizzato l'invio di messaggi. Assicurarsi che sia selezionata la casella Utilizza elenco completamento automatico per suggerire nomi quando si digita in a, Cc e Ccn righe(la schermata per questo passaggio Ŕ riportato di seguito).

    Riduci l'immagineEspandi l'immagine
    La schermata per questo passaggio

Come importare file nk2 in Outlook

Per ulteriori informazioni, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
980542 Come importare file nk2 in Outlook 2010

Come esportare il messaggio di completamento automatico delle cassette postali

  1. Chiudere Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) in tutte le workstation connesse alla cassetta postale.
  2. Scaricare e installare MFCMAPI da http://MFCMAPI.codeplex.com.
  3. Eseguire mfcmapi.exe.
  4. Dal menu di sessione , fare clic su accesso.
  5. Se richiesto un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.
  6. Nel riquadro superiore, individuare la riga che corrisponde alla cassetta postale e quindi fare doppio clic su esso.
  7. Nel riquadro di spostamento a sinistra, espandere il Contenitore radicee quindi Parte superiore dell'archivio informazioni o IPM_SUBTREE.
  8. Pulsante destro del mouse nella cartella posta in arrivo e quindi scegliere Apri tabella di contenuto associato. Questa azione apre una nuova finestra MFCMAPI contenente diverse proprietÓ.
  9. Nella colonna argomento destro l'elemento associato all'oggetto IPM.Configuration.Autocomplete, quindi fare clic su Esporta messaggi. Questa azione viene visualizzata la finestra di Messaggio Salva su File .
  10. Nell'elenco a discesa, selezionare file MSG (UNICODE)e quindi fare clic su OK.
  11. Selezionare un percorso di cartella a cui si desidera salvare il messaggio e quindi fare clic su Salva. Prendere nota del percorso.

Come importare il messaggio di completamento automatico delle cassette postali

  1. Chiudere Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) in tutte le workstation connesse alla cassetta postale.
  2. Scaricare e installare MFCMAPI da http://MFCMAPI.codeplex.com
  3. Eseguire mfcmapi.exe.
  4. Dal menu di sessione , fare clic su accesso.
  5. Se richiesto un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.
  6. Nel riquadro superiore, individuare la riga che corrisponde alla cassetta postale e quindi fare doppio clic su esso.
  7. Nel riquadro di spostamento a sinistra, espandere la radice - cassetta postalee quindi Parte superiore dell'archivio informazioni o IPM_SUBTREE.
  8. Pulsante destro del mouse nella cartella posta in arrivo e quindi scegliere Apri tabella di contenuto associato. Questa azione apre una nuova finestra MFCMAPI contenente diverse proprietÓ.
  9. Per evitare voci duplicate, Ŕ necessario eliminare il messaggio di completamento automatico esistente.

    Nota. Prima di eliminare il IPM.Configuration.Autocomplete messaggio, Ŕ necessario esportare il messaggio utilizzando la procedura descritta nella sezione "esportare la cache di completamento automatico".

    Per eliminare il messaggio di completamento automatico, attenersi alla seguente procedura:

    1. Nella colonna argomento , individuare l'elemento associato all'oggetto IPM.Configuration.Autocomplete.
    2. L'elemento e quindi fare clic su Elimina messaggio. VerrÓ visualizzata la finestra Elimina elemento .
    3. Nell'elenco a discesa, selezionare l'eliminazione permanente (eliminazioni di mantenimento degli elementi eliminati, se supportato)e quindi fare clic su OK.
  10. Dal menu della cartella , fare clic su Importae quindi Da MSG.
  11. Individuare il file con estensione msg creato nel passaggio 11 della sezione "Come per esportare l'elenco di completamento automatico" e quindi fare clic su OK.
  12. Nella finestra Carico MSG selezionare Carica messaggio nella cartella corrente nell'elenco stile di carico e quindi fare clic su OK.
Le informazioni di completamento automatico vengono importate dall'IPM.Configuration.Autocomplete_<hexadecimal code=""></hexadecimal>. MSG, dove il segnaposto<hexadecimal code=""> </hexadecimal> rappresenta una lunga stringa di numeri e lettere.

Come rimuovere le voci di elenco di completamento automatico una alla volta

Per rimuovere voci da una voce della cache di completamento automatico in un momento, attenersi alla seguente procedura:
  1. Aprire un nuovo messaggio di posta elettronica.
  2. Digitare i primi caratteri della voce del completamento automatico che si desidera rimuovere.
  3. Quando viene visualizzata la voce nell'elenco dei nomi, spostare il puntatore del mouse sul nome fino a quando non viene evidenziato, ma non scegliere il nome.
  4. Quando compare l'icona di "X" accanto al nome evidenziato, fare clic su X per rimuovere il nome dall'elenco oppure premere il tasto CANC sulla tastiera.

Come cancellare l'intero elenco di completamento automatico

Metodo 1
  1. Aprire Outlook.
  2. Nella scheda File , fare clic su Opzioni (la schermata per questo passaggio Ŕ riportata di seguito).

    Riduci l'immagineEspandi l'immagine
    La schermata per questo passaggio

  3. Fare clic sulla scheda posta .
  4. InInvio messaggi, fare clic suElenco di completamento automatico vuoto (la schermata per questo passaggio Ŕ riportata di seguito).

    Riduci l'immagineEspandi l'immagine
    La schermata per questo passaggio

  5. Fare clic su .

Metodo 2
Avviare Outlook utilizzando l'opzione /CleanAutoCompleteCache. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Start, quindi su Esegui
  2. ipoOutlook.exe /CleanAutoCompleteCache.

    Nota. Se Outlook non Ŕ installato nel percorso predefinito, deve puntare al percorso di Outlook.exe.

Problemi con la cache di completamento automatico

In questa sezione vengono descritti problemi noti che possono verificarsi con la cache di completamento automatico.
Le voci non vengono salvate.
La cache di completamento automatico pu˛ danneggiarsi nel tempo e non pu˛ salvare le nuove voci. In questo caso, Ŕ possibile provare a rimuovere singole voci dall'elenco. Per eseguire questa operazione, vedere la sezione intitolata "Come rimuovere voci dell'elenco di completamento automatico di uno alla volta". Se il problema persiste, Ŕ possibile reimpostare l'intero elenco di completamento automatico. Per eseguire questa operazione, vedere la sezione intitolata "Come cancellare l'intero elenco di completamento automatico".

Come modificare il limite per l'elenco di completamento automatico

PoichÚ questa configurazione viene testata, non Ŕ consigliato. Se si dispone di un elenco di completamento automatico pi¨ grande, si potrebbe perdere anche un maggior numero di voci memorizzate nella cache se la cache di completamento automatico diventa inutilizzabile a causa di danneggiamento. Data questa limitazione di responsabilitÓ, Ŕ possibile utilizzare i seguenti dati del Registro di sistema per aumentare il limite di elenco di completamento automatico in Outlook.

Importante Questa sezione, metodo o attivitÓ contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero verificarsi seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo, Ŕ possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows
  1. Uscire da Outlook.
  2. Avviare l'Editor del Registro di sistema.
    • In Windows 8. x, premere Windows chiave, digitare regedit e quindi preme INVIO.
    • In Windows 7 e Windows Vista, fare clic su Start, tipo Regedit Nella casella Inizia ricerca e quindi premere INVIO.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoNameCheck

  4. Dal menu Modifica , scegliere Nuovoe quindi fare clic su valore DWORD.
  5. Tipo MaxNickNames, quindi premere INVIO.
  6. Dal menu Modifica , fare clic su Modifica.
  7. Digitare il nuovo valore per il limite e quindi fare clic su OK.

    Note
    • Assicurarsi di digitare il numero decimal modulo. Che Ŕ la forma corretta in cui digitare il numero.
    • Provare ad aumentare il limite di solo una quantitÓ marginale per testare il nuovo limite. Ad esempio, per creare un aumento del 20% entro il limite in Outlook 2010, specificare 1200 per il valore di MaxNickNames.
  8. Uscire dall'Editor del Registro di sistema.
  9. Avviare Outlook.
Nota. Il valore del Registro di sistema MaxNickNames solo di specificare il limite non predefinito. Pertanto, Ŕ anche possibile utilizzare questo valore per ridurre il limite della cache del nome alternativo.

ProprietÓ

Identificativo articolo: 2679568 - Ultima modifica: sabato 15 febbraio 2014 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Outlook 2010
Chiavi:á
kbmt KB2679568 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2679568
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com