Outlook 2010 の自動補完リストに関する情報

文書翻訳 文書翻訳
文書番号: 2679568 - 対象製品
すべて展開する | すべて折りたたむ

概要

この資料では、Microsoft Outlook 2010 のオートコンプリート リストの概要を示します。他の機能を説明する、リストを管理する高度なユーザーのさまざまな情報と手順が提供されます。

詳細については

Outlook 2010 は、両方の名前の自動チェックの機能と自動補完機能によって使用される、自動補完リストを保持します。オートコンプリートの一覧、ニックネーム キャッシュとも呼ばれますが Outlook から電子メール メッセージを送信するように自動的に生成されます。リストには、SMTP アドレス、LegacyExchangeDN、および以前にメールを送信したユーザーの表示名が含まれています。以前のバージョンの Outlook 自動補完リストをコンピューター上のファイルに格納されているとは異なり Outlook 2010 は、プライマリ メッセージ ストア内の非表示のメッセージとして、自動補完のリストを格納します。

メモ Outlook の自動完了し、Outlook に固有の Outlook Web App (OWA) が共有されていません。OWA では、独自の自動補完のリストを維持します。

次のセクションでは、自動補完機能についての情報を提供します。

エントリの数を制限します。

Outlook 2010 では、自動補完リストに保存できるエントリの数は 1,000 のエントリです。この制限に達すると、ベストのリストから削除するのに名前を決定する内部アルゴリズムが使用されます。これは、使用法の重み付けに基づきます。そのため、いくつかの名前が予期せず、ニックネームのキャッシュから削除される場合もあります。この状況を回避するを使用することができます 2 つの一般的な方法があります。

  1. 事前に不要なオートコンプリート リスト エントリを削除できます。これは、推奨されるアプローチです。これを行う方法の詳細については、方法を時に自動補完リストのエントリを 1 つを削除する。」というタイトルのセクションを参照してください。
  2. Canincrease、ニックネームのキャッシュを制限します。この構成はテストされていない、ためお勧めしません。ニックネーム キャッシュ サイズを増やす場合は、多数のキャッシュ エントリのニックネーム キャッシュを破損により使用できなくなった場合も失うがあります。制限値を大きく方法の詳細については、「自動補完リストの制限を変更する方法。」というタイトルのセクションを参照してください。

オートコンプリート機能を有効にする方法

オートコンプリート機能を有効にするには以下の手順を実行します。
  1. ファイルをクリックし、[オプション] をクリックします。
  2. [メール] タブを選択します。
  3. 約半分まで下にスクロールしてメッセージを送信するを参照してください。行、[cc]、および [bcc] の入力時に名前の候補をオートコンプリートの一覧の使用] ボックスがオンになっていることを確認します (この手順は、次に示すは、ショットの画面)。

    元に戻す画像を拡大する
    ここのスクリーン ショット

.Nk2 ファイルを Outlook にインポートする方法

詳細については、以下の資料番号をクリックして、マイクロソフト サポート技術情報資料を参照してください。
980542 Outlook 2010 に .nk2 ファイルをインポートする方法

メールボックスの自動完了のメッセージをエクスポートする方法

  1. Outlook を終了して、Outlook Web Access または Outlook Web App (OWA) のメールボックスに接続されているすべてのワークステーション上で閉じます。
  2. ダウンロードし、インストールから MFCMAPI http://mfcmapi.codeplex.com.
  3. Mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルのプロンプトが表示されたら、該当するプロファイルの名前を選択し、[ OK] をクリックします。
  6. 上部ウィンドウで、自分のメールボックスに対応する行を検索、ダブルクリック
  7. 左側のナビゲーション ウィンドウで、ルート コンテナーを展開し、し、上のインフォメーション ストアまたはIPM_SUBTREEを展開します。
  8. [受信トレイ] フォルダーを右クリックし、関連のコンテンツ テーブルを開く] をクリックします。この操作は、さまざまなプロパティを含む新しい MFCMAPI ウィンドウを開きます。
  9. [件名] 列で、IPM のの主題を持っている項目] を右クリックします。Configuration.Autocompleteメッセージのエクスポートをクリックします。このアクション ウィンドウが開き、メッセージをファイルに保存します。
  10. ドロップダウン] ボックスの一覧でMSG ファイル (を UNICODE)] を選択]をクリック。
  11. 、メッセージを保存するフォルダーの場所を選択し、[保存] をクリックします。この場所に注意してください。

メールボックスの自動完了のメッセージをインポートする方法

  1. Outlook を終了して、Outlook Web Access または Outlook Web App (OWA) のメールボックスに接続されているすべてのワークステーション上で閉じます。
  2. ダウンロードし、インストールから MFCMAPI http://mfcmapi.codeplex.com
  3. Mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルのプロンプトが表示されたら、該当するプロファイルの名前を選択し、[ OK] をクリックします。
  6. 上部ウィンドウで、自分のメールボックスに対応する行を検索、ダブルクリック
  7. 左側のナビゲーション ウィンドウで、ルート - メールボックスを展開し、し、上のインフォメーション ストアまたはIPM_SUBTREEを展開します。
  8. [受信トレイ] フォルダーを右クリックし、関連のコンテンツ テーブルを開く] をクリックします。この操作は、さまざまなプロパティを含む新しい MFCMAPI ウィンドウを開きます。
  9. エントリの重複を回避するのには、既存の自動完了のメッセージを削除してください。

    メモ IPM のを削除する前に。Configuration.Autocompleteメッセージ、「オートコンプリートのキャッシュをエクスポートする方法」セクションで手順を実行してメッセージをエクスポートする必要があります。

    オートコンプリートの既存メッセージを削除するには以下の手順を実行します。

    1. [件名] 列で、件名、IPM のを持っている項目を探します。Configuration.Autocomplete
    2. 項目を右クリックし、 メッセージを削除します。.これは、アイテムの削除] ウィンドウが開きます。
    3. ドロップダウン] ボックスの一覧で、[完全に削除 (サポートされている場合は、削除済みアイテムの保存期間を削除)を [ OK] をクリックします。
  10. [フォルダー ] メニューで、[インポート] をクリックをクリックからのメッセージ
  11. .Msg ファイルの方法をエクスポート、オートコンプリートの一覧] セクションで、手順 11 で作成したを見つけてし、[ OK] をクリックします。
  12. 読み込みメッセージウィンドウが表示されたら、ロード スタイルの一覧で、現在のフォルダーにメッセージを負荷を選択して、[ OK] をクリックしてください
オートコンプリートの情報は、IPM からインポートされます。Configuration.Autocomplete_<hexadecimal code=""></hexadecimal>.msg、場所のプレース ホルダー<hexadecimal code=""></hexadecimal>の文字と数字の長い文字列を表します。

時、自動補完リストのエントリを 1 つを削除する方法

一度に 1 つの自動補完のキャッシュ エントリからエントリを削除、以下の手順を実行します。
  1. 新しい電子メール メッセージを開きます。
  2. オートコンプリートのエントリを削除することの最初の数文字を入力します。
  3. エントリが、リストの提示名、名前が強調表示されているまで、マウスのポインターが移動されますが、名前をクリックしてしないでください。
  4. 強調表示されている名前の横に"X"アイコンが表示されたら、 Xボックスの一覧から名前を削除する] をクリックします。 または、キーボードのDelキーを押します。

オートコンプリートの一覧全体をクリアする方法

方法 1
  1. Outlook を開きます。
  2. [ファイル] タブのスクリーン ショットこの手順は以下の一覧のオプションをクリックします。

    元に戻す画像を拡大する
    ここのスクリーン ショット

  3. [メール] タブをクリックします。
  4. [メッセージの送信空のオートコンプリートの一覧(下のスクリーン ショットここは表示されます) をクリックします。

    元に戻す画像を拡大する
    ここのスクリーン ショット

  5. [はい]をクリックします。

方法 2
/CleanAutoCompleteCache スイッチを使用して Outlook を起動します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. Outlook.exe の/CleanAutoCompleteCacheの種類。

    メモ Outlook が既定の場所にインストールされていない場合は、Outlook.exe のパスを指す必要があります。

オートコンプリート キャッシュに関する問題

このセクションでは、オートコンプリート キャッシュで発生する可能性のある既知の問題について説明します。
エントリが保存されません。
オートコンプリート キャッシュが時間の経過とともに破損し、新しいエントリを保存できません可能性があります。この場合、リストから個々 のエントリを削除しようことができます。これには、削除する方法」自動補完リストのエントリを 1 つずつです。「というタイトル セクションを参照してください。、問題が解決しない場合は、自動補完リストの全体をリセットできます。これには、「オートコンプリートの一覧全体をクリアする方法。」というタイトル セクションを参照してください。

自動補完リストの制限を変更する方法

この構成はテストされていない、ためにお勧めできませんです。なら、大規模な自動補完のリストは、多数のキャッシュ エントリのオートコンプリートのキャッシュを破損により使用できなくなった場合も失うがあります。この免責事項を指定して、Outlook のオートコンプリート リストの制限値を大きくには、次のレジストリ データを使用できます。

重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、この手順を慎重に実行するようにしてください。万一に備えて、編集の前にレジストリをバックアップしてください。そうすることで、問題が発生した場合でもレジストリを復元できます。レジストリをバックアップおよび復元する方法の詳細については、以下のサポート技術情報番号をクリックしてください。

322756 Windows でレジストリをバックアップおよび復元する方法
  1. Outlook を終了します。
  2. レジストリ エディターを起動します。
    • Windows の 8.x、Windows キー、 regeditと入力し、 Enterキーを押して、キーを押します。
    • Windows 7 および Windows Vista では、[スタート] をクリックしての種類 regedit検索の開始ボックス、およびEnterキーを押します。
  3. 次のレジストリ サブキーを選択します。

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoNameCheck

  4. [編集] メニューで、新規作成をポイントし、[ DWORD 値] をクリックします。
  5. タイプ MaxNickNames、し、 Enterキーを押します。
  6. [編集] メニューの [変更を] をクリックします。
  7. 制限の新しい値を入力し、[ OK] をクリックします。

    注:
    • Decimal フォームで番号を入力することを確認します。正しい番号を入力するためのフォームです。
    • 新しい制限をテストする時間が最低限の制限を増やしてください。たとえば、20% の増加で、Outlook 2010 で制限を作成するのには指定しました。 1200 MaxNickNames の値。
  8. レジストリ エディターを終了します。
  9. Outlook を起動します。
メモ だけで、MaxNickNames のレジストリ値は、既定以外の制限を指定します。したがって、ニックネーム キャッシュの制限を低減この値を使用することもできます。

プロパティ

文書番号: 2679568 - 最終更新日: 2014年2月15日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
キーワード:?
kbmt KB2679568 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:2679568
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com