I client di Exchange Server 5.5 sembrano bloccarsi quando l'archivio informazioni interroga la directory

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256986Descrizione del Registro di sistema di Microsoft Windows
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Sintomi

Pu˛ sembrare che il processo client ha smesso di rispondere (si blocca) e viene visualizzato il cursore a forma di clessidra per lunghi periodi, ma il processo infine restituisce il controllo utente. In genere, questo problema si ripete in tutto il giorno, spesso durante i cicli di replica e solo quando il sito Ŕ sotto carico.

Misurato da Performance Monitor, l'archivio informazioni si blocca, accompagnato da picchi nel contatore Richieste RPC , mentre il client RPC scrittura di byte al secondo contatore rimane a zero. Chiamata elevata di procedura remota (RPC) richiesta da sole o solo byte di scrittura minime non correlate a questo problema. Solo quando un server si verifica entrambe contemporaneamente potrebbe essere questo il problema.

Questo comportamento Ŕ stato osservato solo all'interno di organizzazioni di Exchange Server con centinaia di siti.

Cause

Organizzazioni di Exchange Server di grandi dimensioni con centinaia di siti spesso richiedono alcuni minuti per completare una ricerca della directory dall'archivio informazioni. Quando alcuni oggetti vengono modificate nella directory, pu˛ essere avviata una notifica per indicare l'archivio informazioni per la ricostruzione ad esempio elenchi di indirizzi di sito o elenchi di dominio SMTP validi.

Se memorizzano le informazioni Ŕ molto occupati cercando nella directory qualcosa e viene notificati che un oggetto nella directory che Ŕ stato guardando Ŕ stato modificato, l'archivio informazioni potrebbe restituire un errore DS_E_TOO_LATE, il cui aspetto Ŕ simile al seguente nel registro eventi applicazioni:
ID evento: 7201
Origine: MSExchangeIS
Tipo: avviso
Categoria: generale
Descrizione: Thread di background FDsWaitTask verificato un problema.
Codice di errore DS_E_TOO_LATE
Risposta dell'archivio informazioni a questo errore Ŕ ricostruire l'elenco di oggetti che Ŕ stato ricerca contro. In questi casi, l'archivio informazioni utilizza accesso serializzato per leggere dalla directory, che aumenta il slowness. Quando il server Ŕ giÓ occupato tenta di gestire le richieste client (alcuni dei quali sono in probabilmente attesa per la ricerca alla fine), i client sembrano bloccarsi perchÚ in attesa per le chiamate RPC a fine. Si noti che ogni aggiornamento possibile imporre l'archivio informazioni per cercare nella directory informazioni, in modo che alcuni minuti di tempo apparente blocco pu˛ comportare una stringa lunga degli aggiornamenti.

Naturalmente, i client producono spesso il cursore a forma di clessidra per molti motivi completamente non correlati a questo problema. In questo caso il client Ŕ in attesa di risposta dal server e utilizza tempo di CPU o nulle sul computer client.

Risoluzione

Per risolvere il problema, ottenere il service pack pi¨ recente di Exchange Server 5.5. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
191014Come ottenere il service pack pi¨ recente per Exchange Server 5.5
Questo problema Ŕ peggio quando l'attributo di Nome Directory non Ŕ indicizzato. Quando l'attributo di Nome Directory non Ŕ indicizzato, le prestazioni di alcune ricerche possono risentirne negativamente.

Per indicizzare l'attributo del Nome della directory , attenersi alla seguente procedura.

avviso Se si utilizza la in modo non corretto la modalitÓ raw del programma di amministrazione di Exchange Server ( admin/r ), potrebbero verificarsi problemi gravi che potrebbe essere necessario reinstallare Microsoft Windows NT Server, Microsoft Exchange Server o entrambi. Microsoft non garantisce che i problemi derivanti dall'errato utilizzo del modalitÓ raw possano essere risolti. L'utilizzo di tale modalitÓ Ŕ a rischio e pericolo dell'utente.
  1. Avviare il programma di amministrazione di Exchange in modalitÓ raw. Per effettuare questa operazione, Ŕ possibile utilizzare il comando Admin /r al prompt dei comandi.
  2. Nel menu Visualizza , fare clic su Raw Directory .
  3. Nel riquadro sinistro, fare clic su schema .
  4. Nel riquadro di destra fare doppio clic sul Nome della directory e scegliere .
  5. Nell'elenco degli attributi di oggetto , fare clic su Flag di ricerca .

    Se il valore dell'attributo Flags di ricerca Ŕ impostato su 0 , modificare il valore su 1 .
  6. Riavviare il servizio directory di Microsoft Exchange.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
184823Indice dello schema non valido dopo l'aggiornamento di Exchange 5.5 4.0 per

Workaround

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.
╚ possibile ridurre o attenuazione l'effetto di questo problema aumentando il tempo che il server testa di ponte di replica directory attende prima di notifica a altri server del sito di modifiche. ╚ possibile aumentare il tempo nell'esempio che segue la chiave del Registro di sistema:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDS\Parameters\Replicator notify pause after modify (secs)
Il valore predefinito per questa chiave Ŕ 0x12c o 300 secondi (5 minuti). Se si aumenta tale valore per la durata di pi¨ lunga serie di blocchi, Ŕ possibile ridurre l'impatto del problema.

La strategia qui si Ŕ per imporre la testa di ponte replica directory tenere aggiornamenti pi¨ tempo. Questo riduce la possibilitÓ che una serie di aggiornamenti di randomizing verrÓ colata nel sito. Si noti che ogni aggiornamento potrebbe forzare l'archivio informazioni per cercare informazioni nella directory e che un aggiornamento durante un periodo in cui l'archivio informazioni Ŕ giÓ ricerca la directory Ŕ l'inizio di questo problema.

Si noti che come qualsiasi ottimizzazione delle prestazioni, Ŕ presente un saldo o equilibrio devono essere gestiti. Se si aumenta il valore del Registro di sistema, Ŕ possibile ridurre la probabilitÓ di blocchi client, ma a spese della potenzialmente lente volte per completare la replica directory.

Status

Microsoft ha confermato che questo problema riguarda Microsoft Exchange Server versione 5.5. Questo problema Ŕ stato innanzitutto corretto in Exchange Server 5.5 Service Pack 4.

Informazioni

Pu˛ essere utile utilizzare Performance Monitor per diagnosticare il problema. Utilizzare gli oggetti seguenti:
  • richieste MsExchangeIS::RPC
  • MsExchangeIS::Write client RPC byte/sec
  • MsExchangeDS::ExDS letture/sec
Un grafico di prestazioni tipico di questo problema vengono illustrati MsExchangeIS::RPCRequests (e possibilmente anche MsExchangeDS::ExDS letture/sec ) spiking verso l'alto, mentre nello stesso momento client MsExchangeIS::Write byte RPC al secondo approfondisce su 0 e rimangono. Infine, Richieste RPC restituisce a livelli normali e Byte scritti restituisce fino ai valori tipici.

ProprietÓ

Identificativo articolo: 268357 - Ultima modifica: venerdý 7 febbraio 2014 - Revisione: 4.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 5.5 Standard Edition
  • Microsoft Exchange Server 5.5 Service Pack 1
  • Microsoft Exchange Server 5.5 Service Pack 2
  • Microsoft Exchange Server 5.5 Service Pack 3
Chiavi:á
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Clicca qui per visualizzare la versione originale in inglese dell?articolo: 268357
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