Os clientes do Exchange Server 5.5 parecem deixar de responder quando o arquivo de informações consulta o directório

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importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986Descrição do registo do Microsoft Windows
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Sintomas

Poderá parecer que o processo cliente parou de responder (não reage) e apresenta o cursor ampulheta durante longos períodos, mas o processo, eventualmente, devolve o controlo ao utilizador. Este comportamento ocorrer normalmente em todo o dia, muitas vezes durante os ciclos de replicação e apenas quando o site está sobrecarregado.

Tal como medido pelo Monitor de desempenho, o arquivo de informações deixa de responder, acompanhadas por picos no contador de Pedidos de RPC enquanto os clientes de RPC de escrita de bytes/seg contador permanece no zero. Chamada de procedimento remoto alta (RPC) pede sozinhos ou bytes de escrita baixa apenas não estão relacionado com este problema. Apenas quando um servidor tiver ambos em simultâneo pode ser este o problema.

Este comportamento apenas tem sido observado nas organizações do Exchange Server com centenas de sites.

Causa

Grandes organizações do Exchange Server com centenas de sites frequentemente demorar alguns minutos para concluir uma procura do directório pelo arquivo de informações. Quando forem modificados determinados objectos no directório, pode ser accionada uma notificação para indicar o arquivo de informações para reconstruir itens tais como listas de endereçamento de site ou listas de domínio de SMTP válidas.

Se o arquivo de informações já está a procurar o directório algo muito ocupado e é notificado de que um objecto no directório que foi assistir foi alterado, o arquivo de informações poderá devolver um erro DS_E_TOO_LATE, que tem um aspecto se à seguinte no registo de eventos de aplicações:
ID do evento: 7201
Origem: MSExchangeIS
Tipo: aviso
Categoria: geral
Descrição: Thread em segundo plano FDsWaitTask encontrou um problema.
Código de erro DS_E_TOO_LATE
De resposta o arquivo de informações para este erro deve reconstruir a lista de objectos foi procura contra. Nestes casos, o arquivo de informações está a utilizar acesso serializado para ler o directório, compounds o slowness. Quando o servidor já está ocupado a tentativa de processar pedidos de cliente (alguns dos quais são provavelmente aguardar esta procura concluir a), os clientes parecem deixar de responder porque que estão a aguardar as chamadas RPC concluir. Tenha em atenção que cada actualização pode forçar o arquivo de informações para procurar o directório para obter informações, para que uma cadeia longa de actualizações pode conduzir a vários minutos de tempo não reagir aparente.

Obviamente, clientes frequentemente produzem o cursor de ampulheta por muitos motivos completamente não relacionadas com este problema. Neste caso o cliente está a aguardar resposta do servidor e consome pouca ou nenhuma tempo da CPU no computador cliente.

Resolução

Para resolver este problema, obtenha o service pack mais recente para o Exchange Server 5.5. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
191014Como obter o Exchange Server 5.5 service pack mais recente
Este problema é pior quando o atributo de Nome de directório não está indexado. Quando o atributo de Nome de directório não é indexado, o desempenho de algumas procuras pode ser afectado negativamente.

Para indexar o atributo de Nome de directório , siga estes passos.

aviso Se utilizar o modo não processado do programa Exchange Server Administrator ( /r admin ) incorrectamente, poderão ocorrer problemas graves que poderão forçar a reinstalação do Microsoft Windows NT Server, do Microsoft Exchange Server ou de ambos. Microsoft não garante que problemas resultantes da utilização incorrecta do modo não processado podem ser resolvidos. Utiliza o modo não processado por sua conta e risco.
  1. Inicie o programa Exchange Administrator no modo não processado. Para efectuar este procedimento, pode utilizar o comando Admin /r numa linha de comandos.
  2. No menu Ver , clique em Directório RAW .
  3. No painel esquerdo, clique em esquema .
  4. No painel da direita, faça duplo clique em Nome do directório e, em seguida, clique em Sim .
  5. Na lista os atributos do objecto , clique em Procurar sinalizadores .

    Se o valor do atributo Sinalizadores de procura é definido como 0 , altere o valor como 1 .
  6. Reinicie o serviço Microsoft Exchange Directory.
Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
184823Índice de esquema incorrecto depois da actualização Exchange 4.0 para 5.5

Como contornar

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.
Pode diminuir ou Amortecer o efeito deste problema aumentando o tempo que o servidor bridgehead de replicação de directórios aguarda antes de que notifica outros servidores no site de alterações. Pode aumentar o momento da seguinte chave de registo:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDS\Parameters\Replicator notificar pausa após modificar (segundos)
O valor predefinido para esta chave é 0x12C ou 300 segundos (cinco minutos). Se aumentar este valor para corresponder a duração da maior série de não reage, pode reduzir o impacto do problema.

A estratégia é forçar o bridgehead de replicação de directório para manter respectivo actualizações um pouco mais. Isto diminui a hipótese de uma série de randomizing actualizações vai encher no site. Tenha em atenção que cada actualização poderá forçar o arquivo de informações para procurar no directório para obter informações e que está uma actualização durante um período em que o arquivo de informações já é procurar no directório onde começa este problema.

Tenha em atenção que tal como qualquer optimização do desempenho, existe um saldo ou equilibrium ser mantida. Se aumentar este valor de registo, pode reduzir a probabilidade de cliente não reage mas em detrimento de potencialmente mais lentos vezes para concluir a replicação de directórios.

Ponto Da Situação

A Microsoft confirmou que este é um problema no Microsoft Exchange Server versão 5.5. Este problema foi corrigido pela primeira vez no Exchange Server 5.5 Service Pack 4.

Mais Informação

Pode ser útil utilizar o Monitor de desempenho para diagnosticar este problema. Utilize os seguintes objectos:
  • pedidos de MsExchangeIS::RPC
  • clientes RPC de bytes de MsExchangeIS::Write/seg
  • MsExchangeDS::ExDS leituras/seg
Apresenta um gráfico do Monitor de desempenho típico deste problema MsExchangeIS::RPCRequests (e possivelmente, MsExchangeDS::ExDS leituras/seg ) spiking para cima, enquanto ao mesmo tempo clientes MsExchangeIS::Write RPC de bytes/seg dives como 0 e aí permanece. Eventualmente, Pedidos de RPC devolve a níveis normais e Bytes escritos devolve para os respectivos valores normais.

Propriedades

Artigo: 268357 - Última revisão: 24 de janeiro de 2014 - Revisão: 4.1
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 5.5 Standard Edition
  • Microsoft Exchange Server 5.5 Service Pack 1
  • Microsoft Exchange Server 5.5 Service Pack 2
  • Microsoft Exchange Server 5.5 Service Pack 3
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbbug kbexchange550sp4fix kbfix kbqfe KB268357 KbMtpt
Tradução automática
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