Select the product you need help with
Visual Studio installation problems occur if Crystal Reports 8 is installedArticle ID: 268553 - View products that this article applies to. This article was previously published under Q268553 On This PageSYMPTOMS
When you install Microsoft Visual Studio products on a computer that has Crystal Reports version 8 from Business Objects installed, you receive one of the following error messages:
Message 1
setup error 168
setup error failed to register d:\program files\common files\designer\ msaddndr.dll
setup was not completed successfully, please reinstall
Cannot register msxml3.dll
DLL Name was unable to register itself in the system registry
CAUSE
The third-party program, Crystal Reports, has removed registry permissions from the affected keys.
RESOLUTION
You can use the following procedure to resolve this problem:
MORE INFORMATION
For more information on this problem, see the following article on the Business Objects Web site:
http://technicalsupport.businessobjects.com/KanisaSupportSite/search.do?cmd=displayKC&docType=kc&externalId=c2006825&sliceId=&dialogID=360384&stateId=1%200%20356275
(http://technicalsupport.businessobjects.com/KanisaSupportSite/search.do?cmd=displayKC&docType=kc&externalId=c2006825&sliceId=&dialogID=360384&stateId=1%200%20356275)
Steps to reproduce the behaviorInstall Crystal Reports version 8.0.0.371 or earlier on a computer that is running Microsoft Windows NT 4.0 or Windows 2000. Next, install Microsoft Visual Studio.The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. REFERENCES
For additional information about the registry problems that are caused by Crystal Reports, click the following article number to view the article in the Microsoft Knowledge Base:
272693
For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
(http://support.microsoft.com/kb/272693/
)
0x80004005 ASP error message occurs when you connect to a database after Crystal Reports 8 installation
259569
(http://support.microsoft.com/kb/259569/
)
PRB: Installing third-party product breaks Windows 2000 MDAC registry settings
269383
(http://support.microsoft.com/kb/269383/
)
PRB: 'Error accessing the system registry' message when displaying VB/VBA references
266621
(http://support.microsoft.com/kb/266621/
)
PRB: Error "library not registered" with Crystal Reports 8.0
PropertiesArticle ID: 268553 - Last Review: March 13, 2008 - Revision: 7.1 APPLIES TO
| Article Translations
|


Back to the top








