"0x000000D1" und "anschließen" Abbruchfehler, wenn nicht gesendete Nachrichten an eine Dead Letter-Warteschlange in Windows 7 oder in Windows Server 2008 R2 Message Queuing bewegt werden.

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 2688203 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Szenarien Sie die folgenden.

Szenario 1
  • Sie installieren Microsoft Message Queuing (auch als MSMQ bezeichnet) auf einem Computer, auf der Windows 7 oder Windows Server 2008 R2 ausgeführt wird.
  • Nachrichten werden in einer Warteschlange gehalten. Beispielsweise werden die Nachrichten in der Warteschlange gehalten, wenn die Anwendungen, die der Meldungen, nicht verfügbar sind.
  • Dead Letter-Funktionalität ist in der Warteschlange aktiviert, so dass Message Queuing nicht gesendete Nachrichten an eine private Dead Letter-Warteschlange verschieben.
  • Eine Nachricht nicht von einer Anwendung empfangen, und ein Timeout auftritt, wenn die Nachricht erneut gesendet wird.
  • Message Queuing verschiebt die Nachricht in der Dead Letter-Warteschlange in einer Transaktion.

In diesem Szenario stürzt der Computer. Darüber hinaus erhalten Sie eine Stop-Fehlermeldung, die der folgenden ähnelt:
STOPP: 0X000000D1 (Parameter1, Parameter2, Parameter3, Parameter4)
Notizen
  • Dieser Abbruchfehler beschreibt ein Problem DRIVER_IRQL_NOT_LESS_OR_EQUAL.
  • Die Parameter in der Stop-Fehlermeldung variieren je nach Konfiguration des Computers.
  • Nicht alle "0x000000D1" Stop-Fehler werden durch dieses Problem verursacht.

Szenario 2
  • Sie installieren Microsoft Message Queuing auf einem Computer mit Windows 7 oder Windows Server 2008 R2.
  • Nachrichten werden in einer Warteschlange gehalten. Beispielsweise werden die Nachrichten in einer Warteschlange gehalten, wenn die Anwendungen, die der Meldungen, nicht verfügbar sind.
  • Dead Letter-Funktionalität ist in der Warteschlange aktiviert, so dass Message Queuing nicht gesendete Nachrichten an eine private Dead Letter-Warteschlange verschieben.
  • Sie können die Treiberüberprüfung auf dem Computer.
  • Eine Nachricht nicht von einer Anwendung empfangen, und ein Timeout auftritt, wenn die Nachricht erneut gesendet wird.
  • Message Queuing verschiebt die Nachricht in der Dead Letter-Warteschlange in einer Transaktion.

In diesem Szenario erhalten Sie eine Stop-Fehlermeldung, die der folgenden ähnelt:
STOP: anschließen (parameter1, parameter2, parameter3, parameter4)
Notizen
  • Dieser Abbruchfehler wird ein DRIVER_VERIFIER_IOMANAGER_VIOLATIONL Problem beschrieben.
  • Die Parameter in der Stop-Fehlermeldung variieren je nach Konfiguration des Computers.
  • Nicht alle "anschließen" Stop-Fehler werden durch dieses Problem verursacht.

Ursache

Dieses Problem wird durch eine Lesezugriffsverletzung verursacht, das auftritt, wenn die Nachrichten an Warteschlangen für unzustellbare von ausgehenden Warteschlangen gesendet werden.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll jedoch nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zu einem Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist es ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen

Um diesen Hotfix anwenden zu können, müssen Sie Windows 7 Service Pack 1 (SP1) oder Windows Server 2008 R2 SP1 ausgeführt werden. Darüber hinaus müssen Sie Message Queuing installiert haben.

Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
976932Informationen zu Servicepack 1 für Windows 7 und Windows Server 2008 R2

Informationen zur Registrierung

Um diesen Hotfix anwenden zu können, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Neustart erforderlich ist.

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgelistet. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Sommerzeit (DST) angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf die Dateien ausführen.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings sind Hotfixes, die auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgeführt. Um das Hotfix-Paket anzufordern, das auf ein oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgeführt ist. Immer finden Sie im Abschnitt "Gilt für" im Artikel, um das aktuelle Betriebssystem bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien, die gelten für bestimmte Produkte, SR_Level (RTM, SPn) und Servicebereiche (LDR, GDR) können identifiziert werden, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt:
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereich
    6.1.760 1.21XxxWindows 7 und WindowsServer 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. Manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind. gesondert aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows 7 und WindowsServer 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) sind äußerst wichtig, den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 86-basierten Versionen von Windows 7
Tabelle minimierenTabelle vergrößern
DateinameVersion der DateiDateigrößeDatumZeit
MQAC.sys6.1.7601.21958142,33605-Apr-201203: 19
Für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameVersion der DateiDateigrößeDatumZeit
MQAC.sys6.1.7601.21958189,44005-Apr-201203: 57
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameVersion der DateiDateigrößeDatumZeit
MQAC.sys6.1.7601.21958472,57605-Apr-201203: 16


Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkte zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 86-basierten Versionen von Windows 7
Tabelle minimierenTabelle vergrößern
DateinameX86_ad6305e33e90682416dd1abf36dcc280_31bf3856ad364e35_6.1.7601.21958_none_c60467376f706177.Manifest
Version der DateiNicht zutreffend
Dateigröße714
Datum (UTC)05-Apr-2012
Zeit (UTC)10: 28
DateinameX86_microsoft-Windows-m..CESS-Control-driver_31bf3856ad364e35_6.1.7601.21958_none_c96964aba28da580.manifest
Version der DateiNicht zutreffend
Dateigröße3,650
Datum (UTC)05-Apr-2012
Zeit (UTC)07: 42
Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_ce648341f19f347638ca2449c2820cdb_31bf3856ad364e35_6.1.7601.21958_none_c9d69d2f4081958f.Manifest
Version der DateiNicht zutreffend
Dateigröße718
Datum (UTC)05-Apr-2012
Zeit (UTC)10: 28
DateinameAmd64_microsoft-Windows-m..CESS-Control-driver_31bf3856ad364e35_6.1.7601.21958_none_2588002f5aeb16b6.manifest
Version der DateiNicht zutreffend
Dateigröße3,654
Datum (UTC)05-Apr-2012
Zeit (UTC)08: 29
Zusätzliche Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameIa64_0aeb63db23ec71e6a523c679fe25437f_31bf3856ad364e35_6.1.7601.21958_none_748bd9da0c28fea6.Manifest
Version der DateiNicht zutreffend
Dateigröße716
Datum (UTC)05-Apr-2012
Zeit (UTC)10: 27
DateinameIa64_microsoft-Windows-m..CESS-Control-driver_31bf3856ad364e35_6.1.7601.21958_none_c96b08a1a28bae7c.manifest
Version der DateiNicht zutreffend
Dateigröße3,652
Datum (UTC)05-Apr-2012
Zeit (UTC)08: 29

Eigenschaften

Artikel-ID: 2688203 - Geändert am: Freitag, 25. Mai 2012 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2688203 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2688203
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com