errores de detención "0x000000D1" y "0x000000C9" cuando Message Queue Server mueve los mensajes no enviados a una cola de mensajes no enviados en Windows 7 o en Windows Server 2008 R2

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Síntomas

Tenga en cuenta los siguientes escenarios.

Escenario 1
  • Instalar Microsoft Message Queue Server (también conocido como MSMQ) en un equipo que ejecuta Windows 7 o Windows Server 2008 R2.
  • Los mensajes se almacenan en una cola. Por ejemplo, los mensajes se almacenan en la cola cuando las aplicaciones que reciben los mensajes no están disponibles.
  • Funcionalidad de mensajes no enviados está habilitada en la cola para que Message Queue Server puede mover los mensajes no enviados a una cola privada.
  • No se recibe un mensaje por una aplicación y un tiempo de espera se produce cuando se vuelve a enviar el mensaje.
  • Message Queue Server mueve el mensaje a la cola de mensajes no enviados en una transacción.

En este escenario, el equipo deja de funcionar. Además, recibirá un mensaje de error Stop similar al siguiente:
STOP: 0X000000D1 (parámetro1, parámetro2, parámetro3, parámetro4)
Notas
  • Este error Stop aborda un problema DRIVER_IRQL_NOT_LESS_OR_EQUAL.
  • Los parámetros en el mensaje de error Stop varían según la configuración del equipo.
  • No todos los errores de detención "0x000000D1" son causados por este problema.

Escenario 2
  • Instalar Microsoft Message Queue Server en un equipo que ejecuta Windows 7 o Windows Server 2008 R2.
  • Los mensajes se almacenan en una cola. Por ejemplo, los mensajes se almacenan en una cola cuando las aplicaciones que reciben los mensajes no están disponibles.
  • Funcionalidad de mensajes no enviados está habilitada en la cola para que Message Queue Server puede mover los mensajes no enviados a una cola privada.
  • Habilitar el Comprobador de controlador en el equipo.
  • No se recibe un mensaje por una aplicación y un tiempo de espera se produce cuando se vuelve a enviar el mensaje.
  • Message Queue Server mueve el mensaje a la cola de mensajes no enviados en una transacción.

En este caso, recibirá un mensaje de error Stop similar al siguiente:
STOP: 0x000000C9 (parámetro1, parámetro2, parámetro3, Parámetro4)
Notas
  • Este error Stop aborda un problema DRIVER_VERIFIER_IOMANAGER_VIOLATIONL.
  • Los parámetros en el mensaje de error Stop varían según la configuración del equipo.
  • No todos los errores de detención de "0x000000C9" son causados por este problema.

Causa

Este problema está causado por una infracción de acceso de lectura que se produce cuando los mensajes se envían desde las colas de salida a las colas de mensajes no enviados.

Solución

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga esta revisión.

Si la revisión está disponible para descargar, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows 7 Service Pack 1 (SP1) o Windows Server 2008 R2 SP1. Además, debe tener instalado Message Queue Server.

Para obtener más información acerca de cómo obtener un service pack de Windows 7 o Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
976932Información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Para aplicar esta revisión, no es necesario realizar los cambios en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Se muestran las fechas y las horas de estos archivos en el equipo local en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivos de Windows 7 y Windows Server 2008 R2
Importante Las correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, se enumeran las revisiones en la página de solicitud de revisión en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece en "Windows 7/Windows Server 2008 R2" en la página. Siempre hacen referencia a la sección "Se aplica A" en los artículos para determinar el sistema operativo real que cada revisión se aplica a.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn) y servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo tal como se muestra en la tabla siguiente:
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoSR_LevelRama de servicio
    6.1.760 1.21xxxWindows 7 y Windows Server 2008 R2SERVICE PACK 1LDR
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instala para cada entorno están la lista por separado en la sección "información adicional de archivos para Windows 7 y Windows Server 2008 R2". MAMÁ y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado del componente actualizado. Los archivos de catálogo de seguridad, para que no se enumeran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempo
Mqac.sys6.1.7601.21958142,33605-Abr-201203: 19
Para todas las versiones de 64 compatibles de Windows 7 y Windows Server 2008 R2 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempo
Mqac.sys6.1.7601.21958189,44005-Abr-201203: 57
Para todas las versiones compatibles basadas en IA-64 de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempo
Mqac.sys6.1.7601.21958472,57605-Abr-201216: 03


Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información adicional de archivos para Windows 7 y Windows Server 2008 R2

Archivos adicionales para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoX86_ad6305e33e90682416dd1abf36dcc280_31bf3856ad364e35_6.1.7601.21958_none_c60467376f706177.manifest
Versión del archivoNo es aplicable
Tamaño de archivo714
Fecha (UTC)05-Abr-2012
Hora (UTC)10: 28
Nombre de archivoX86_microsoft-windows-m..Cess-control-driver_31bf3856ad364e35_6.1.7601.21958_none_c96964aba28da580.manifest
Versión del archivoNo es aplicable
Tamaño de archivo3,650
Fecha (UTC)05-Abr-2012
Hora (UTC)07: 42
Archivos adicionales para todas las versiones de 64 compatibles de Windows 7 y Windows Server 2008 R2 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_ce648341f19f347638ca2449c2820cdb_31bf3856ad364e35_6.1.7601.21958_none_c9d69d2f4081958f.manifest
Versión del archivoNo es aplicable
Tamaño de archivo718
Fecha (UTC)05-Abr-2012
Hora (UTC)10: 28
Nombre de archivoAmd64_microsoft-windows-m..Cess-control-driver_31bf3856ad364e35_6.1.7601.21958_none_2588002f5aeb16b6.manifest
Versión del archivoNo es aplicable
Tamaño de archivo3,654
Fecha (UTC)05-Abr-2012
Hora (UTC)08: 29
Archivos adicionales para todas las versiones compatibles basadas en IA-64 de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoIa64_0aeb63db23ec71e6a523c679fe25437f_31bf3856ad364e35_6.1.7601.21958_none_748bd9da0c28fea6.manifest
Versión del archivoNo es aplicable
Tamaño de archivo716
Fecha (UTC)05-Abr-2012
Hora (UTC)10: 27
Nombre de archivoIa64_microsoft-windows-m..Cess-control-driver_31bf3856ad364e35_6.1.7601.21958_none_c96b08a1a28bae7c.manifest
Versión del archivoNo es aplicable
Tamaño de archivo3.652
Fecha (UTC)05-Abr-2012
Hora (UTC)08: 29

Propiedades

Id. de artículo: 2688203 - Última revisión: viernes, 25 de mayo de 2012 - Versión: 2.0
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
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  • Windows 7 Ultimate
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Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2688203

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