erros Stop "0x000000D1" e "0x000000C9" quando enfileiramento de mensagens não enviadas para uma fila de inatividade no Windows 7 ou no Windows Server 2008 R2

Traduções de Artigos Traduções de Artigos
Artigo: 2688203 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere os seguintes cenários.

Cenário 1
  • Instalar o Microsoft Message Queuing (também conhecido como MSMQ) em um computador que esteja executando o Windows 7 ou Windows Server 2008 R2.
  • As mensagens são mantidas em uma fila. Por exemplo, as mensagens são mantidas na fila quando os aplicativos que recebem as mensagens não estão disponíveis.
  • Funcionalidade de inatividade é habilitada na fila para que o enfileiramento de mensagens pode mover as mensagens não enviadas para uma fila de inatividade particular.
  • Uma mensagem não é recebida por um aplicativo e um tempo limite ocorre quando a mensagem é enviada novamente.
  • O Message Queuing move a mensagem para a fila de inatividade em uma transação.

Nesse cenário, o computador trava. Além disso, você recebe uma mensagem de erro Stop semelhante à seguinte:
STOP: 0X000000D1 (Parameter1, Parâmetro2, Parâmetro3, Parâmetro4)
Observações
  • Esse erro Stop descreve um problema DRIVER_IRQL_NOT_LESS_OR_EQUAL.
  • Os parâmetros na mensagem de erro Stop variam, dependendo da configuração do computador.
  • Nem todos os erros de Stop "0x000000D1" são causados pelo problema.

Cenário 2
  • Instalar o Microsoft Message Queuing em um computador que esteja executando o Windows 7 ou Windows Server 2008 R2.
  • As mensagens são mantidas em uma fila. Por exemplo, as mensagens são mantidas em uma fila quando os aplicativos que recebem as mensagens não estão disponíveis.
  • Funcionalidade de inatividade é habilitada na fila para que o enfileiramento de mensagens pode mover as mensagens não enviadas para uma fila de inatividade particular.
  • Ativar o verificador de Driver no computador.
  • Uma mensagem não é recebida por um aplicativo e um tempo limite ocorre quando a mensagem é enviada novamente.
  • O Message Queuing move a mensagem para a fila de inatividade em uma transação.

Nesse cenário, você recebe uma mensagem de erro Stop semelhante à seguinte:
STOP: 0x000000C9 (Parâmetro1, Parâmetro2, Parâmetro3, Parâmetro4)
Observações
  • Esse erro Stop descreve um problema DRIVER_VERIFIER_IOMANAGER_VIOLATIONL.
  • Os parâmetros na mensagem de erro Stop variam, dependendo da configuração do computador.
  • Nem todos os erros de parada "0x000000C9" são causados pelo problema.

Causa

Esse problema é causado por uma violação de acesso de leitura que ocorre quando as mensagens são enviadas de filas de saída para filas de inatividade.

Resolução

Informações sobre hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplica esse hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos de suporte normais se aplicarão a perguntas de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows 7 Service Pack 1 (SP1) ou Windows Server 2008 R2 SP1. Além disso, você deve ter o enfileiramento de mensagens instalado.

Para obter mais informações sobre como obter um service pack do Windows 7 ou Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
976932Informações sobre o Service Pack 1 para Windows 7 e Windows Server 2008 R2

Informações do registro

Para aplicar esse hotfix, não é necessário fazer alterações no registro.

Requisito de reinicialização

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do arquivo

A versão global deste hotfix instala arquivos que tenham os atributos listados nas tabelas a seguir. As datas e horários para esses arquivos estão listados no tempo Universal Coordenado (UTC). As datas e horários para esses arquivos no computador local são exibidos em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e horas podem ser alterados quando você realizar algumas operações nos arquivos.
Informações sobre o arquivo do Windows 7 e Windows Server 2008 R2
Importante Hotfixes do Windows 7 e os hotfixes do Windows Server 2008 R2 estão incluídos nos mesmos pacotes. No entanto, os hotfixes na página solicitação de Hotfix são listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Consulte a seção "Aplica-se A" nos artigos para determinar o sistema operacional real que cada hotfix se aplica para sempre.
  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn) e ramificação (LDR, GDR) do serviço podem ser identificados examinando os números de versão do arquivo conforme mostrado na tabela a seguir:
    Reduzir esta tabelaExpandir esta tabela
    VersãoProdutoSR_LevelRamificação do serviço
    6.1.760 1.21xxxWindows 7 e Windows Server 2008 R2SP1LDR
  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "informações de arquivo adicionais para o Windows 7 e Windows Server 2008 R2". MUM e arquivos de MANIFESTO e os arquivos de catálogo (. cat) de segurança associadas, são extremamente importantes para manter o estado do componente atualizado. Os arquivos de catálogo de segurança para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x86 do Windows 7
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempo
MQAC.sys6.1.7601.21958142,33605-Abr-201203: 19
Para todas as versões baseadas em x64 do Windows 7 e do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempo
MQAC.sys6.1.7601.21958189,44005-Abr-201203: 57
Para todas as versões baseadas em IA-64 do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempo
MQAC.sys6.1.7601.21958472,57605-Abr-201216: 03


Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Informações de arquivo adicionais

Informações de arquivo adicionais para o Windows 7 e Windows Server 2008 R2

Arquivos adicionais para todas as versões baseadas em x86 do Windows 7
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoX86_ad6305e33e90682416dd1abf36dcc280_31bf3856ad364e35_6.1.7601.21958_none_c60467376f706177.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo714
Data (UTC)05-Abr-2012
Hora (UTC)10: 28
Nome de arquivoX86_microsoft-windows-m...driver_31bf3856ad364e35_6.1.7601.21958_none_c96964aba28da580.manifest de controle de cess
Versão do arquivoNão aplicável
Tamanho do arquivo3,650
Data (UTC)05-Abr-2012
Hora (UTC)07: 42
Arquivos adicionais para todas as versões baseadas em x64 do Windows 7 e do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoAmd64_ce648341f19f347638ca2449c2820cdb_31bf3856ad364e35_6.1.7601.21958_none_c9d69d2f4081958f.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo718
Data (UTC)05-Abr-2012
Hora (UTC)10: 28
Nome de arquivoAmd64_microsoft-windows-m...driver_31bf3856ad364e35_6.1.7601.21958_none_2588002f5aeb16b6.manifest de controle de cess
Versão do arquivoNão aplicável
Tamanho do arquivo3,654
Data (UTC)05-Abr-2012
Hora (UTC)08: 29
Arquivos adicionais para todas as versões compatíveis baseadas em IA-64, do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome de arquivoIa64_0aeb63db23ec71e6a523c679fe25437f_31bf3856ad364e35_6.1.7601.21958_none_748bd9da0c28fea6.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo716
Data (UTC)05-Abr-2012
Hora (UTC)10: 27
Nome de arquivoIa64_microsoft-windows-m...driver_31bf3856ad364e35_6.1.7601.21958_none_c96b08a1a28bae7c.manifest de controle de cess
Versão do arquivoNão aplicável
Tamanho do arquivo3,652
Data (UTC)05-Abr-2012
Hora (UTC)08: 29

Propriedades

Artigo: 2688203 - Última revisão: 25 de maio de 2012 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palavras-chave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2688203 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2688203

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com