Old System Center 2012 Configuration Manager application Deployment Type source content remains in the client cache after the application is removed

Article translations Article translations
Article ID: 2688244 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You create an application that uses a Deployment Type that has the Persist content in the client cache option selected and then deploy the application to a client computer that is running Microsoft System Center 2012 Configuration Manager.
  • You install the application on the client computer that is running Configuration Manager.
  • In the Configuration Manager Administrator Console, you make a change to the application Deployment Type that affects the source and then distribute that new source to your distribution points.
  • On the client, you remove the application by using Control Panel to and then run the Application Deployment Evaluation Cycle action by using the Configuration Manager item in Control Panel.
  • The updated Deployment Type source content is downloaded into the client cache.

In this scenario, the original source content remains in the client cache. However, you expect the old source content to be removed from the client cache.

CAUSE

This problem occurs because associated source content is not automatically deleted from the cache. After it is downloaded, source content for all Deployment Types is guaranteed to stay in the cache for at least one day after the cached content was last referenced. However, if you configure the Deployment Type while the Persist content in the client cache option is enabled, the source is never deleted.

WORKAROUND

To work around this problem, increase your cache size, or force the existing packages to be deleted.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2688244 - Last Review: July 9, 2012 - Revision: 2.0
APPLIES TO
  • Microsoft System Center 2012 Configuration Manager
Keywords: 
kbtshoot kbprb kbexpertiseinter kbsurveynew KB2688244

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com