"Network and Dial-up Connections" folder icons missing

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Article ID: 269019 - View products that this article applies to.
This article was previously published under Q269019
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SYMPTOMS

When you open the Network and Dial-up Connections folder, your Local Area Connection and dial-up connection icons may not be visible, although networking continues to function correctly. The only icon in the folder is the Make New Connection icon.

CAUSE

This behavior can occur if the following registry key or one of its subkeys has been deleted or changed to an invalid value:
HKEY_CLASSES_ROOT\Interface\{0000010C-0000-0000-C000-000000000046}

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50601

Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

  1. Start Notepad.
  2. Type the following lines in Notepad:
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Interface\{0000010c-0000-0000-C000-000000000046}]
    @="IPersist"

    [HKEY_CLASSES_ROOT\Interface\{0000010c-0000-0000-C000-000000000046}\NumMethods]
    @="4"

    [HKEY_CLASSES_ROOT\Interface\{0000010c-0000-0000-C000-000000000046}\ProxyStubClsid32]
    @="{00000320-0000-0000-C000-000000000046}"
  3. Save the file as Restore.reg. Note that Notepad may add a .txt extension to the file name. If this occurs, rename the file to Restore.reg.
  4. Double-click the Restore.reg file.
  5. When you are prompted to confirm that you want to add the information to the registry, click Yes.
  6. Restart your computer.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

Properties

Article ID: 269019 - Last Review: February 17, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnetwork kbprb kbui kbfixme kbmsifixme KB269019

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