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文書番号: 269075 - 最終更新日: 2004年11月17日 - リビジョン: 7.0

エラー メッセージ : 次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: \Winnt\System32\Config\Systemced

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、システムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986? (http://support.microsoft.com/kb/256986/ ) Microsoft Windows レジストリの説明

目次

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現象

Microsoft Windows 2000 ベースのコンピュータを再起動した際、次のエラー メッセージが表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: \WINNT\SYSTEM32\CONFIG\SYSTEMced
: エラー メッセージの最後の文字 "ced" は、実際にはエラー メッセージの一部ではありません。この文字は、エラー メッセージが表示される前の画面に表示されていたもので、エラー メッセージが表示されたときに完全には消去されませんでした。

次のエラー メッセージが表示されることもあります。
System hive error

原因

この現象は、以下の状況のいずれかに該当する場合に発生することがあります。
  • Promise Technology, Inc. ATA66 PCI コントローラ カードがコンピュータにインストールされている場合。通常、この問題は Windows 2000 のインストール時に発生します。
  • レジストリ内のシステム ハイブが破損しているか、または見つからない場合。

    Windows 2000 では、レジストリが非常に大きい場合はレジストリを読み込めないことがあります。この問題は、プロセスによって、非常に大きなデータがレジストリの System サブキーに書き込まれる際に発生することがあります。System サブキーは、コンピュータの起動に必要な情報のみを含むように設計されています。

    Intel アーキテクチャまたは ARC (RISC) アーキテクチャ ベースのコンピュータは、ブート処理のこの段階ではメモリを 16 MB しか使用できません。System レジストリ サブキーは、16 MB をローダー、カーネル、HAL、およびブート ドライバと共有する必要があります。場合によっては、System サブキーのサイズが 13 MB 以上になることがあります。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

この問題を解決するには、次のうち適切な方法を使用します。

Promise Technology ATA66 PCI コントローラを削除する

Promise ATA66 コントローラがインストールされているコンピュータに Windows 2000 をインストールしているときにこの問題が発生した場合、Promise Technology ATA66 PCI コントローラ カードを取り外し、BIOS 設定を確認してマザーボード上の IDE コントローラが有効になっていることを確認した後、Windows 2000 セットアップをもう一度実行します。

システム ハイブのバックアップを復元する

重要 : REPAIR フォルダのシステム ハイブを使用すると、ドメイン コントローラの機能が失われるため、この手順は Active Directory のドメイン コントローラでは使用できません。

回復コンソール ツールを使用して、repair フォルダのシステム ハイブのバックアップ コピーと置き換えます。回復コンソール ツールがコンピュータにインストールされていない場合は、次のようにシステム修復処理から実行します。
  1. Windows 2000 の CD-ROM または Windows 2000 起動ディスクを使用して、コンピュータを起動します。
  2. "セットアップへようこそ" メッセージが表示されたら R キーを押して "修復" を選択します。
  3. C キーを押して、回復コンソール ツールを実行します。
  4. 修復するインストールを選択します。
  5. Administrator のパスワードを入力します。

    コンピュータがドメイン コントローラである場合、要求された際にディレクトリ サービスの復元モードのパスワードを入力します。 回復コンソール ツールの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    239803? (http://support.microsoft.com/kb/239803/ ) [NT] 修復コンソールの Administrator パスワードを変更する方法
    223301? (http://support.microsoft.com/kb/223301/ ) オフライン SAM の管理者アカウントの保護
  6. 回復コンソール コマンド プロンプトで以下のコマンドを入力します。各コマンドを入力した後、Enter キーを押します。
    cd system32\config
    ren system system.old
    ren system.alt systemalt.old
  7. Windows バックアップと回復ツールからシステム修復ディスク ウィザードを実行した場合、%SystemRoot%\Repair\Regback フォルダからシステム ハイブのバックアップをコピーします。

    システム修復ディスク ウィザードを実行していない場合、%SystemRoot%\Repair フォルダからデフォルトのシステム ハイブをコピーします。

    重要 : システム ハイブは、最新のコピーを復元する必要があります。さらに、システム修復ディスクを最後に更新したとき以降にインストールした、ハードウェア デバイス ドライバやサービスとして実行するプログラムを再インストールする必要もあります。

    デフォルトのシステム ハイブをコピーするには、次のコマンドを入力し、Enter キーを押します。
    copy c:\winnt\repair\system c:\winnt\system32\config
    前回システム修復ディスク ウィザードを実行したときにバックアップしたシステム ハイブをコピーするには、次のコマンドを入力し、Enter キーを押します。
    copy c:\winnt\repair\regback\system c:\winnt\system32\config
  8. コマンド プロンプトで exit と入力し、Enter キーを押して Windows を再起動します。

システム ハイブのサイズを小さくする

コンピュータ上で多数のリソースを共有している場合は、レジストリが非常に大きくなることがあります。この問題を解決するには、次の手順を実行します。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. レジストリの次のキーに移動し、キーをクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Share
  3. [レジストリ] メニューの [キーの保存] をクリックします。
  4. [ファイル名] ボックスに Shares.new と入力し、[保存] をクリックします。
  5. レジストリの次のキーに移動し、キーをクリックします。
    HKEY_LOCAL_MACHINE
  6. [レジストリ] メニューの [ハイブのロード] をクリックします。
  7. ファイルの一覧で、[System.old] ファイルを見つけてクリックし、[開く] をクリックします。
  8. [キー名] ボックスに、System.old と入力し、[OK] をクリックします。
  9. レジストリの次のキーに移動し、キーをクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\Select
  10. Default 値の設定をメモします。
  11. レジストリの次のキーに移動し、キーをクリックします。
    HKEY_LOCAL_MACHINE\System.old\ControlSetx\Services\LanmanServer\Shares
    x には、手順 10. でメモした数値を指定します。
  12. [レジストリ] メニューの [キーの保存] をクリックします。
  13. [ファイル名] ボックスに Shares.old と入力し、[保存] をクリックします。
  14. Shares.new キーを、次の System.old レジストリ ハイブに復元します。
    HKEY_LOCAL_MACHINE\System.old\ControlSetx\Services\LanmanServer\Shares
  15. HKEY_LOCAL_MACHINE\System.old キーをクリックします。
  16. [レジストリ] メニューの [ハイブのアンロード] をクリックします。
  17. レジストリ エディタを終了します。
  18. 回復コンソールでコンピュータを再起動します。
  19. コマンド プロンプトで、以下の行を入力します。各行を入力した後、Enter キーを押します。
    ren system system.org
    ren system.old system
  20. コマンド プロンプトで exit と入力し、Enter キーを押して Windows を再起動します。

詳細

Windows XP セットアップ ブート ディスクの入手方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
310994? (http://support.microsoft.com/kb/310994/ ) Windows XP セットアップ ブート ディスクの入手方法
Windows Server 2003 におけるシステム ハイブの制限の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
302594? (http://support.microsoft.com/kb/302594/ ) Windows Server 2003 におけるシステム ハイブのメモリ制限の緩和
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 269075? (http://support.microsoft.com/kb/269075/EN-US/ ) (最終更新日 2004-04-09) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
キーワード:?
kberrmsg kbtool kbprb KB269075
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