Help and Support
 

powered byLive Search

Error message when you try to set an IP address on a network adapter

Article ID:269155
Last Review:February 28, 2007
Revision:3.4
This article was previously published under Q269155
On This Page

SYMPTOMS

When you trying to set the IP address on a network adapter, you may receive the following error message:
The IP address XXX.XXX.XXX.XXX you have entered for this network adapter is already assigned to another adapter Name of adapter. Name of adapter is hidden from the network and Dial-up Connections folder because it is not physically in the computer or is a legacy adapter that is not working. If the same address is assigned to both adapters and they become active, only one of them will use this address. This may result in incorrect system configuration. Do you want to enter a different IP address for this adapter in the list of IP addresses in the advanced dialog box?
Where XXX.XXX.XXX.XXX is the IP address that you are trying to set and Name of adapter is the name of the network adapter that is present in the registry but hidden in Device Manager.

If you click Yes, you see the TCP/IP properties where you can change the IP address to something different for the currently showing network adapter in Device Manager. If you click No, the IP address is assigned to the network adapter. Note that if you click No, the selected network adapter in Device Manager and the ghosted network adapter have the same IP address. In most cases, this does not cause any problems because the driver is disabled.

Back to the top

CAUSE

A network adapter with the same IP address is in the registry but is hidden in Device Manager. This can occur when you move a network card from one PCI slot to another PCI slot.

Back to the top

RESOLUTION

To resolve this problem, uninstall the ghosted network adapter from the registry using one of the following methods:

Back to the top

Method 1

1.Click Start, click Run, type cmd.exe, and then press ENTER.
2.Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
3.Type Start DEVMGMT.MSC, and then press ENTER.
4.Click View, and then click Show Hidden Devices.
5.Expand the Network Adapters tree.
6.Right-click the dimmed network adapter, and then click Uninstall.

Back to the top

Method 2

The DevCon utility is a command-line utility that acts as an alternative to Device Manager. When you use DevCon, you can enable, disable, restart, update, remove, and query individual devices or groups of devices. To use DevCon, follow these steps:
1.Download the DevCon tool by clicking the following article number to view the article in the Microsoft Knowledge Base:
311272 (http://support.microsoft.com/kb/311272/) The DevCon command-line utility functions as an alternative to Device Manager
2.Unpack the 32-bit or 64-bit DevCon tool binary to a local folder.
3.Click Start, click Run, then type cmd and press ENTER.
4.Type CD:\path_to_binaries to navigate to the devcon.exe is located.
5.Use the following syntax to find installed network adapters:
devcon findall =net or
devcon listclass net
Note In the output of the previous commands, there is a line for the ghosted network adapter that is similar to the following:
PCI\VEN_10B7&DEV_9200&SUBSYS_00D81028&REV_78\4&19FD8D60&0&58F0: 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)
6.Remove the ghosted device by typing the following syntax:
devcon -r remove "@PCI\VEN_10B7&DEV_9200&SUBSYS_00D81028&REV_78\4&19FD8D60&0&58F0"

Back to the top

MORE INFORMATION

When you receive the error message in the "Symptoms" section, the hidden or ghosted network adapter does not appear in Device Manager unless you follow the steps in this article. Device Manager does show a network adapter and it typically has "#2" appended to the name.

Back to the top


APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows XP Professional

Back to the top

Keywords: 
kberrmsg kbhardware kbprb KB269155

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.