Article ID: 269201 - Last Review: December 3, 2007 - Revision: 5.1

Query builder Values box cannot display large item list

This article was previously published under Q269201
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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SYMPTOMS

When you create a query in Systems Management Server (SMS) 2.0, the Values box in the query builder may be empty. This may occur if the hotfix for Q245648 is installed, and there is either a very large value (approximately 9,500; the actual number varies based on available memory) or a value of 0 (a value of 0 requests that all records be returned) specified in:
HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\AdminUI\QueryBuilder\ValueLimit
The hotfix for Q245648 (both for Service Pack 1 and Service Pack 2) allows for more than 2,000 records to be listed in the query builder criteria section. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
245648  (http://support.microsoft.com/kb/245648/ ) Values list from Query Builder not always sorted and limited to first 2000 records

CAUSE

The SMS provider runs out of memory while it is caching a large result set.

RESOLUTION

To resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
288239  (http://support.microsoft.com/kb/288239/ ) How to obtain the latest Systems Management Server 2.0 service pack

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
If you are running Microsoft Windows NT or Microsoft Windows 2000, you should also update your Emergency Repair Disk (ERD) after completing this procedure.

To work around this problem, use a lower value in:
HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\AdminUI\QueryBuilder\ValueLimit
Use a value such that the records are displayed (the actual number varies based on available memory).

Note If ValueLimit does not exist, you can create it (Reg_DWORD).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2.0 Service Pack 3.

Registry subkey information

In SMS 2.0 and in SMS 2003, the registry key is as follows:
HKEY_LOCAL_MACHINE\SMS\AdminUI\QueryBuilder\ValueLimit
In Microsoft System Center Configuration Manager (SCCM) 2007, the registry key is as follows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ConfigMgr\AdminUI\QueryProcessors\ValueLimit
ValueLimit is a registry entry under the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ConfigMgr\AdminUI\QueryProcessors registry subkey.

ValueLimit should be a dword value. The value signifies how many items are returned when the user clicks the values button in the criterion dialog box. This is an optional value. The default value is 2000 if no key exists. If users want to override the default value, they can create the registry key.

APPLIES TO
  • Microsoft Systems Management Server 2.0 Standard Edition
  • Microsoft Systems Management Server 2.0 Service Pack 1
  • Microsoft Systems Management Server 2.0 Service Pack 2
  • Microsoft Systems Management Server 2.0 Service Pack 3
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbqfe kbhotfixserver kbbug kbfix kbsms200presp3fix KB269201
 

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