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Symptoms

Assume that you run an application remotely to collect performance counter and performance monitor information from a computer that is running Windows Vista or Windows Server 2008. You run the application by using a user profile that does not have the appropriate permissions on the following registry subkey:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Perflib
In this scenario, you cannot query performance counters by using the Remote Registry service. Additionally, the performance monitor stops responding.

Notes

  • After the issue that is described in the “Symptoms” section occurs, users can no longer query the counters by using the Remote Registry service. This includes users who have the appropriate permissions.

  • This issue is resolved temporarily when you restart the Remote Registry service.


Cause

This issue occurs because the user profile that you use to run the application does not have the appropriate permissions on the following registry subkey:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Perflib

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2.
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600
    2.
    22xxx

    Windows Vista and Windows Server 2008

    SP2

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista


File name

File version

File size

Date

Time

Regsvc.dll

6.0.6002.22831

107,008

02-Apr-2012

14:50

For all supported x64-based versions of Windows Server 2008 and of Windows Vista


File name

File version

File size

Date

Time

Regsvc.dll

6.0.6002.22831

207,360

02-Apr-2012

15:44

For all supported IA-64-based versions of Windows Server 2008


File name

File version

File size

Date

Time

Regsvc.dll

6.0.6002.22831

356,352

02-Apr-2012

15:46

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the RegOpenKeyEx function, go to the following Microsoft website:

General information about the RegOpenKeyEx functionFor more information about the Perflib subkey, go to the following Microsoft website:

General information about the Perflib subkeyFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008


File name

X86_fa9d9d30d68fc7300c9bb32cf88d2811_31bf3856ad364e35_6.0.6002.22831_none_2f0d7d4d0ac5a682.manifest

File version

Not applicable

File size

710

Date (UTC)

03-Apr-2012

Time (UTC)

09:52

File name

X86_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.0.6002.22831_none_8bb6b7ee99d2969f.manifest

File version

Not applicable

File size

11,192

Date (UTC)

02-Apr-2012

Time (UTC)

15:11

Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008


File name

Amd64_021ab139b3c4a9b4540e25bac5d92f41_31bf3856ad364e35_6.0.6002.22831_none_675801666153bbd2.manifest

File version

Not applicable

File size

714

Date (UTC)

03-Apr-2012

Time (UTC)

09:53

File name

Amd64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.0.6002.22831_none_e7d55372523007d5.manifest

File version

Not applicable

File size

11,468

Date (UTC)

02-Apr-2012

Time (UTC)

16:06

Additional files for all supported IA-64-based versions of Windows Server 2008


File name

Ia64_add0e52152f831919912e78661eb664d_31bf3856ad364e35_6.0.6002.22831_none_58b73ba1d541756b.manifest

File version

Not applicable

File size

712

Date (UTC)

03-Apr-2012

Time (UTC)

09:52

File name

Ia64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.0.6002.22831_none_8bb85be499d09f9b.manifest

File version

Not applicable

File size

11,461

Date (UTC)

02-Apr-2012

Time (UTC)

15:58

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