You receive duplicate read receipts from a user who is using an IMAP4 client in an Exchange Server 2007 environment

Article ID: 2696628 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • On a Microsoft Exchange Server 2007 server, you run the Set-ImapSettings -SuppressReadReceipt $true cmdlet in Microsoft Exchange Management Shell, and then restart the Internet Message Access Protocol (IMAP4) service.

    Note The Set-ImapSettings -SuppressReadReceipt $true cmdlet specifies that IMAP4 users who enable the Send read receipts for messages I send option in their IMAP4 clients only receive a read receipt when the recipient opens the message.
  • You send a user an email message and request a read receipt.
  • The user logs on to the mailbox by using an IMAP4 client, and then opens the email message.
  • You receive a read receipt.
In this scenario, you receive another read receipt when the user selects to send the read receipt.

CAUSE

This issue occurs because the SuppressReadReceipt flag for IMAP4 messages is always set to False.

RESOLUTION

To resolve this issue, install the following update rollup:
2655203 Description of Update Rollup 7 for Exchange Server 2007 Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2696628 - Last Review: April 16, 2012 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 3, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew KB2696628

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com