Esclarecimentos sobre o ciclo de vida do suporte para o .NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0

Traduções deste artigo Traduções deste artigo
ID do artigo: 2696944 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

INTRODUÇÃO

Este artigo contém esclarecimentos sobre o ciclo de vida do suporte para o .NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0. 

Segundo plano

O .NET Framework 3.5, o .NET Framework 3.0 e o .NET Framework 2.0 foram historicamente lançados como produtos individuais em plataformas com versões do Windows anteriores ao Windows 7 e Windows Server 2008 R2.

Na realidade, cada uma das versões destes produtos são camadas de uma pilha de recursos. Internamente, cada camada contém componentes mutuamente exclusivos. Portanto, os componentes no .NET Framework 3.0 são criados a partir do .NET Framework 2.0 e os componentes do .NET Framework 3.5 são criados a partir do .NET Framework 2.0 e do .NET Framework 3.0. Isso é exibido na imagem a seguir: 

Recolher esta imagemExpandir esta imagem
Imagem dos componentes


Um resultado desta arquitetura é que o .NET Framework 3.5 não pode funcionar sem o .NET Framework 2.0 e o .NET Framework 3.0 porque não há um CLR (Common Language Runtime) na camada do .NET Framework 3.5. Portanto, quando o .NET Framework 3.5 é instalado, também são instalados o .NET Framework 2.0 Service Pack 1 (SP1) e o .NET Framework 3.0 SP1. Da mesma forma, quando o .NET Framework 3.5 SP1 é instalado, também são instalados o .NET Framework 2.0 SP2 e o .NET Framework 3.0 SP2. Clientes executando o Windows XP ou o Windows Server 2003 podem exibir estas versões individuais junto com as atualizações correspondentes no item Adicionar ou remover programas do Painel de Controle:

Recolher esta imagemExpandir esta imagem
Imagem de atualizações correspondentes


No Windows Vista SP2 e no Windows Server 2008 SP2, o .NET Framework 2.0 SP2 e o .NET Framework 3.0 SP2 estão embutidos no sistema operacional. Da mesma forma, no Windows Vista SP1 e no Windows Server 2008, o .NET Framework 2.0 SP1 e o .NET Framework 3.0 SP1 estão embutidos no sistema operacional. Portanto, os clientes veem apenas o .NET Framework 3.5 no item Programas e Recursos, como exibido na imagem a seguir:

Recolher esta imagemExpandir esta imagem
Imagem de Programas e Recursos

Implicações do ciclo de vida do suporte

Como o .NET Framework 3.5, o .NET Framework 3.0 e o .NET Framework 2.0 foram lançados como versões de produto independentes, cada um deles possui ciclos de vida do suporte independentes.

Conforme discutido anteriormente neste artigo, o .NET Framework 3.5 não funciona sem o .NET Framework 2.0 e o .NET Framework 3.0. Em vários casos, resolver problemas funcionais ou proteger os clientes das vulnerabilidades de segurança do .NET Framework 3.5 exige resolver problemas em cada uma das camadas dos três produtos. Isso pode resultar em cenários onde o .NET Framework 3.5 está dentro do período de suporte e exige uma atualização das camadas subjacentes do .NET Framework 2.0 ou do .NET Framework 3.0 quando a documentação do ciclo de vida do suporte lista que a versão subjacente está sem suporte. Um exemplo disso é o .NET Framework 3.5 SP1, que atualmente está dentro do período de suporte. No entanto, o .NET Framework 3.0 SP2 está documentado como sem suporte a partir do dia 12/7/2011.

Nestes casos, o suporte para instalações autônomas do .NET Framework 3.0 expiraram. No entanto, a Microsoft oferecerá suporte dos componentes do .NET Framework 2.0 e .NET Framework 3.0 para clientes que instalaram o .NET Framework 3.5 enquanto o .NET Framework 3.5 permanecer dentro do período de suporte.

Além disso, como o .NET Framework 2.0 SP2 e o .NET Framework 3.0 SP2 são embutidos no Windows Vista SP2 e no Windows Server 2008 SP2 e o .NET Framework 2.0 SP1 e o .NET Framework 3.0 SP1 são embutidos no Windows Vista SP1 e no Windows Server 2008, estas versões serão suportadas como parte de seus respectivos sistemas operacionais enquanto estas versões do .NET permanecerem dentro do período de suporte.

Observação O .NET Framework 3.5 é apenas suportado no nível do SP1 junto com o .NET Framework 2.0 SP2 e o .NET Framework 3.0 SP2. A versão original do .NET Framework 3.5 com o .NET Framework 2.0 SP1 e o .NET Framework 3.0 SP1 não é mais suportada. 
Observação: este é um artigo de ?PUBLICAÇÃO RÁPIDA? criado diretamente pela organização de suporte da Microsoft. As informações aqui contidas são fornecidas no presente estado, em resposta a questões emergentes. Como resultado da velocidade de disponibilização, os materiais podem incluir erros tipográficos e poderão ser revisados a qualquer momento, sem aviso prévio. Consulte os Termos de Uso para ver outras informações.

Propriedades

ID do artigo: 2696944 - Última revisão: sábado, 7 de abril de 2012 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 3.5
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 2.0
Palavras-chave: 
kbinfo kbexpertiseinter kbsecbulletin kbsecurity KB2696944

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com