Error "dirección de correo electrónico no se puede resolver a un ExchangePrincipal" cuando un usuario intenta ver la información de disponibilidad en Outlook

Seleccione idioma Seleccione idioma
Id. de artículo: 2697150 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Tenga en cuenta la situación siguiente:
  • El buzón del usuario 1 está alojado en Microsoft Exchange Server 2007.
  • Usuario 1 se está ejecutando Microsoft Outlook 2010.
  • Usuario 1 habilita la opción "Habilitar el registro de solución de problemas" en Outlook 2010.
  • Usuario 1 ve la información de disponibilidad para el usuario 2.
  • Se aloja el buzón para el usuario 2 Microsoft Exchange Server 2010.
  • El servidor que ejecuta Exchange Server 2010 se quita de un grupo de disponibilidad de base de datos (DAG).
  • El buzón de usuario 2 se mueve a otro servidor que ejecuta Exchange Server 2010.
  • Usuario 1 intenta ver la información de disponibilidad para el usuario 2.
En este escenario, el usuario 1 no puede ver la información de disponibilidad para el usuario 2. Además, se registra un mensaje de error similar al siguiente en el archivo de registro del servicio de disponibilidad:

<FreeBusyResponse><ResponseMessage responseclass="Error"><MessageText>La dirección de correo electrónico &lt; dominio </MessageText></ResponseMessage></FreeBusyResponse>
Usuario &gt;SMTP:User@contoso.com no se puede resolver un objeto ExchangePrincipal.<ResponseCode>ErrorMailRecipientNotFound</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey>
<MessageXml><ExceptionType xmlns=" xmlns=""></ExceptionType xmlns="></MessageXml>http://schemas.Microsoft.com/Exchange/Services/2006/Errors">Microsoft.Exchange.InfoWorker.Common.Availability.MailRecipientNotFoundException<>


xmlns = "http://schemas.Microsoft.com/Exchange/Services/2006/Errors">5009>


Causa

Este problema se produce porque el atributo msExchHomeServerName en servicios de dominio de Active Directory (AD DS) no es válido para el usuario cuyo buzón se movió.

Solución

Para resolver este problema, utilice uno de los métodos siguientes:

Método 1: Actualizar el valor de msExchHomeServerName para el usuario

Para resolver este problema, actualizar el valor de msExchHomeServerName para el usuario cuyo buzón se movió. Para ello, siga estos pasos:
  1. Edición inicio Active Directory Service Interfaces (ADSI).
  2. Expanda (Contexto de nomenclatura predeterminadonombreDeServidor)y, a continuación, expanda DC =DominioDC = com.
  3. Haga clic en Usuarios.
  4. Haga clic en el usuario que desee y, a continuación, haga clic en Propiedades.
  5. Bajo Atributo, haga clic en msExchHomeServerNamey, a continuación, haga clic en Editar.
  6. Haga clic en Borrar, utilice una copia y pega o escriba el atributo legacyExchangeDN del nuevo nombre de servidor de buzón y, a continuación, haga clic en ACEPTAR. Por ejemplo, escriba lo siguiente:

    / o = EXORG/ou = grupo administrativo de Exchange (exchange_group_name) / cn = Configuration/cn = Servers/cn =mailbox_server_name

    Nota Se recomienda copiar y pegar el valor legacyExchangeDN de un buzón diferente en el mismo servidor para evitar los errores.
  7. Salga de edición de ADSI.
Método 2: Ejecuta el cmdlet Get-ADUser

Para resolver este problema, ejecute el cmdlet Get-ADUser . Para ello, en el símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:
Import-Module ActiveDirectory
Get-ADUser-propiedades msExchHomeServerName - filtroLDAP "(msExchHomeServerName = * old_mailbox_server)" | Conjunto-AdUser-reemplazar @{msExchHomeServerName ='/ o = dominio/ou = Exchange Administrative Group (Exchange_administrative_group/cn = Configuration/cn = Servers/cn = new_mailbox_server'}
Nota El cmdlet Get-ADUser está disponible en Windows Server 2008 R2 y versiones posteriores cuando se ejecuta el comando Import-Module ActiveDirectory .


Más información

Exchange Server 2007 consulta AD DS para el valor de msExchHomeServerName para determinar la ubicación del buzón y el servidor de acceso de cliente (CAS).El atributo msExchHomeServerName se rellena con el nombre de servidor que aloja el buzón cuando se crea el buzón.

El atributo msExchHomeServerName no se actualiza cuando se mueve una base de datos a un servidor diferente. Por lo tanto, las entidades Emisoras de Exchange Server 2007 no puede determinar las entidades Emisoras correcta para la solicitud de disponibilidad.

Referencias

Para obtener más información acerca de cómo iniciar el servicio de disponibilidad, visite el siguiente sitio Web de Microsoft:
http://Office.Microsoft.com/en-us/Outlook-Help/What-is-the-Enable-Logging-Troubleshooting-Option-HA010356489.aspx
Para obtener más información acerca del cmdlet Get-ADUser , visite el siguiente sitio Web de TechNet:
http://technet.Microsoft.com/en-us/library/ee617241.aspx
Para obtener más información sobre el comando Import-Module ActiveDirectory , visite el siguiente sitio Web de TechNet:
http://technet.Microsoft.com/en-us/library/dd378937 (v=ws.10) .aspx

Propiedades

Id. de artículo: 2697150 - Última revisión: jueves, 27 de septiembre de 2012 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2010 Coexistence
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Service Pack 1
  • Microsoft Exchange Server 2010 Service Pack 2
  • Microsoft Exchange Server 2010 Standard
Palabras clave: 
kbsurveynew kbtshoot kbprb kbmt KB2697150 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2697150

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com