Erro "endereço de email não pôde ser resolvido para um ExchangePrincipal" quando um usuário tenta exibir informações de disponibilidade no Outlook

Traduções deste artigo Traduções deste artigo
ID do artigo: 2697150 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Caixa de correio de usuário 1 é hospedada no Microsoft Exchange Server 2007.
  • O usuário 1 está executando o Microsoft Outlook 2010.
  • O usuário 1 habilita a opção "Habilitar o log de solução de problemas" no Outlook 2010.
  • Usuário 1 exibe as informações de disponibilidade para o usuário 2.
  • Caixa de correio de usuário 2 está hospedada em Microsoft Exchange Server 2010.
  • O servidor que está executando o Exchange Server 2010 é removido de um grupo de disponibilidade do banco de dados (DAG).
  • Caixa de correio de usuário 2 é movida para outro servidor que esteja executando o Exchange Server 2010.
  • O usuário 1 tenta exibir as informações de disponibilidade para o usuário 2.
Nesse cenário, o usuário 1 não pode exibir as informações de disponibilidade para o usuário 2. Além disso, uma mensagem de erro semelhante à seguinte é registrada no arquivo de log do serviço de disponibilidade:

<FreeBusyResponse><ResponseMessage responseclass="Error"><MessageText>O endereço de email &lt; domínio </MessageText></ResponseMessage></FreeBusyResponse>
Usuário &gt;SMTP:User@Contoso.com não pôde ser resolvido para um objeto ExchangePrincipal.<ResponseCode>ErrorMailRecipientNotFound</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey>
<MessageXml><ExceptionType xmlns=" xmlns=""></ExceptionType xmlns="></MessageXml>http://schemas.microsoft.com/Exchange/Services/2006/errors">Microsoft.Exchange.InfoWorker.Common.Availability.MailRecipientNotFoundException<>


xmlns = "http://schemas.microsoft.com/Exchange/Services/2006/errors">5009>


Causa

Esse problema ocorre porque o atributo msExchHomeServerName nos serviços de domínio Active Directory (AD DS) não é válido para o usuário cuja caixa de correio foi movida.

Resolução

Para resolver esse problema, use um dos seguintes métodos:

Método 1: Atualizar o valor msExchHomeServerName do usuário

Para resolver esse problema, atualize o valor msExchHomeServerName do usuário cuja caixa de correio foi movida. Para fazer isso, siga estes passos:
  1. Editar início Active Directory Service Interfaces (ADSI).
  2. Expandir (Contexto de nomenclatura padrãoservername)e em seguida, expanda DC =domínioDC = com.
  3. Clique em Usuários.
  4. Clique com o botão direito do usuário que deseja e clique em Propriedades.
  5. Em Atributo, clique em msExchHomeServerNamee clique em Editar.
  6. Clique em Limpar, use uma cópia e colar operação ou digite legacyExchangeDN do novo nome de servidor de caixa de correio e clique em OK. Por exemplo, digite o seguinte:

    /o = EXORG/ou = (grupo administrativo do Exchangeexchange_group_name) / cn = configuração/cn = servidores/cn =mailbox_server_name

    Observação Recomendamos que você copie e cole o legacyExchangeDN da outra caixa de correio no mesmo servidor para evitar erros.
  7. Saia do ADSI Edit.
Método 2: Executar o cmdlet Get-ADUser

Para resolver esse problema, execute o cmdlet Get-ADUser . Para isso, no prompt de comando, digite o seguinte comando e pressione Enter:
Módulo de importação ActiveDirectory
Get-ADUser-propriedades msExchHomeServerName - FiltroLDAP "(msExchHomeServerName = * old_mailbox_server)" | Conjunto AdUser-substituir @{msExchHomeServerName =' /o = domínio/ou = grupo administrativo do Exchange (Exchange_administrative_group/cn = configuração/cn = servidores/cn = new_mailbox_server'}
Observação O cmdlet Get-ADUser está disponível no Windows Server 2008 R2 e versões posteriores, quando você executar o comando Import-Module ActiveDirectory .


Mais Informações

Exchange Server 2007 consultas AD DS para o valor msExchHomeServerName para determinar o local da caixa de correio e o servidor de acesso para cliente (CAS).O atributo msExchHomeServerName é preenchido usando o nome do servidor que hospeda a caixa de correio quando a caixa de correio é criada.

O atributo msExchHomeServerName não é atualizado quando um banco de dados é movido para um servidor diferente. Portanto, CAS Exchange Server 2007 não é possível determinar o CAS correto para a solicitação de disponibilidade.

Referências

Para obter mais informações sobre o log do serviço de disponibilidade, visite o seguinte site da Microsoft:
http://Office.microsoft.com/en-US/Outlook-Help/What-is-the-Enable-Logging-Troubleshooting-Option-HA010356489.aspx
Para obter mais informações sobre o cmdlet Get-ADUser , visite o seguinte site do TechNet:
http://technet.microsoft.com/en-us/library/ee617241.aspx
Para obter mais informações sobre o comando Import-Module ActiveDirectory , visite o seguinte site do TechNet:
. aspx http://technet.microsoft.com/en-us/library/dd378937 (v=ws.10)

Propriedades

ID do artigo: 2697150 - Última revisão: quinta-feira, 27 de setembro de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2010 Coexistence
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Service Pack 1
  • Microsoft Exchange Server 2010 Service Pack 2
  • Microsoft Exchange Server 2010 Standard
Palavras-chave: 
kbsurveynew kbtshoot kbprb kbmt KB2697150 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2697150

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com