"E-mailová adresa neidentifikovateľná na ExchangePrincipal" chyba, keď sa používateľ pokúsi zobraziť informácie voľnom v programe Outlook

Preklady článku Preklady článku
ID článku: 2697150 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Priznaky

Uvažujme o nasledujúcom prípade:
  • Poštovú schránku používateľa 1 je hosťované na serveri Microsoft Exchange Server 2007.
  • Používateľ 1 je spustený program Microsoft Outlook 2010.
  • Používateľ 1 umožňuje možnosť "Zapnúť zapisovanie riešenie problémov" v programe Outlook 2010.
  • Používateľ 1 názory informácie voľnom používateľ 2.
  • Poštovú schránku používateľa 2 je hosťované na serveri Microsoft Exchange Server 2010.
  • Server so spustenou službou Exchange Server 2010 je odstránený z databáza dostupnosť Group (DAG).
  • Poštovú schránku používateľa 2 je presunutý na iný server so spustenou službou Exchange Server 2010.
  • Používateľ 1 sa pokúša Zobraziť informácie voľnom používateľ 2.
V takomto prípade 1 používateľ nemôže zobraziť informácie voľnom používateľ 2. Okrem toho chybové hlásenie podobné nasledujúcemu prihlásený v súbore denníka dostupnosť služby:

<FreeBusyResponse><ResponseMessage responseclass="Error"><MessageText>E-mailová adresa &lt; doména </MessageText></ResponseMessage></FreeBusyResponse>
Užívateľ &gt;SMTP:user@contoso.com sa nepodarilo vyriešiť k ExchangePrincipal objektu.<ResponseCode>ErrorMailRecipientNotFound</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey>
<MessageXml><ExceptionType xmlns=" xmlns=""></ExceptionType xmlns="></MessageXml>http://schemas.Microsoft.com/Exchange/Services/2006/errors">Microsoft.Exchange.InfoWorker.common.Availability.MailRecipientNotFoundException<>


xmlns = "http://schemas.Microsoft.com/Exchange/Services/2006/errors">5009>


Pricina

Tento problém sa vyskytuje, pretože atribút msExchHomeServerName v Doménové služby Active Directory (AD DS) nie je platný pre používateľa, ktorého poštová schránka bolo presunuté.

Riesenie

Ak chcete vyriešiť tento problém, použite jednu z nasledovných metód:

Metóda 1: Aktualizovať msExchHomeServerName hodnotu pre užívateľa

Ak chcete vyriešiť tento problém, aktualizujte msExchHomeServerName hodnotu pre užívateľa, ktorého poštová schránka bolo presunuté. Chcete urobiť, postupujte nasledovne:
  1. Štart Active Directory Service rozhrania upraviť.
  2. Rozšíriť Predvolený názvový kontext)názov_servera), a potom rozbaľte položku DC =doménuDC = com.
  3. Kliknite na tlačidlo Užívatelia.
  4. Kliknite pravým tlačidlom myši na užívateľa, ktorého chcete, a potom kliknite Vlastnosti.
  5. Pod Atribút, kliknite na msExchHomeServerName, a potom kliknite Upraviť.
  6. Kliknite na tlačidlo Jasné, používať kópiu vložiť operácie alebo zadajte legacyExchangeDN nový názov poštovej schránky servera a potom kliknite ok. Napríklad, zadajte:

    / o = EXORG/ou = administratívne skupiny Exchange ()exchange_group_name) / cn = Configuration/KN = servery/KN =mailbox_server_name

    Poznámka Odporúčame, že skopírujete a prilepíte legacyExchangeDN z rôznych schránky na rovnakom serveri, aby sa zabránilo akejkoľvek chyby.
  7. Ukončite program ADSI Edit.
Metóda 2: Spustením rutiny cmdlet Get-ADUser

Ak chcete vyriešiť tento problém, spustením rutiny cmdlet Get-ADUser . To sa, do príkazového riadka zadajte nasledovný príkaz a stlačte kláves Enter:
Import modul ActiveDirectory
Get-ADUser-vlastnosti msExchHomeServerName - LDAPFilter "(msExchHomeServerName = * old_mailbox_server)" | Set-AdUser-nahradiť @{msExchHomeServerName = "/ o = domény/ou = administratívne skupiny Exchange (Exchange_administrative_group/cn = Configuration/KN = servery/KN = new_mailbox_server"}
Poznámka Rutiny cmdlet Get-ADUser je k dispozícii v systéme Windows Server 2008 R2 a novších verziách, pri spustení príkazu Import modulu ActiveDirectory .


dalsie informacie

Exchange Server 2007 zisťuje AD DS pre hodnotu msExchHomeServerName určiť umiestnenie schránky a server klientskeho prístupu (CAS).Atribút msExchHomeServerName je obývaný pomocou názvu servera, ktorý hosťuje poštovej schránky po vytvorení poštovú schránku.

Atribút msExchHomeServerName nie je aktualizovaný, keď databáza je presunutý na iný server. Preto, Exchange Server 2007 CAS nemôže určiť správny CAS na požiadavku dostupnosti.

ODKAZY

Ďalšie informácie o dostupnosti služby prihlásením, navštívte nasledujúce webovú lokalitu spoločnosti Microsoft:
http://Office.Microsoft.com/en-us/Outlook-help/What-is-the-Enable-logging-Troubleshooting-option-HA010356489.aspx
Ďalšie informácie o Get-ADUser cmdlet, navštívte nasledujúce webovú lokalitu TechNet:
http://technet.Microsoft.com/en-us/library/ee617241.aspx
Ďalšie informácie o príkaze Import modul ActiveDirectory , navštívte nasledujúce webovú lokalitu TechNet:
http://technet.Microsoft.com/en-us/library/dd378937 (v=ws.10) .aspx

Vlastnosti

ID článku: 2697150 - Posledná kontrola: 27. septembra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Exchange Server 2010 Coexistence
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Service Pack 1
  • Microsoft Exchange Server 2010 Service Pack 2
  • Microsoft Exchange Server 2010 Standard
Kľúčové slová: 
kbsurveynew kbtshoot kbprb kbmt KB2697150 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2697150

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com