FIX: Error message when you try to export your configuration settings in Forefront Unified Access Gateway 2010 SP1: "Unspecified error"

Article translations Article translations
Article ID: 2697188 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When you try to export your configuration settings in Microsoft Forefront Unified Access Gateway (UAG) 2010 Service Pack 1 (SP1) to an XML file, the export fails. Additionally, you may receive the following error message:

Unspecified error

Cause

This problem occurs because, as part of the export process, the Forefront UAG configuration tries to parse the XML file that is created. When the configuration includes files in custom update folders, those files are included in the XML file. Depending on how much memory is available, the parsing of the XML file may fail.

Resolution

To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:
2710791 Description of Service Pack 2 for Forefront Unified Access Gateway 2010
To prevent the configuration from parsing the .xml file during the export process, set the following DWORD registry value:

Registry location:
HKEY_LOCAL_MACHINE\Software\WhaleCom\e-Gap\Configuration
DWORD: ExportXmlSuppressParse
Value: 1
Notes
  • Set this value to 1 to disable XML parsing during the export process.
  • Set this value to 0 to enable XML parsing during the export process.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about how to export the Forefront UAG configuration settings, visit the following Microsoft TechNet website:

Backing up and restoring with export and import

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 2697188 - Last Review: December 7, 2012 - Revision: 4.0
Applies to
  • Microsoft Forefront Unified Access Gateway 2010 Service Pack 1
Keywords: 
kbqfe kbfix kbexpertiseinter kbbug kbsurveynew KB2697188

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com