Differences Between "Bytes Sent/Sec" and "Bytes Received/Sec" Counters

Article translations Article translations
Article ID: 269738 - View products that this article applies to.
This article was previously published under Q269738
Expand all | Collapse all

On This Page

SYMPTOMS

When you measure the performance of the computers in your environment, you might find that the "Bytes Sent/sec" counter for the Network Interface object is off by a magnitude of 8 to 10 from the "Bytes Received/sec" counter when the same amount of data is exchanged in both directions.

There are other counters that measure network throughput, such as the "Bytes Transmitted/sec" and "Bytes Received/sec" Server object counters. These should be in the same range as the Network Interface counters.

Currently, this problem has only been seen in a mixed Fast Ethernet and Gigabit Ethernet environment.

CAUSE

Some network adapter drivers do not set all of the fields in the packet information correctly. In this case, a member of this structure does not have the right information; therefore, incorrect results are reported by Address Resolution Protocol (ARP). With this hotfix, ARP uses a field that is required to have the correct information.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Windows 2000

The English version of this fix should have the following file attributes or later:
   Date        Time    Version        Size     File name
   ---------------------------------------------------------
   12/05/2000  06:51a  5.0.2195.2778  123,184  Afd.sys
   12/05/2000  06:51a  5.0.2195.2779  107,280  Msafd.dll
   12/05/2000  06:51a  5.0.2195.2785  323,088  Tcpip.sys
   12/05/2000  06:51a  5.0.2195.2772   16,240  Tdi.sys
   12/05/2000  06:51a  5.0.2195.2104   17,680  Wshtcpip.dll
				

Windows NT 4.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time    Version        Size     File name  Platform   
   ---------------------------------------------------------------
   07/31/2000  05:05p  4.0.1381.7086  174,640  Tcpip.sys  Intel
   07/31/2000  05:04p  4.0.1381.7086  308,688  Tcpip.sys  Alpha
				

STATUS

Windows 2000

Microsoft has confirmed that this is a problem in Windows 2000. This problem was first corrected in Windows 2000 Service Pack 2.

Windows NT 4.0

Microsoft has confirmed that this is a problem in Windows NT 4.0.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

Properties

Article ID: 269738 - Last Review: February 20, 2007 - Revision: 2.4
APPLIES TO
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT 4.0 Service Pack 6a
Keywords: 
kbbug kbfix kbwin2000presp2fix kbqfe kbhotfixserver KB269738

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com