"Nie można uruchomić aplikacji. Skontaktuj się z dostawcą aplikacji" podczas uruchamiania instalatora programu Microsoft 365 Desktop

Problem

Podczas próby uruchomienia aplikacji ClickOnce platformy Microsoft 365, takiej jak Microsoft 365 Desktop Setup lub Microsoft 365 Desktop Readiness Tool, zostanie wyświetlony następujący komunikat o błędzie:

Nie można uruchomić aplikacji. Skontaktuj się z dostawcą aplikacji.

Zrzut ekranu przedstawiający komunikat o błędzie w oknie dialogowym Nie można uruchomić aplikacji.

Po kliknięciu przycisku Szczegóły zostanie wyświetlony szczegółowy komunikat o błędzie podobny do następującego:

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of https://<NameOfDomain>/ClickOnceConnector/Office365DesktopSetup.application resulted in exception. Following failure messages were detected:
+ Unable to install this application because an application with the same identity is already installed. To install this application, either modify the manifest version for this application or uninstall the preexisting application.

Przyczyna

Ten problem występuje, jeśli aplikacja została zapisana w pamięci podręcznej aplikacji ClickOnce. Aby można było pomyślnie uruchomić aplikację, należy ją usunąć z pamięci podręcznej.

Rozwiązanie

Aby wyczyścić pamięć podręczną aplikacji ClickOnce, wykonaj następujące kroki:

  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz ciąg cmd, a następnie kliknij przycisk OK.
  2. Wpisz następujące polecenie, a następnie naciśnij klawisz Enter: rundll32 dfshim CleanOnlineAppCache

Aby sprawdzić, czy problem został rozwiązany, wykonaj następujące kroki:

Więcej informacji

Aby uzyskać więcej informacji, zobacz Dokumentacja niezarządzanego interfejsu API ClickOnce.

Nadal potrzebujesz pomocy? Przejdź do witryny internetowej https://go.microsoft.com/fwlink/?linkid=2003907 .