When you use Microsoft Dynamics CRM 2011, Internet Explorer 9 may reload and cause CRM to crash

Article ID: 2698959 - View products that this article applies to.
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SYMPTOMS

When you open or close Microsoft Dynamics CRM 2011 records, the CRM application may crash and Internet Explorer reloads. A script error may also occur, similar to below:

<Message>Object doesn't support this property or method</Message>

or

<Message>'lookupstyle' is null or not an object</Message>


Please see More Information for additional script detail

CAUSE

This is caused by the Internet Explorer 9 Hang Resistance Feature. The Hang Resistance feature is enabled by default in Windows Internet Explorer 9. Setting the HangRecovery value to 0 disables this feature; setting it to 1 enables it.

RESOLUTION

As a workaround, to have us disable the Hang Resistance feature for you, go to the "Fix it for me" section. If you prefer to disable the Hang Resistance feature yourself, go to the "Let me fix it myself" section.

Fix it for me



To disable the Hang Resistance feature automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50893


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

As a workaround, use the steps below to disable this feature:

1. Point to the Start menu, click Run, and then type regedit.
2. Navigate to HKEY_Current_User\Software\Microsoft\Internet Explorer\Main
3. Right-click Main, and then select new DWORD (32-bit) Value
4. Enter HangRecovery as the name.
5. The default value will be 0.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

MORE INFORMATION

A webpage or an ActiveX control that is hosted on a webpage may stop receiving the focus intermittently in Internet Explorer 9
http://support.microsoft.com/kb/2633864


A web page may fail to get focus in Windows Internet Explorer 9
http://support.microsoft.com/kb/2600156


<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>Object doesn't support this property or method</Message>
<Line>53</Line>
<URL>/_static/_forms/controls/form.crm.htc?ver=1272624968</URL>
<PageURL>/userdefined/edit.aspx?_gridType=1&etc=1&id=%7b882F4C68-14EE-E011-BDA0-00155D9D3D22%7d&pagemode=iframe&rskey=759356843&sitemappath=Workplace%7cMyWork%7cnav_dashboards</PageURL>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<CallStack>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<Function>IsReadyToClose()</Function>
<Function>Close(oEvent)</Function>
</CallStack>


or


<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>'lookupstyle' is null or not an object</Message>
<Line>73</Line>
<URL>/_static/_forms/controls/img.lu.htc?ver=1272624968</URL>
<PageURL>/userdefined/edit.aspx?_gridType=1&etc=1&id=%7b882F4C68-14EE-E011-BDA0-00155D9D3D22%7d&pagemode=iframe&rskey=759356843&sitemappath=Workplace%7cMyWork%7cnav_dashboards</PageURL>
<Function>getDataXml(sAttributeName)</Function>
<CallStack>
<Function>getDataXml(sAttributeName)</Function>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<Function>IsReadyToClose()</Function>
<Function>Close(oEvent)</Function>
</CallStack>

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2698959 - Last Review: June 27, 2012 - Revision: 4.0
APPLIES TO
  • Microsoft Dynamics CRM 2011
Keywords: 
kbmbsmigrate kbsurveynew kbfixme kbmsifixme KB2698959

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