FIX: Incorrect XML may be generated when you try to create an updategram by using the BizTalk Adapter for Host Files

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Article ID: 2699274 - View products that this article applies to.
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SYMPTOMS

In a Microsoft Host Integration Server 2010 environment, you use the Microsoft BizTalk Adapter for Host Files that is installed by cumulative update package 3 for Host Integration Server 2010. When you try to create an updategram, incorrect XML may be generated.

Note This problem may occur when you create an INSERT, a DELETE, or an UPDATE command.

For example, when you create an INSERT command, the XML that is generated may resemble the following:
<ns0:HFTest1Request xmlns:ns0="HFTest1">
  <sync>
    <after>
      <Demo.CUSTOMER_RECORD CUSTOMER_NAME="Superman" 
             CUSTOMER_SSN="111223333" 
             CUSTOMER_STREET="101 Main Street" 
             CUSTOMER_CITY="Gotham" 
             CUSTOMER_STATE="NY" 
             CUSTOMER_ZIP="12345" 
             CUSTOMER_PHONE="5551234567" 
             CUSTOMER_ACCESS_PIN="1234">
        Demo.CUSTOMER_RECORD_0
      </Demo.CUSTOMER_RECORD>
    </after>
  </sync>
</ns0:HFTest1Request>

Regardless of the values that you use in the INSERT command, you receive an error message that resembles the following:
The adapter failed to transmit message going to send port "SendPort_HFTest1" with URL "HostFiles://URL". It will be retransmitted after the retry interval specified for this Send Port.
Details:
"The host file qualified name is invalid. A qualified name can contain up to 22 parts and have a maximum length of 44 characters."

CAUSE

This problem occurs because the host file data provider does not trim the host file name of spaces.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: 
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have cumulative update package 3 for Host Integration Server 2010 installed to apply this hotfix.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2654652 Cumulative update package 3 for Host Integration Server 2010

Restart information

You have to stop and then restart any BizTalk Host Instances that use the host file provider after you apply this hotfix.

Replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For Host Integration Server 2010, 32-bit edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.hostintegration.adapters.mshostfile.management.dll8.5.4495.2399,28810-Apr-201213:31x86
For Host Integration Server 2010, 64-bit edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Adloc.dll8.5.4224.030,54410-Apr-201213:40x86
Dtcwrapper.dllNot Applicable55,12810-Apr-201213:40x86
Fmistr32.dll8.5.4224.017,74410-Apr-201213:40x86
Microsoft.hostintegration.adapters.mshostfile.management.dll8.5.4495.2399,28810-Apr-201213:40x86
Snadmod.dll8.5.4224.0837,45610-Apr-201213:40x86
Snadump.dll8.5.4224.016,20810-Apr-201213:40x86
Snaip.dll8.5.4224.0124,75210-Apr-201213:40x86
Snaip6.dll8.5.4224.0124,75210-Apr-201213:40x86
Snalm.dll8.5.4224.071,50410-Apr-201213:40x86
Snareg.dll8.5.4224.051,02410-Apr-201213:40x86
Snasvc.dll8.5.4224.015,69610-Apr-201213:40x86
Snatrc.dll8.5.4224.079,69610-Apr-201213:40x86
Snatrcsn.dll8.5.4224.055,12010-Apr-201213:40x86
Wappc32.dll8.5.4224.0198,48010-Apr-201213:40x86
Wcpic32.dll8.5.4224.0112,46410-Apr-201213:40x86
Winappc.dll8.5.4224.011,60010-Apr-201213:40x86
Wincsv32.dll8.5.4224.051,02410-Apr-201213:40x86
Winmgt32.dll8.5.4224.067,40810-Apr-201213:40x86
Winrui32.dll8.5.4224.0100,17610-Apr-201213:40x86
Winsli32.dll8.5.4224.0120,65610-Apr-201213:40x86
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.


WORKAROUND

To work around this problem, remove the leading and trailing spaces in your host file name as follows:
CUSTOMER_ACCESS_PIN="1234">Demo.CUSTOMER_RECORD_0</Demo.CUSTOMER_RECORD>
For example, the INSERT command in the scenario that is described in the "Symptoms" section should resemble the following:
<ns0:HFTest1Request xmlns:ns0="HFTest1">
  <sync>
    <after>
      <Demo.CUSTOMER_RECORD CUSTOMER_NAME="Superman" 
             CUSTOMER_SSN="111223333" 
             CUSTOMER_STREET="101 Main Street" 
             CUSTOMER_CITY="Gotham" 
             CUSTOMER_STATE="NY" 
             CUSTOMER_ZIP="12345" 
             CUSTOMER_PHONE="5551234567" 
             CUSTOMER_ACCESS_PIN="1234">Demo.CUSTOMER_RECORD_0</Demo.CUSTOMER_RECORD>
    </after>
  </sync>
</ns0:HFTest1Request>

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2699274 - Last Review: May 1, 2012 - Revision: 1.0
APPLIES TO
  • Microsoft Host Integration Server 2010
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseinter kbsurveynew kbbug KB2699274

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