PRJ : Description du Format Exchange de fichier MPX Project

Traductions disponibles Traductions disponibles
Numéro d'article: 270139 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Le format de fichier MPX 4.0 est un format de fichier ASCII que vous pouvez utiliser pour transférer des informations de projet entre différentes versions de Microsoft Project ainsi que des programmes tiers qui prennent en charge le format de fichier MPX, comme le Planificateur de projet Primavera et estimation de Precision Timberline.

Le fichier Mpxfile.wri (Windows) et le fichier de format de fichier MPX (Macintosh) indiquent le format des fichiers MPX 4.0 créés dans Microsoft Project, versions 4.0, 4.1 et 98. Vous trouverez ces fichiers dans le dossier où vous avez installé Microsoft Project version 4.0 ou 4.1. La section "Informations supplémentaires" de cet article contient le texte complet du fichier Mpxfile.wri. (Remarque : le fichier Mpxfile.wri n'est pas inclus dans Microsoft Project 98 ou Microsoft Project 2000.)

Le tableau suivant résume les versions de Microsoft Project qui peuvent de créer ou de lire le format de fichier MPX 4.0 :
                                     Create      Read
                                     ----------------
      Microsoft Project 4.0          Yes         Yes
      Microsoft Project 4.1          Yes         Yes
      Microsoft Project 98           Yes         Yes
      Microsoft Project 2000         No          Yes
				
le convertisseur Microsoft Project est un programme Windows que vous pouvez utiliser pour convertir des fichiers créés dans le logiciel de gestion de projet de fournisseur tiers au format MPX 4.0. Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la base de connaissances Microsoft :
130206PRJ : Convertisseur de Microsoft Project pour Project 4.0 et 4.1
221256PRJ : Mise à jour du convertisseur de projet pour ABT Project Workbench 4.x
Pour savoir comment résoudre les messages d'erreur qui se produisent lorsque vous ouvrez un fichier MPX qui contient des données non valides, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
141261PRJ : Comment faire pour interpréter le message reçu lors de l'ouverture du fichier .mpx

Plus d'informations

Voici le texte complet du fichier Mpxfile.wri.

D'après le format de fichier MPX

A propos du format de fichier MPX

Le format de fichier MPX est un format de fichier ASCII qui vous permet de transférer des informations de projet entre Microsoft Project et autres applications qui prennent en charge le format de fichier MPX, comme le Planificateur de projet Primavera et estimation de Precision Timberline. Le format de fichier MPX vous permet des informations de projet de transfert qui ne peut pas apparaître dans une table, telles que les informations d'affectations de ressource détaillée, les informations de calendrier ou des informations dans la boîte de dialogue informations de projet.

Avant d'enregistrer un fichier Microsoft Project dans le format de fichier MPX, vérifiez que l'application à laquelle vous souhaitez transférer les informations de votre projet peut interpréter le format MPX. Dans certains cas, il se peut que vous deviez exécuter un programme de conversion avant d'utiliser votre fichier dans l'autre application.

Microsoft Project peut également ouvrir des fichiers enregistrés au format de fichier MPX. Microsoft Project version 4.1 pour Windows 95 peut ouvrir et enregistrer les fichiers Microsoft Project version 1.0, 3.0, 4.0 et 4.1 MPX.

Vous ouvrez un fichier comme n'importe quel autre fichier Microsoft Project. Lorsque vous ouvrez un fichier, vous pouvez fusionner le fichier dans le projet actif ou placer les informations dans un nouveau projet. Si vous choisissez Fusionner les fichiers et que vous utilisez des identificateurs uniques, les informations dans le nouveau fichier remplacent les informations de l'enregistrement correspondant. Vous pouvez créer des fichiers MPX contenant uniquement cette informations que vous souhaitez fusionner dans le projet existant, ainsi que les affectations de ressources. Par exemple, vous pouvez créer un fichier MPX qui contient uniquement les informations de coût qui ont changé. En incluant l'ID unique et le nouveau coût pour cet ensemble de ressources, seulement ces informations sont remplacées dans votre projet.

Pour enregistrer un fichier au format MPX, consultez l'exportation, un projet de fichier dans MPX format rubrique aide en ligne. Lorsque vous exportez un fichier MPX, vous ne spécifiez pas une table car les tables d'exportation tâches et les ressources sont automatiquement utilisés. Si vous supprimez les tables d'exportation de global.mpt, vous ne pourrez pas exporter un fichier MPX, sauf si vous copiez les tables d'exportation à partir de votre fichier de sauvegarde globale à votre projet en cours ou de global.mpt.

Vous pouvez modifier les tables d'exportation en choisissant des tables dans le menu Affichage, plus de tables de choix, en sélectionnant Exporter et cliquer sur le bouton Modifier ; toutefois, vous devez le faire uniquement si vous demande de l'application dans lequel vous transférez les informations exportées. Les tables d'exportation fournis avec Microsoft Project sont les tables standard utilisées par la plupart des applications qui prennent en charge le format de fichier MPX.

Si les tâches ou les ressources entrant inclure le numéro d'identification unique dans la position du premier ou deuxième et fusion de deux fichiers, Microsoft Project fusionne les informations dans l'enregistrement correspondant, si aucune correspondance n'est trouvée, un nouvel enregistrement est créé à la fin des tâches ou ressources. Si vous fusionnez pas le fichier que vous ouvrez et les tâches entrants ou les ressources incluent un numéro d'ID au premier champ, Microsoft Project insère chaque tâche ou ressource dans la ligne avec le numéro d'identification correspondante afin que le numéro d'identification de chaque tâche ou ressource dans Microsoft Project est le même que le numéro d'identification d'origine. Si le fichier entrant ignore un numéro d'identification, la ligne de tâche ou ressource portant ce numéro d'identification est laissée vide afin que vous pouvez importer des lignes vides entre les tâches ou ressources.

Les différences suivantes existent entre fichiers version 3.0 de Microsoft Project MPX et fichiers MPX la version 4.0 et 4.1 :

-Lorsque vous ouvrez un fichier dans Microsoft Project, vous obtenez n'est plus invité à fusionner le fichier dans le projet existant par défaut. Si vous souhaitez fusionner les informations dans le fichier dans le fichier en cours vous devez le spécifier à dans la liste des paramètres de la commande FileOpen. Pour obtenir des instructions sur la pour ce faire, recherchez format de fichier MPX de fusion dans l'aide.

-Un nouvel enregistrement a été ajouté pour stocker les informations utilisées par les fonctions de groupe de travail.

-Un nouvel enregistrement a été ajouté pour stocker des informations sur les tâches récurrentes.

-Le paramètre de position du symbole dans l'enregistrement de paramètres de devise, désormais prend en charge un espace entre le symbole monétaire et le nombre.

-Remarque : il n'y a aucune différence entre le format de fichier MPX pour Microsoft Project version 4.1 pour Windows 95 et le format de fichier MPX pour Microsoft Project version 4.0.

Spécifications de format de fichier MPX

Cette section est destinée aux développeurs qui créent des programmes utilitaires pour le transfert des informations entre une autre application et Microsoft Project. Si vous transférez des fichiers MPX entre Microsoft Project et une autre application gérant déjà le format de fichier MPX, vous pouvez lire cette section.

Un fichier MPX est constitué d'enregistrements séparés par des retours chariot et de ligne de flux. Dans chaque enregistrement sont des champs qui contiennent les informations du projet. Les types d'enregistrements et l'ordre de ces enregistrements sont définies. Le tableau suivant répertorie tous les types d'enregistrements, le numéro d'enregistrement permettant d'identifier chaque type d'enregistrement et le nombre d'enregistrements de chaque type peuvent être inclus dans le fichier MPX. Le fichier ne dispose pas contenir tous les types d'enregistrements ; la seule enregistrement requis est l'enregistrement de création d'un fichier. Tous les enregistrements inclus dans le fichier MPX doivent être dans l'ordre indiqué dans le tableau, sauf que les enregistrements de commentaires peuvent être insérés n'importe où dans le fichier.
Record name                        Record number   Maximum number of Records
----------------------------------------------------------------------------
File Creation (required)           none            1
Currency Settings                  10              1
Default Settings                   11              1
Date and Time Settings             12              1
Base Calendar Definition           20              250
Base Calendar Hours                25              7 per Base Calendar
                                                   Definition record
Base Calendar Exception            26              250 per Base Calendar
                                                   Definition record
Project Header                     30              1
Text Resource Table Definition     40              1
  (Or you can use the Numeric Resource Table Definition record)
Numeric Resource Table Definition  41              1
Resource                           50              9,999
Resource Notes                     51              1 per Resource record
Resource Calendar Definition       55              1 per Resource record
Resource Calendar Hours            56              7 per Resource Calendar
                                                   Definition record
Resource Calendar Exception        57              250 per Resource Calendar
                                                   Definition record
Text Task Table Definition         60              1
  (Or you can use the Numeric Task Table Definition record)
Numeric Task Table Definition      61              1
Task                               70              9,999
Task Notes                         71              1 per Task record
Recurring Task                     72              1 per Task record
Resource Assignment                75              100 per Task record
Assignment Workgroup fields        76              1 per Assignment record
Project Names                      80              500
DDE and OLE Client Links           81              500
Comments                           0               unlimited
				
Remarque
Certains enregistrements dans le fichier doivent suivre les autres enregistrements. Les enregistrements dans le tableau précédent qui répertorient un nombre maximal «par «l'enregistrement précédent doivent être répertoriés immédiatement après cet enregistrement. Par exemple, jusqu'à 100 ressources affectations vous pouvez préciser par enregistrement de tâche. Si une tâche 10 affectations de ressources, ces 10 enregistrements d'affectation des ressources doivent être situé immédiatement après cet enregistrement de tâche et avant la prochaine tâche Enregistrer.

Un fichier MPX commence toujours par l'enregistrement de la création de fichiers ; cet enregistrement identifie le format de fichier (MPX), le caractère séparateur de liste utilisé pour séparer les champs dans ces enregistrements, l'application et le numéro de version utilisé pour créer le MPX de fichiers, la version de format MPX utilisé par le fichier et la page de codes utilisée pour créer le fichier. Chaque enregistrement, à l'exception de l'enregistrement de la création de fichiers, débute par le numéro d'enregistrement. Le numéro d'enregistrement est suivi du caractère séparateur de liste et les informations pour chacun des champs ; chaque champ est séparé par le caractère séparateur de liste.

Les règles générales pour le contenu du champ sont les suivantes :

-Les champs calculés est inutile être importés car ils sont ignorés.

-Si le caractère séparateur de liste, généralement une virgule ou un point-virgule, est inclus dans un champ, par exemple, pour séparer les prédécesseurs, le champ est placé entre guillemets.

-Si un champ contient un guillemet, deux guillemets sont utilisés.

-Le caractère séparateur de liste n'ont pas besoin d'être inclus pour les champs vides à la fin d'un enregistrement.

-Le caractère séparateur de liste doit être inclus dans les champs vides entre les champs qui contiennent des informations.

-Lors de l'exportation d'un fichier Microsoft Project au format MPX, dates et heures sont écrits dans le format de date par défaut pour la table d'exportation. Microsoft Project peut importer les dates entrées dans un des formats de dates affichées dans la boîte de dialogue Options. Pour informations sur les formats de date et heure, recherchez Microsoft Project aide les dates d'et consultez la rubrique dates.

-Microsoft Project ignore l'espace blanc (espaces et les tabulations) au début et à la fin des champs lorsque vous importez un fichier MPX.

-Vides champs importés ne remplacent pas les informations existantes lors de la fusion de fichiers MPX.

L'ordre et le contenu exact des champs dans chaque enregistrement sont décrits dans les définitions d'enregistrement suivantes. Le numéro d'enregistrement permettant d'identifier le type d'enregistrement suit le nom de l'enregistrement. L'exemple de chaque définition d'enregistrement utilise une virgule comme séparateur de liste.

Création de fichiers - aucun numéro d'enregistrement   Il s'agit d'un enregistrement requis qui identifie le format de fichier (MPX), le caractère séparateur de liste utilisé dans le fichier, le programme et le numéro de version utilisé pour créer le fichier, le numéro de version du format de fichier MPX utilisé dans le fichier et la page de codes utilisée pour créer le fichier. Ce doit être le premier enregistrement dans le fichier. Lors de l'exportation à partir de Microsoft Project, le caractère séparateur de liste est spécifié dans l'élément de paramètres régionaux dans le panneau de configuration de Windows.

Les champs inclus dans cet enregistrement sont les suivants :
-MPX suivie immédiatement par le caractère séparateur de liste
-Nom/Identificateur de programme
-Numéro de version du fichier
-Code Page (850, 437, MAC, ANSI)

Exemple : MPX, Microsoft Project 3.0

Cet exemple montre comment spécifier que la virgule est utilisée comme séparateur de liste dans ce fichier MPX et la version du format MPX utilisé dans le fichier est exportée à partir de Microsoft Project version 3.0.

Paramètres de devise - 10   Cet enregistrement spécifie les paramètres pour les options de devise dans la boîte de dialogue Options. Si vous incluez des valeurs monétaires dans votre fichier d'importation, spécifiez les paramètres de devise ici afin que les valeurs sont importées correctement. Si cet enregistrement n'est pas inclus, les paramètres en cours dans la boîte de dialogue Options sont utilisés. Pour informations sur les paramètres de devise, recherchez devise par défaut dans l'aide de Microsoft Project. Les milliers et les séparateurs de décimale sont spécifiées pour l'élément de paramètres régionaux dans le panneau de configuration Windows.

Les champs inclus dans cet enregistrement sont les suivants :
-Symbole monétaire
-Symbole Position (0 = après 1 = avant, 2 = après avec un espace, 3 = avant avec un espace)
-Devise chiffres (0,1,2)
-Des milliers séparateur
-Séparateur décimal

Exemple : 10, $, 1, 2, ",".

Cet exemple montre comment spécifier que les valeurs monétaires incluent un signe dollar ($) avant, que deux chiffres sont placées après la virgule décimale, qu'une virgule est utilisée pour séparer les milliers, et qu'un point est utilisé comme la virgule décimale. Étant donné que le caractère séparateur de liste est inclus dans le champ Séparateur des milliers, le champ est entouré de guillemets.

Paramètres - 11 par défaut   Cet enregistrement spécifie les paramètres pour les options par défaut dans la boîte de dialogue Options. Si les durées que vous importez n'incluent pas une abréviation de durée, spécifier l'unité de durée par défaut ici pour que les unités de durée sont correctes. Si cet enregistrement n'est pas inclus, les paramètres en cours dans la boîte de dialogue Options sont utilisés. Pour informations sur les options par défaut, recherchez durée par défaut dans l'aide de Microsoft Project.

Les champs inclus dans cet enregistrement sont les suivants :
-Unités de durée par défaut (0 = minutes, 1 = heures, 2 = jours, 3 = semaines)
-Type de durée par défaut (0 = ne pas fixe, 1 = fixe)
-Unités de travail par défaut (0 = minutes, 1 = heures, 2 = jours, 3 = semaines)
-Par défaut heures/jour
-Par défaut heures/semaine
-Taux Standard par défaut
-Taux des heures sup. par défaut
-Mise à jour des tâches état mises à jour ressource état (0 = non, 1 = Oui)
-Fractionner les tâches en cours (0 = non, 1 = Oui)

Exemple : 11,2,0,1,8,40, 10 ? / h 15 $ par heure, 1

Cet exemple montre comment spécifier les paramètres par défaut suivants : durées sont en jours et ne sont pas résolues, sont des unités de travail en heures, il y a huit heures dans une journée de travail et 40 heures dans une semaine de travail, le taux standard est 10 EUR de l'heure, le taux est 15 ? par heure et la mise à jour des tâches état mises à jour ressource état est activée.

Format MPX 1.0 : depuis uniquement des nombres entiers sont autorisés pour les heures/jour par défaut et les heures/semaine par défaut dans Microsoft Project version 1.0, une valeur non entière pour une de ces options est arrondie à l'entier le plus proche lorsque vous créez un fichier au format MPX 1.0. Options pas dans Microsoft Project version 1.0 ne sont pas écrites lorsque vous créez un fichier au format MPX 1.0.

Date et de l'heure - 12   Cet enregistrement spécifie les paramètres pour la date et d'options de temps dans la boîte de dialogue Options et de l'option de format de date de texte de barre dans la boîte de dialogue Mise en page. Si cet enregistrement n'est pas inclus, les paramètres en cours dans la boîte de dialogue Options sont utilisés. Pour informations sur les paramètres de date et heure, recherchez les dates dans l'aide et consultez la rubrique dates.

Les champs inclus dans cet enregistrement sont les suivants :
-Date commande (0 = mois/jour/année, 1 = jour/mois/année, 2 = année/mois/jour)
-Format de temps (0 = 12 heures, 1 = 24 heures sur 24)
-Par défaut temps (nombre de minutes écoulées après minuit)
-Séparateur de date
-Séparateur temps
-0: 00 à 11 : 59 texte
-12 : 00 à 23 : 59 texte
-Date Format (0 -14) *
-Format de date de texte de barre (-194 0) *

* 20 Différents formats sont disponibles pour les dates. Pour visualiser les formats de date disponibles dans le menu Outils, choisissez Options, sélectionnez l'onglet Affichage et sélectionnez l'option de date souhaité dans la liste Format de date. Pour plus d'informations, recherchez les dates dans l'aide et consultez la rubrique dates.

Exemple : 12,0,0,480, /,:, am, pm

Cet exemple montre comment spécifier que dates se trouvent dans l'ordre mois/jour/année, qui sont des heures dans format 12 heures, la durée par défaut est de 8 h 00 (ou 480 minutes après minuit), que le jour, mois et année sont séparées par une barre oblique, que les heures et minutes sont séparées par un signe deux-points, et que «suis» et «pm» are utilisées pour indiquer matin et soir.

Définition de calendrier de base - 20   Ces enregistrements définissent les calendriers de base et leurs périodes ouvrées et chômées jours de la semaine. Lorsque vous fusionnez un fichier MPX, informations de calendrier sont fusionnées dans le projet actif et calendriers portant le même nom sont écrasés. Les paramètres par défaut sont utilisées si il n'existe aucune entrée pour un jour. Les paramètres par défaut sont lundi à vendredi pour les jours de travail et samedi et dimanche pour les jours chômés. Dans cet enregistrement, le champ nom est requis. Pour chacun des jours, une entrée de 0 indique que le jour est un jour chômé, et une entrée de 1 indique que le jour est un jour ouvré.

Les champs inclus dans cet enregistrement sont les suivants :
-Nom
-Dimanche
-Lundi
-Mardi
-Mercredi
-Jeudi
-Vendredi
-Samedi

Exemple : 20, rédacteurs, 0, 1, 1, 1, 1, 1, 0

Cet exemple montre comment spécifier que lundi à vendredi sont des jours ouvrés et samedi et dimanche sont les jours chômés du calendrier principal nommés des writers.

Heures calendrier de base - 25   Ces enregistrements définir les heures de travail pour les jours de la semaine, s'ils diffèrent des paramètres par défaut. Les heures de travail par défaut sont 8 h 00 à 12: 00 et 13: 00 à 17: 00 Chaque enregistrement heures calendrier de base fait référence à l'enregistrement précédent de la définition de calendrier de base. Jusqu'à sept de ces enregistrements peuvent suivre chaque enregistrement de définition de calendrier de base.

-Jour de la semaine (1-7, où 1 = dimanche et 7 = samedi)
-Délai de 1
-Pour 1 heure
-Délai de 2
-Pour heure 2
-Délai de 3
-Pour la durée 3

Exemple : 25,2, 7: 00 11 : 00, 12 : 00, 4: 00

Cet exemple spécifie que le lundi, les heures de travail sont de 7 h 00 à 11 h 00 et 12 h 00 à 16 h 00.

Exception calendrier de base - 26   Ces enregistrements définissent les exceptions aux jours et heures spécifiées dans les deux types d'enregistrements précédentes. Jusqu'à 250 de ces enregistrements peuvent suivre chaque enregistrement de définition de calendrier de base. Ces enregistrements doivent être répertoriés dans l'ordre chronologique. Si une exception est un jour, vous pouvez laisser le champ date vide. Si aucun temps sont indiqués, les délais par défaut de 8 h 00 à 12: 00 et 13: 00 à 17: 00 sont utilisées.

Les champs inclus dans cet enregistrement sont les suivants :
-Date de début
-Jusqu'au
-Chômés/utilisation (0 = non ouvrables, 1 = travail)
-Délai de 1
-Pour 1 heure
-Délai de 2
-Pour heure 2
-Délai de 3
-Pour la durée 3

Exemple 1: 26,12/24/95,12/25/95,0
Exemple 2: 26,10/4/95,, 1, 8 h 00, 12 : 30

Exemple 1 rend décembre 24 et 25, 1995, les jours chômés.
Exemple 2 rend dimanche, octobre 4, 1995, une journée de travail de 8 h 00 à 12 : 30
Exemple 2 requiert une virgule supplémentaire pour contenir le lieu du champ date de fin.

Format MPX 1.0 : étant donné que les exceptions uniquement 50 sont autorisées dans Microsoft Project version 1.0, toutes les exceptions après la première 50 sera ignoré lorsque vous créez un fichier au format MPX 1.0.

En-tête de projet - 30   Cet enregistrement définit les champs de projet global, tels que date de fin de la date de début de projet et le projet. Les champs de cet enregistrement correspondent aux informations contenues dans les boîtes de dialogue Infos projet et les statistiques.

Les champs et onglets inclus dans cet enregistrement sont les suivants :
-Onglet projet
-Société
-Responsable
-Calendrier (standard utilisé si aucune entrée)
-Démarrez Date (ce champ ou le champ suivant est calculé pour un fichier importé, selon le paramètre de la planification de)
-Date de fin
-Planification de (0 = début, 1 = fin)
-Date en cours *
-Commentaires
-Coût *
-Coût planifié *
-Coût réel *
-Travail *
-Travail planifié *
-Travail réel *
-Travail *
-Durée *
-Planifié durée *
-Durée réel *
-Pourcentage accompli *
-Démarrer base *
-Planifié terminer *
-Démarrer réel *
-Terminer réel *
-Démarrez variation *
-Fin variation *
-L'objet
-Auteur
-Mots clés

* Ces champs sont calculés par Microsoft Project, valeurs importées sont pas pris en compte.

Exemple : 30, annexe horloges, Musée National, Michael Edwards, standard, 1/2/95

Dans cet exemple montre comment les horloges ont un projet pour le Musée National est géré par Michael Edwards, utilise le calendrier standard et commence le 2 janvier 1995.

MPX 1.0 et les 3.0 formats : les champs pas dans Microsoft Project version 1.0 ou 3.0 ne sont pas écrites lorsque vous créez un fichier au format 3.0 ou MPX 1.0.

Définition de table de ressources de texte - 40   Cet enregistrement répertorie les champs de ressource, dans l'ordre, qui sont importés ou exportés. Pour les fichiers importés, les noms doivent correspondre aux noms de champs utilisés dans Microsoft Project. Des fichiers exportés, cet enregistrement proviennent de la table d'exportation de ressource. Vous devez utiliser cet enregistrement ou l'enregistrement de définition de table de ressources numériques décrites ci-après. Lors de l'exportation à partir de Microsoft Project, deux de ces enregistrements sont inclus. Pour obtenir une description complète des champs disponibles, recherchez aide de Microsoft Project table d'exportation et accédez à la synthèse de table d'exportation (ressource) ou à la rubrique de synthèse de table d'exportation (tâche).

Pour cet enregistrement, répertoriez les noms des champs de ressources souhaitée, en les séparant par le caractère séparateur de liste.

Exemple : 40, nom, max. unités, taux standard

Cet exemple montre comment spécifier que chaque enregistrement de ressource dans le fichier contient le nom de ressource, la capacité maximale et le taux standard.

Remarque
Pour les fichiers importés, si vous ne fusionnez pas le nouveau fichier avec le projet ouvert et l'ID est le premier champ indiqué après le numéro d'enregistrement dans l'enregistrement de texte ou de définition de table de ressources numériques, les enregistrements de ressources sont importés avec le même numéro d'identification comme indiqué dans l'enregistrement. Par exemple, si la première importé enregistrement de ressource possède un numéro d'identification de 1 et le deuxième enregistrement de ressource importé porte le numéro ID 3, les enregistrements sont importés dans Microsoft Project en tant que ressource 1 et ressource 3, en laissant vide la ressource 2. Si vous le faites fusion et le champ N° Unique est le premier champ ou le deuxième champ suivant le champ ID, Microsoft Project va rechercher un enregistrement avec le même ID unique et remplacez les informations existantes avec les nouvelles informations. Si aucune correspondance n'est trouvée, un nouvel enregistrement est ajouté à la fin de la liste.

MPX 1.0 et 3.0 formats : les champs pas dans Microsoft Project versions 1.0 ou 3.0 ne sont pas écrites lorsque vous créez un fichier au format MPX 1.0.

Un fichier MPX doit avoir au moins deux tâches et les deux champs de ressources.

Définition de table de ressources numériques - 41   À l'aide de nombres plutôt que des noms, cet enregistrement répertorie les champs de ressource, dans l'ordre, qui sont importés ou exportés. Ceci est une autre méthode permettant d'identifier les champs de ressources inclus dans chaque enregistrement de ressource et est utile lors de la définition d'un fichier créé par un produit de langue étrangère.

Le tableau suivant répertorie les numéros de champ pour tous les champs de ressources dans Microsoft Project. Pour obtenir une description complète des champs disponibles, recherchez aide de Microsoft Project table d'exportation et consultez la rubrique de synthèse de table d'exportation (ressource).

Pour cet enregistrement, liste les numéros des champs de ressources souhaitée, en les séparant par le caractère séparateur de liste.
Field                   Number
------------------------------
% Work Complete         26
Accrue At               45
Actual Cost             32
Actual Work             22
Base Calendar           48
Baseline Cost*          31
Baseline Work*          21
Code                    4
Cost*                   30
Cost Per Use            44
Cost Variance*          34
Email Address           11
Group                   3
ID                      40
Initials                2
Linked Fields*          51
Max Units               41
Name                    1
Notes                   10
Objects*                50
Overallocated*          46
Overtime Rate           43
Overtime Work*          24
Peak*                   47
Remaining Cost*         33
Remaining Work*         23
Standard Rate           42
Text1                   5
Text2                   6
Text3                   7
Text4                   8
Text5                   9
Unique ID               49
Work*                   20
Work Variance*          25

* When creating a file to be imported into Microsoft Project, you do not have to 
include this field as it will be ignored.
				
Exemple : 41,1,41,42

Cet exemple répertorie les numéros de champ correspondent aux champs indiqués dans l'exemple précédent (nom, unités maximales et taux standard).

MPX 1.0 et 3.0 formats : les champs pas dans Microsoft Project version 1.0 ou 3.0 ne sont pas écrites lorsque vous créez un fichier au format 3.0 ou MPX 1.0.

Ressources - 50   Ces enregistrements contiennent les informations pour chaque ressource qui est importée ou exportée. Chaque enregistrement de ressource décrit une ressource. Lorsque vous importez des informations, les champs qui sont inclus sont définis par l'enregistrement de définition de table de ressources de texte ou l'enregistrement de définition de table de ressources numériques. Lorsque vous exportez des informations, les champs qui sont inclus sont ceux répertoriés dans la table d'exportation de ressources.

Pour cet enregistrement, répertorient les valeurs de champ pour la ressource, en les séparant par le caractère séparateur de liste.

Exemple : 50, charpentier, 4, 10 ? / h

Cet exemple affiche les informations de la ressource Charpentiers peut être utilisée qui correspond à la définition de la table ressource spécifiée dans l'exemple précédent. La capacité max est quatre et le taux standard est de 10 EUR de l'heure.

Format MPX 1.0 : champs de texte sont trop longs sont tronqués lorsque vous créez un fichier au format MPX 1.0. Ressources uniquement 2000 seront enregistrées au format MPX 1.0.

Notes de la ressource - 51   Ces enregistrements contiennent des remarques sur l'enregistrement de ressource qui précède immédiatement. Caractère ASCII 127 permet d'indiquer une nouvelle ligne dans la note. Si la note inclut le caractère séparateur de liste, placez la note entre guillemets.

Format MPX 1.0 : si la note est trop longue, il est tronqué lorsque vous créez un fichier au format MPX 1.0.

Définition de calendrier de ressource - 55   Ces enregistrements définissent les jours ouvrés pour la ressource spécifiée dans l'enregistrement de ressource qui précède immédiatement. Pour les fichiers importés, si il n'existe aucune entrée pour le champ nom de calendrier de base standard est utilisé. Aucune entrée pour le jour n'indique que le jour est défini sur la valeur par défaut (2). Si il n'y a aucun enregistrement de définition de calendrier de ressources, standard est utilisé comme le calendrier de base pour la ressource de la valeur par défaut utilisé pour les jours. Pour chacun des jours, une entrée de 0 indique que le jour est un jour chômé, 1 indique que le jour est un jour ouvré et 2 Spécifie que la valeur par défaut est utilisé. Pour plus d'informations sur les calendriers des ressources, recherchez Microsoft Project aide calendrier des ressources et passez à la rubrique commande temps de travail change.

Les champs inclus dans cet enregistrement sont les suivants :
-Nom du calendrier base
-Dimanche
-Lundi
-Mardi
-Mercredi
-Jeudi
-Vendredi
-Samedi

Exemple : 55, standard, 2, 2, 2, 2, 2, 0, 2

Cet exemple montre comment spécifier que la ressource définie qui précède cet enregistrement (dans ce cas, charpentier) possède la même jours ouvrables et pour dimanche au jeudi et samedi les heures le calendrier de base standard, mais ne fonctionne pas le vendredi.

Ressources calendrier heures - 56   Ces enregistrements définissent les heures de travail pour la ressource qui diffèrent du calendrier de base utilisé par la ressource. Ces enregistrements s'applique à l'enregistrement de définition de calendrier de ressources qui précède cet enregistrement. Jusqu'à sept de ces enregistrements peuvent suivre chaque enregistrement de définition de calendrier de ressources.

Les champs inclus dans cet enregistrement sont les suivants :
-Jour de la semaine (1-7, où 1 = dimanche et 7 = samedi)
-Délai de 1
-Pour 1 heure
-Délai de 2
-Pour heure 2
-Délai de 3
-Pour la durée 3

Exemple : 56,3, 7: 00 11 : 00, 12 : 00, 4: 00

Cet exemple montre comment spécifier que le mardi, la ressource immédiatement précédente (dans ce cas, charpentier) fonctionne à partir de 7 h 00 à 4: 00 avec une heure de 11: 00 à 12 h 00

Exception de calendrier de ressource - 57   Ces enregistrements définissent les exceptions aux jours et heures spécifiées dans les deux types d'enregistrements précédentes. Jusqu'à 250 de ces enregistrements peuvent suivre chaque enregistrement de définition de calendrier de ressources. Ces enregistrements doivent être répertoriés dans l'ordre chronologique. Si l'exception n'est qu'un seul jour, vous pouvez laisser le champ date vide. Si aucun temps sont indiqués, les délais par défaut de 8 h 00 à 12: 00 et 13: 00 à 17: 00 sont utilisées.

Les champs inclus dans cet enregistrement sont les suivants :
-Date de début
-Jusqu'au
-Chômés/utilisation (0 = non ouvrables, 1 = fonctionne, 2 = par défaut)
-Délai de 1
-Pour 1 heure
-Délai de 2
-Pour heure 2
-Délai de 3
-Pour la durée 3

Exemple : 57,11/9/95,11/13/95,0

Cet exemple montre comment spécifier que cette ressource (dans ce cas, charpentier) ne fonctionne pas 9 novembre 1995, 13 novembre 1995.

Format MPX 1.0 : étant donné que les exceptions uniquement 50 sont autorisées dans Microsoft Project version 1.0, toutes les exceptions après la première 50 sera ignoré lorsque vous créez un fichier au format MPX 1.0.

Définition de table de la tâche texte - 60   Cet enregistrement répertorie les champs de tâche, dans l'ordre, qui sont importés ou exportés. Pour les fichiers importés, les noms doivent correspondre aux noms de champs utilisés dans Microsoft Project. Si le fichier en cours d'exportation, cet enregistrement provient de la table d'exportation de tâches. Vous pouvez utiliser cet enregistrement ou l'enregistrement de définition de table de tâches numérique décrite plus loin, mais une ou l'autre est obligatoire. Lors de l'exportation à partir de Microsoft Project, deux de ces enregistrements sont inclus. Pour obtenir une description complète des champs disponibles, recherchez aide de Microsoft Project table d'exportation et accédez à la synthèse de table d'exportation (ressource) ou à la rubrique de synthèse de table d'exportation (tâche).

Les champs sont calculés par Microsoft Project, tels que Démarrer planifiées et de fin prévue, sont ignorés si importé. Si vous avez une tâche de début ou de fin des dates qui sont résolus, utilisez les champs type de contrainte et date contrainte.

Pour cet enregistrement, répertoriez les noms des champs de tâches souhaitée, en les séparant par le caractère séparateur de liste.

Exemple : 60, nom, la durée, prédécesseurs

Cet exemple spécifie que chaque enregistrement de tâche dans le fichier contient le nom de la tâche, la durée et prédécesseurs.

Remarque
Pour les fichiers importés, si vous ne fusionnez pas le nouveau fichier avec le projet ouvert et ID de tâche est le premier champ indiqué après le numéro d'enregistrement dans l'enregistrement de texte ou numérique définition de table de tâches, les enregistrements de tâche sont importés avec le même numéro d'identification de la tâche, comme indiqué dans l'enregistrement. Par exemple, si le premier enregistrement de tâche importées a un numéro d'identification de la tâche 1 et le deuxième enregistrement de tâche importées porte le numéro ID de tâche de 3, les enregistrements sont importés dans Microsoft Project et que la tâche 1 et tâche 3, en laissant la tâche 2 est vide. Si vous le faites fusion et le champ N° Unique est le premier champ ou le deuxième champ suivant le champ ID de tâche, Microsoft Project va rechercher un enregistrement avec le même ID unique et remplacez les informations existantes avec les nouvelles informations. Si aucune correspondance n'est trouvée, un nouvel enregistrement est ajouté à la fin de la liste. Si vous fusionnez sur les identificateurs uniques et que vous souhaitez maintenir les relations correctes, inclure Nº Unique des prédécesseurs à être importés en tant que champ et supprimer les prédécesseurs.

Si vous choisissez de fusionner dans le nouveau fichier, vous devez inclure enregistrement 75 si vous souhaitez conserver les affectations de ressources. Si vous ne le faites pas, les affectations de ressources seront supprimées.

MPX 1.0 et les 3.0 formats : les champs pas dans Microsoft Project version 1.0 ou 3.0 ne sont pas écrites lorsque vous créez un fichier au format 3.0 ou MPX 1.0. Le champ de priorités dans version 4.0 et 4.1 correspondent aux versions 1.0 et 3.0 comme suit : Not niveau et deviennent vraies optimale ; très haute, supérieure et haute deviennent élevé ; moyen est la moyenne ; faible, inférieure et très faible deviennent faible ; et le niveau inférieur sont Lowest.

Un fichier MPX doit avoir au moins deux tâches et les deux champs de ressources.

Définition de table de tâches numérique - 61   À l'aide de nombres plutôt que des noms, cet enregistrement répertorie les champs de tâche, dans l'ordre, qui sont importés ou exportés. Ceci est une autre méthode permettant d'identifier les champs de tâche inclus dans chaque enregistrement de tâche et est utile lors de la définition d'un fichier créé par un produit de langue étrangère.

Le tableau suivant répertorie les numéros de champ pour tous les champs de tâche dans Microsoft Project. Pour obtenir une description complète des champs disponibles, recherchez dans l'aide de la table d'exportation et consultez la rubrique de synthèse de table d'exportation (tâche).

Pour cet enregistrement, afficher les numéros des champs de tâches souhaitées séparées par le caractère séparateur de liste.

Field                   Number
------------------------------
% Complete              44
% Work Complete         25
Actual Cost             32
Actual Duration         42
Actual Finish           59
Actual Start            58
Actual Work             22
Baseline Cost           31
Baseline Duration       41
Baseline Finish         57
Baseline Start          56
Baseline Work           21
BCWP                    86
BCWS                    85
Confirmed               135
Constraint Date         68
Constraint Type         91
Contact                 15
Cost                    30
Cost1                   36
Cost2                   37
Cost3                   38
Cost Variance*          34
Created*                125
Critical*               82
CV*                     88
Delay                   92
Duration                40
Duration1               46
Duration2               47
Duration3               48
Duration Variance*      45
Early Finish*           53
Early Start*            52
Finish                  51
Finish1                 61
Finish2                 63
Finish3                 65
Finish4                 127
Finish5                 129
Finish Variance*        67
Fixed                   80
Fixed Cost              35
Flag1                   110
Flag2                   111
Flag3                   112
Flag4                   113
Flag5                   114
Flag6                   115
Flag7                   116
Flag8                   117
Flag9                   118
Flag10                  119
Free Slack*             93
Hide Bar                123
ID                      90
Late Finish*            55
Late Start*             54
Linked Fields*          122
Marked                  83
Milestone               81
Name                    1
Notes                   14
Number1                 140
Number2                 141
Number3                 142
Number4                 143
Number5                 144
Objects*                121
Outline Level           3
Outline Number          99
Predecessors            70
Priority                95
Project                 97
Remaining Cost          33
Remaining Duration      43
Remaining Work          23
Resource Group*         16
Resource Initials       73
Resource Names          72
Resume                  151
Resume No Earlier Than  152
Rollup                  84
Start                   50
Start1                  60
Start2                  62
Start3                  64
Start4                  126
Start5                  128
Start Variance*         66
Stop                    150
Subproject File         96
Successors              71
Summary*                120
SV*                     87
Text1                   4
Text2                   5
Text3                   6
Text4                   7
Text5                   8
Text6                   9
Text7                   10
Text8                   11
Text9                   12
Text10                  13
Total Slack*            94
Unique ID               98
Unique ID Predecessors  74
Unique ID Successors    75
Update Needed           136
WBS                     2
Work                    20
Work Variance*          24

* When creating a file to be imported into Microsoft Project, you do not have to 
include this field as it will be ignored. If you have start or finish dates that are 
fixed, use the Constraint Type and Constraint Date fields.
				
Exemple : 61,1,40,70

Cet exemple répertorie les numéros de champ correspondent aux champs indiqués dans l'exemple précédent (nom, la durée et prédécesseurs).

MPX 1.0 et le format 3.0 : les champs pas dans Microsoft Project version 1.0 ou 3.0 ne sont pas écrites lorsque vous créez un fichier au format 3.0 ou MPX 1.0.

Tâche - 70   Ces enregistrements contiennent les informations pour chaque tâche qui est importée ou exportée. Chaque enregistrement de la tâche décrit une tâche. Lorsque vous importez des informations, les champs qui sont inclus sont définis par l'enregistrement de définition de table de tâches de texte ou l'enregistrement de définition de table de tâches numérique. Lorsque vous exportez des informations, les champs qui sont inclus sont ceux répertoriés dans la table d'exportation de tâches.

Pour cet enregistrement, répertorient les valeurs de champ pour la tâche, en les séparant par le caractère séparateur de liste.

Exemple : 70, pour ciment, 6d

Cet exemple affiche les informations de la tâche «Couler ciment», qui correspond à la définition de table de tâche spécifiée dans l'exemple précédent. La durée de la tâche est de 6 jours.

Format MPX 1.0 : supérieure à cinq sont enregistrés en tant que niveau cinq niveaux de contour. Les champs de texte sont trop longs sont tronqués. Tâches uniquement 2000 sont enregistrées.

Remarques sur la tâche - 71   Ces enregistrements contiennent des remarques sur l'enregistrement de tâche immédiatement précédent. Caractère ASCII 127 permet d'indiquer une nouvelle ligne dans la note. Si la note inclut le caractère séparateur de liste, placez la note entre guillemets.

Format MPX 1.0 : si la note est trop longue, il est tronqué lorsque vous créez un fichier au format MPX 1.0.

Périodique de tâches - 72   Ces enregistrements indiquent si la tâche est une tâche périodique.

Les champs inclus dans cet enregistrement si la tâche est une tâche périodique parent sont les suivants :
-Début des occurrences que celui entré dans la boîte de dialogue Infos sur la tâche périodique.
-Fin date entrée dans la boîte de dialogue Infos sur la tâche périodique.
-Durée de chaque occurrence.
-Type de durée (jour, mois, etc..).
-Nombre d'occurrences.
-Le type choisi. (1 DAILY, 4 - WEEKLY, 8 - MONTHLY, 16 - tous les ans) dans la boîte de dialogue Infos sur la tâche périodique.
-L'index de liste modifiable dans boîte de dialogue quotidienne (1 pour tous les, 2 pour chaque autre etc..).
-L'index de liste modifiable dans la zone hebdomadaire.
-L'index de liste modifiable (premier, deuxième, troisième...) dans la zone mensuelle.
-L'index de liste modifiable (lundi, mardi...) dans la zone mensuelle.
-La zone de liste déroulante index (tous, tous autres), si bas option est sélectionnée dans la zone mensuelle.
-La valeur de la journée dans la zone mensuelle.
-La zone de liste déroulante d'index (tous, tous autres...) si options supérieure est sélectionnée dans la zone mensuelle.
-L'index de liste modifiable (premier, deuxième...) dans la zone par année.
-L'index de liste modifiable (lundi,...) dans la zone par année.
-La zone de liste déroulante indexer (janvier, février..) dans la zone par année.
-La date indiquée dans la zone par année.

Si la tâche est une tâche périodique enfant, le champ inclus dans cet enregistrement est :
-ID unique du parent

Exemple : 72,1

Cet exemple montre comment spécifier que la tâche est une tâche périodique enfant et que la tâche périodique de parent a unique ID 1.

Affectation des ressources - 75   Ces enregistrements répertorient des informations sur les ressources affectées à la tâche qui a été définie dans l'enregistrement précédent de la tâche. Si vous fusionnez les fichiers et que vous souhaitez que les informations d'affectation de ressource conservées, vous devez inclure les informations dans le fichier MPX. Si vous choisissez de fusionner, toutes les affectations existantes sur les tâches fusionnés seront supprimées. Si vous fusionnez des fichiers en fonction d'identificateurs uniques, les ressources sont affectées à l'aide du identificateurs uniques des ressources, non ID.

Les champs inclus dans cet enregistrement sont les suivants :
-ID
-Unités
-Travail
-Travail planifiée
-Travail réel
-Heures sup.
-Coût
-Coût planifiée
-Coût réel
-Début *
-Fin *
-Délai
-ID unique ressource

* Dans la mesure où ces champs sont calculés par Microsoft Project, les valeurs importées sont ignorées.

Exemple : 75,3,0.5, h 40

Cet exemple montre comment spécifier que la ressource avec numéro d'identification 3 doit être affectée à la tâche immédiatement précédente. Si les ressources entrants ne disposez pas de numéros d'identification, la ressource entrante tiers est affectée. Dans cet exemple, la ressource est affectée à la tâche «Couler le ciment» 40 heures de travail, avec 0,5 unités.

Format MPX 1.0 : champ le retard est ignoré si vous créez un fichier au format MPX 1.0.

Champs de groupe de travail affectation ressource - 76   Ces enregistrements répertorient les informations sont stockées avec chaque affectation pour les fonctionnalités de groupe de travail de Microsoft Project 4.0 et 4.1. Si vous utilisez les fonctionnalités de groupe de travail, vous devez inclure cet enregistrement pour vous assurer qu'aucune des informations sont perdue.

Les champs inclus dans cet enregistrement sont les suivants :
-ID unique du message
-Confirmé (0 = false, 1 = true)
-Réponse en attente (0 = false, 1 = true)
-Mise à jour de début (date)
-Mise à jour de fin (date)
-ID de Schedule +

Exemple : 76,1,0,1,6/1/95,6/2/95

Cet exemple montre comment spécifier que l'affectation de ressource spécifiée dans l'enregistrement d'affectation ci-dessus (75) comporte un message unique ID 1, l'affectation n'a pas confirmé, n'a pas répondu au dernier message envoyé et a été averti que la tâche de début et fin les dates sont 6/1/95 et 2/6/95.

Noms de projet - 80   Ces enregistrements répertorient tous les noms de liens DDE sont stockés dans le projet.

Les champs inclus dans cet enregistrement sont les suivants :
-Nom
-Description

Exemple : 80,DDE_Link_T1,"T((1,3,5),(Name,Duration))"

Cet exemple répertorie la liaison DDE nommée DDE_Link_T1 et sa description. Pour plus d'informations sur l'échange dynamique de données, recherchez DDE dans l'aide et consultez la rubrique Définition DDE (Dynamic Data Exchange). Étant donné que le caractère séparateur de liste est inclus dans la description, le champ est entouré de guillemets.

Format MPX 1.0 : Si vous enregistrez au format MPX 1.0, cet enregistrement n'est pas écrit.

DDE et OLE client liens - 81   Ces enregistrements répertorient tous les liens DDE dans le projet.

-Source
-Lier À

Exemple : 81,Winword|d:\winword\MPX.doc!DDE_Link1,"T(1,Name)"

Dans cet exemple, Winword|d:\winword\MPX.doc!DDE_Link1 est l'argument LINK à partir et T(1,Name) est l'argument lier À. Le caractère séparateur de liste est inclus dans la zone Lier À, le champ est entouré de guillemets. OLE liens client sont distinguent des liaisons DDE client en affectant le premier caractère «:». Par exemple : 81,:\LINK_1,"T(2,1)",":" au début de la liaison d'argument indique un lien OLE.

Format MPX 1.0 : Si vous enregistrez au format MPX 1.0, cet enregistrement n'est pas écrit.

Commentaires - 0   Ces enregistrements peuvent être utilisés pour ajouter des commentaires au fichier et peuvent apparaître dans n'importe quelle position dans le fichier. Chaque enregistrement de commentaires doit commencer par "0".

Propriétés

Numéro d'article: 270139 - Dernière mise à jour: samedi 27 janvier 2007 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Project 2000 Standard
  • Microsoft Project 98 Standard
  • Microsoft Project 4.1 Standard
  • Microsoft Project 4.1a
  • Microsoft Project 4.0 Standard
  • Microsoft Project 4.0 pour Macintosh
Mots-clés : 
kbmt kbinfo KB270139 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 270139
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com