PRJ: Descrição do formato MPX Project File Exchange de

Traduções deste artigo Traduções deste artigo
ID do artigo: 270139 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

O formato de arquivo MPX 4.0 é um formato de arquivo ASCII que você pode usar para transferir informações do projeto entre diferentes versões do Microsoft Project, bem como os programas de terceiros que oferecem suporte a formato de arquivo MPX, como Primavera Project planejador e Timberline Estimando a precisão.

O arquivo Mpxfile.wri (Windows) e o arquivo de formato de arquivo MPX (Macintosh) descrevem o formato MPX 4.0 arquivos criados no Microsoft Project versões 4.0, 4.1 e 98. Você pode encontrar esses arquivos na pasta onde você instalou o Microsoft Project versão 4.0 ou 4.1. A seção "Mais informações" deste artigo contém o texto completo do arquivo Mpxfile.wri. (Observação: O arquivo Mpxfile.wri não é incluído no Microsoft Project 98 ou Microsoft Project 2000.)

A tabela a seguir resume as versões do Microsoft Project que podem criar ou ler o formato de arquivo MPX 4.0:
                                     Create      Read
                                     ----------------
      Microsoft Project 4.0          Yes         Yes
      Microsoft Project 4.1          Yes         Yes
      Microsoft Project 98           Yes         Yes
      Microsoft Project 2000         No          Yes
				
o conversor de projeto do Microsoft é um programa baseado no Windows que você pode usar para converter arquivos criados no software de gerenciamento de projeto third-party formato MPX 4.0. Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
130206PRJ: O conversor do Microsoft Project para o Project 4.0 e 4.1
221256PRJ: Atualização do conversor de projeto para BTA Project Workbench 4.x
Para obter informações sobre como solucionar mensagens de erro que ocorrem quando você abre um arquivo MPX que contém dados inválidos, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
141261PRJ: Como interpretar a mensagem recebida ao abrir arquivo .MPX

Mais Informações

A seguir está o texto completo do arquivo Mpxfile.wri.

Com o formato de arquivo MPX

Sobre o formato de arquivo MPX

O formato de arquivo MPX é um formato de arquivo ASCII que você pode usar para transferir informações de projeto entre o Microsoft Project e outros aplicativos que oferecem suporte a formato de arquivo MPX, como Primavera Project planejador e Timberline Estimando a precisão. O formato de arquivo MPX permite a você informações de projeto de transferência que não podem aparecer em uma tabela, como informações de atribuição de recurso detalhadas, informações do calendário, ou informações na caixa de diálogo informações do projeto.

Antes de salvar um arquivo do Microsoft Project no formato de arquivo MPX, verifique que o aplicativo ao qual você deseja transferir suas informações de projeto pode interpretar o formato MPX. Em alguns casos, talvez seja necessário executar um programa de conversão antes de usar o arquivo no outro aplicativo.

Microsoft Project também pode abrir arquivos salvos em formato de arquivo MPX. O Microsoft Project versão 4.1 para o Windows 95 pode abrir e salvar arquivos MPX do Microsoft Project versão 1.0, 3.0, 4.0 e 4.1.

Você abre um arquivo MPX assim como qualquer outro arquivo do Microsoft Project. Quando você abre um arquivo MPX, você pode mesclar o arquivo no projeto ativo ou colocar as informações em um novo projeto. Se você optar por mesclar os arquivos e estiver usando identificações exclusivas, as informações no arquivo novo substituirá as informações no registro correspondente. Você pode criar arquivos MPX contendo apenas que informações que você deseja mesclar com o projeto existente, mais as atribuições de recursos. Por exemplo, você pode criar um arquivo MPX que contém somente informações de custo que foi alterado. Incluindo a identificação exclusiva e o novo custo para esse conjunto de recursos, somente essas informações são substituídas no seu projeto.

Para salvar um arquivo no formato MPX, consulte a exportação um projeto do arquivo no formato MPX tópico na Ajuda on-line. Quando você exporta um arquivo MPX, você não especificar uma tabela porque as tabelas de exportação de tarefas e recursos são usadas automaticamente. Se você excluir as tabelas de exportação do global.mpt, não será capaz de exportar um arquivo MPX a menos que você copie as tabelas de exportação do arquivo de backup global para global.mpt ou o projeto atual.

Você pode alterar as tabelas de exportação escolhendo tabelas no menu Exibir, escolhendo mais tabelas, selecionando Export e clicar no botão Editar; no entanto, você deve fazer isso somente se for instruído pelo aplicativo no qual você irá ser transferindo as informações exportadas. As tabelas de exportação fornecidas com o Microsoft Project são as tabelas padrão usadas por maioria dos aplicativos que oferecem suporte o formato de arquivo MPX.

Se as tarefas ou recursos de entrada incluir o número de identificação exclusivo na primeira ou segunda posição e você estiver mesclando dois arquivos, o Microsoft Project mescla as informações no registro correspondente; se nenhuma correspondência for encontrada, um novo registro é criado no final de tarefas ou recursos. Se você não estiver mesclando o arquivo que você está abrindo e as tarefas de entrada ou os recursos incluem um número de identificação como o primeiro campo, Microsoft Project insere cada tarefa ou recurso na linha com o número correspondente de identificação para que o número de identificação de cada tarefa ou recurso no Microsoft Project é o mesmo que o número de identificação original. Se o arquivo de entrada ignora um número de identificação, a linha de tarefa ou recurso com esse número de identificação é deixada em branco para que você pode importar linhas em branco entre as tarefas ou recursos.

Existem as seguintes diferenças entre arquivos MPX do Microsoft Project versão 3.0 e versão 4.0 e 4.1 MPX arquivos:

-Quando você abre um arquivo MPX no Microsoft Project, você não obtém o prompt para mesclar o arquivo de projeto existente por padrão. Se você deseja mesclar as informações no arquivo MPX no atual arquivo você deverá especificar isso na lista de parâmetro do comando Abrir. Para obter instruções sobre como fazer isso, procure na Ajuda para o formato de arquivo MPX mesclagem.

-Um novo registro foi adicionado para armazenar as informações usadas pelos recursos de grupo de trabalho.

-Um novo registro foi adicionado para armazenar informações sobre tarefas recorrentes.

-A configuração de posição do símbolo no registro de configurações de moeda agora fornece suporte a um espaço entre o símbolo de moeda e o número.

-Observe: não existem diferenças entre o formato de arquivo MPX do Microsoft Project versão 4.1 para Windows 95 e o formato de arquivo MPX do Microsoft Project versão 4.0.

Especificações de formato de arquivo MPX

Esta seção é destinada a desenvolvedores que estão criando programas utilitários para transferir informações entre o outro aplicativo e o Microsoft Project. Se estiver transferindo arquivos MPX entre o Microsoft Project e o outro aplicativo que já oferece suporte o formato de arquivo MPX, você não precisará ler esta seção.

Um arquivo MPX consiste em registros separados por retornos de carro e linha feeds. Dentro de cada registro são campos que contêm as informações para o projeto. Os tipos de registros e a ordem desses registros são definidas. A tabela a seguir lista todos os tipos de registro, o número do registro usada para identificar cada tipo de registro e o número de registros de cada tipo que podem ser incluídos no arquivo MPX. O arquivo MPX não tem que conter todos os tipos de registro; o único registro necessário é o registro criação do arquivo. Os registros incluídos no arquivo MPX devem ser na ordem mostrada na tabela, exceto que registros de comentário podem ser inseridos em qualquer lugar no arquivo.
Record name                        Record number   Maximum number of Records
----------------------------------------------------------------------------
File Creation (required)           none            1
Currency Settings                  10              1
Default Settings                   11              1
Date and Time Settings             12              1
Base Calendar Definition           20              250
Base Calendar Hours                25              7 per Base Calendar
                                                   Definition record
Base Calendar Exception            26              250 per Base Calendar
                                                   Definition record
Project Header                     30              1
Text Resource Table Definition     40              1
  (Or you can use the Numeric Resource Table Definition record)
Numeric Resource Table Definition  41              1
Resource                           50              9,999
Resource Notes                     51              1 per Resource record
Resource Calendar Definition       55              1 per Resource record
Resource Calendar Hours            56              7 per Resource Calendar
                                                   Definition record
Resource Calendar Exception        57              250 per Resource Calendar
                                                   Definition record
Text Task Table Definition         60              1
  (Or you can use the Numeric Task Table Definition record)
Numeric Task Table Definition      61              1
Task                               70              9,999
Task Notes                         71              1 per Task record
Recurring Task                     72              1 per Task record
Resource Assignment                75              100 per Task record
Assignment Workgroup fields        76              1 per Assignment record
Project Names                      80              500
DDE and OLE Client Links           81              500
Comments                           0               unlimited
				
Observação
Alguns registros dentro do arquivo devem seguir outros registros. Os registros na tabela anterior que listam o número máximo "por" o registro anterior devem estar listados imediatamente após esse registro. Por exemplo, até 100 recursos atribuições podem ser listadas por registro de tarefa. Se uma tarefa tiver 10 atribuições de recursos, os 10 registros de atribuição de recursos devem ser localizada imediatamente após esse registro de tarefa e antes da próxima tarefa gravar.

Um arquivo MPX sempre começa com o registro de criação do arquivo; este registro identifica o formato de arquivo (MPX), o caractere de separador de lista usado para separar campos dentro de registros, o número de aplicativo e versão usado para criar o MPX de arquivo, a versão do formato MPX que usa o arquivo e a página de código usada para criar o arquivo. Cada registro, exceto o registro de criação do arquivo, começa com o número do Registro. O número do registro é seguido pelo caractere separador de listas e as informações para cada um dos campos; cada campo é separado pelo caractere separador de lista.

As regras gerais para o conteúdo do campo são:

Campos - calculados não precisam ser importado porque eles serão ignorados.

-Se o caractere separador de lista, geralmente uma vírgula ou ponto-e-vírgula, estiver incluído em um campo, por exemplo, para separar predecessoras, o campo é colocado entre aspas.

-Se um campo contiver uma aspa, duas aspas serão usadas.

-O caractere separador de lista não precisa ser incluído para campos em branco no final de um registro.

-O caractere separador de lista deve ser incluído para campos em branco entre os campos que contêm informações.

-Quando exportando um arquivo no formato MPX do Microsoft Project, datas e horas são gravadas no formato de data padrão para a tabela Exportar. Microsoft Project pode importar as datas inseridas em qualquer um dos formatos de datas mostradas na caixa de diálogo Opções. Para obter informações sobre formatos de data e hora, procure Ajuda do Microsoft Project datas e vá para o tópico de datas.

-Microsoft Project ignora o espaço em branco (tabulações e espaços) no início e no final de campos ao importar um arquivo MPX.

Campos importados - em branco não substituir informações existentes quando mesclando arquivos MPX.

A ordem e o conteúdo exato dos campos em cada registro são descritos nas definições de registro a seguir. O número do registro usado para identificar o tipo de registro segue o nome do Registro. O exemplo em cada definição de registro usa uma vírgula como o caractere separador de lista.

Criação do arquivo - nenhum número de registro    Este é um registro necessário que identifica o formato de arquivo (MPX), o caractere separador de lista usado no arquivo, o número de versão e programa usado para criar o arquivo, o número de versão do formato de arquivo MPX usado no arquivo e a página de código usada para criar o arquivo. Isso deve ser o primeiro registro no arquivo. Quando a exportação do Microsoft Project, o caractere separador de lista é especificado no item de configurações regionais no painel de controle do Windows.

Os campos incluídos nesse registro são:
-MPX seguido imediatamente o caractere separador de lista
-Nome/identificador de programa
Número de-versão do arquivo
-Código de página (850, 437, MAC, ANSI)

Exemplo: MPX, Microsoft Project, 3.0

Este exemplo especifica que uma vírgula é usada como o caractere separador de lista neste arquivo MPX e a versão do formato MPX usado no arquivo do é exportada do Microsoft Project versão 3.0.

configurações de moeda - 10    Este registro Especifica configurações para as opções de moeda na caixa de diálogo Opções. Se você incluir valores de moeda no arquivo de importação, especifique as configurações de moeda para que os valores sejam importados corretamente. Se este registro não for incluído, as configurações atuais na caixa de diálogo Opções são usadas. Para obter informações sobre as configurações de moeda, procure a Ajuda do Microsoft Project para as configurações padrão de moeda. Os milhares e separadores decimais são especificados no item de configurações regionais no painel de controle do Windows.

Os campos incluídos nesse registro são:
Símbolo de-moeda
-Posição do símbolo (0 = após, 1 = antes, 2 = após com um espaço, 3 = antes com um espaço)
Dígitos de moeda-(0,1,2)
-Milhares separador
-Decimal separador

Exemplo: 10, $, 1,2, ",".

Este exemplo especifica que valores de moeda incluem um sinal de cifrão ($) antes de eles, dois dígitos são incluídos após o ponto decimal, que uma vírgula é usada para separar milhares, e que um período é usado como o ponto decimal. Como o caractere separador de lista é incluído no campo Separador de milhar, o campo está entre aspas.

configurações - 11 padrão    Este registro Especifica configurações para as opções padrão na caixa de diálogo Opções. Se as durações que você está importando não incluem uma abreviação de duração, especifique a unidade de duração padrão aqui para que unidades de duração estão corretas. Se este registro não for incluído, as configurações atuais na caixa de diálogo Opções são usadas. Para obter informações sobre as opções padrão, procure a Ajuda do Microsoft Project para padrões de duração.

Os campos incluídos nesse registro são:
Unidades de duração - padrão (0 = minutos, 1 = 2 horas, dias, = 3 = semanas)
Tipo de duração - padrão (0 = não corrigidos, 1 = fixo)
Unidades de trabalho - padrão (0 = minutos, 1 = 2 horas, dias, = 3 = semanas)
-Padrão horas/dia
-Padrão horas/semana
Taxa padrão - padrão
Taxa de horas extras - padrão
-Atualizar Status da tarefa status atualizações recursos (0 = não, 1 = yes)
-Dividir as tarefas em andamento (0 = não, 1 = yes)

Exemplo: 11,2,0,1,8,40, $ 10/h, $ 15/h, 1

Este exemplo especifica as seguintes configurações padrão: as durações estão em dias e não são corrigidas, unidades de trabalho estão em horas, há oito horas em um dia de trabalho e 40 horas em uma semana de trabalho, a taxa de pagamento padrão é de r$ 10,00 por hora, a taxa de pagamento de horas extras é $ 15 por hora e a caixa de seleção Atualizar Status atualizações recurso status da tarefa está marcada.

Formato MPX 1.0: como apenas números inteiros são permitidos por horas/dia padrão e horas/semana padrão no Microsoft Project versão 1.0, um valor noninteger para qualquer uma dessas opções é arredondado para o inteiro mais próximo quando você cria um arquivo no formato MPX 1.0. Opções não no Microsoft Project versão 1.0 não são gravadas quando você cria um arquivo no formato MPX 1.0.

Data e hora configurações - 12    Este registro Especifica configurações para a data e opções de tempo na caixa de diálogo Opções e a opção de formato data texto da barra na caixa de diálogo Layout. Se este registro não for incluído, as configurações atuais na caixa de diálogo Opções são usadas. Para obter informações sobre as configurações de data e hora, consulte a Ajuda para datas e vá para o tópico de datas.

Os campos incluídos nesse registro são:
-Data pedido (0 = dia/mês/ano, 1 = dia/mês/ano, 2 = ano/mês/dia)
-Formato de hora (0 = 12 horas, 1 = 24 horas)
Hora padrão-(número de minutos após a meia-noite)
Separador de data-
Separador de hora-
-0: 00 a 11: 59 texto
-12: 00 a 23: 59 texto
-Data Format (0-14) *
-Formato de data do texto de barra (0-194) *

* Há 20 diferentes formatos disponíveis para datas. Para ver os formatos de data disponíveis, no menu ' Ferramentas ', escolha ' Opções ', selecione a guia Exibir e selecione a opção de data desejada na lista formato de data. Para obter mais informações, consulte a Ajuda para datas e vá para o tópico de datas.

Exemplo: 12,0,0,480,:, 00, 00

Este exemplo especifica que as datas estão no ordem mês/dia/ano, que horas estão no formato de 12 horas, que o tempo padrão é 8: 00 (ou 480 minutos após a meia-noite), que o mês, dia e ano são separado por uma barra que horas e minutos são separados por dois-pontos e que "sou" e "pm" são usados para indicar manhã e noite.

definição do calendário base - 20    Esses registros definem calendários base e seus úteis e dias da semana. Ao mesclar um arquivo MPX, informações do calendário são mescladas no projeto ativo e calendários com o mesmo nome são substituídos. As configurações padrão serão usadas se não há nenhuma entrada para um dia. As configurações padrão são segunda a sexta-feira para dias úteis e o sábado e domingo para dias de folga. Nesse registro, o campo nome é obrigatório. Para cada um dos dias, uma entrada de 0 indica que o dia é um dia não útil, e uma entrada de 1 indica que o dia um dia útil.

Os campos incluídos nesse registro são:
-Nome
-Domingo
Segunda-
-Terça-feira
-Quarta-feira
-Quinta-feira
-Sexta-feira
-Sábado

Exemplo: 20, gravadores, 0, 1, 1, 1, 1, 1, 0

Este exemplo especifica que a segunda a sexta-feira são dias úteis, e sábado e domingo são dias de folga do calendário base nomeados gravadores.

horas de calendário base - 25    Esses registros especificar as horas de trabalho para os dias da semana, se eles forem diferentes das configurações padrão. As horas de trabalho padrão são das 8: 00 às 12: 00 e 13: 00 5: 00 Cada registro de horas do calendário base refere-se para o registro anterior de definição do calendário base. Até sete desses registros pode seguir cada registro de definição do calendário base.

-Dia da semana (1-7, onde 1 = domingo e 7 = Sábado)
-Do horário 1
-Ao horário 1
-Do horário 2
-Ao horário 2
-Do horário 3
-Ao horário 3

Exemplo: 25,2, 7: 00, 11: 00, 12: 00, 4: 00

Este exemplo especifica que nas segundas-feiras, as horas de trabalho são das 7: 00 às 12: 00 às 4 h e 11: 00

exceção de calendário base - 26    Esses registros definem as exceções aos dias e horas especificadas nos dois tipos de registros anteriores. Até 250 desses registros pode seguir cada registro de definição do calendário base. Esses registros devem estar listados em ordem cronológica. Se uma exceção for um dia, você pode deixar o campo de data vazio. Se não vezes são indicados, serão usados os horários padrão de 8: 00 às 12: 00 e 13: 00 às 17: 00.

Os campos incluídos nesse registro são:
-Desde a data
-A data
-Folga/trabalho (0 = não útil, 1 = trabalho)
-Do horário 1
-Ao horário 1
-Do horário 2
-Ao horário 2
-Do horário 3
-Ao horário 3

Exemplo 1: 26,12/24/95,12/25/95,0
Exemplo 2: 26,10/4/95, 1, 8: 00, 12: 30

Exemplo 1 torna 24 de dezembro e 25, 1995, dias de folga.
Exemplo 2 faz domingo 4 de outubro de 1995, um dia de trabalho das 8: 00 para 12: 30
Exemplo 2 requer uma vírgula extra para armazenar o local do campo Data.

Formato MPX 1.0: como são permitidas somente 50 exceções no Microsoft Project versão 1.0, todas as exceções após 50 primeiro será ignorado quando você cria um arquivo no formato MPX 1.0.

cabeçalho de projeto - 30    Este registro define campos de projeto global, como a data de início do projeto e projeto data de término. Os campos nesse registro correspondem às informações nas caixas de diálogo informações do projeto e estatísticas.

Os campos e guias incluídas nesse registro são:
Guia de-projeto
-Da empresa
-Gerenciador
Calendário-(usado se nenhuma entrada padrão)
-Data (neste campo ou o próximo campo é calculado para um arquivo importado, dependendo da configuração de cronograma a partir) de início
-Data de término
-Agenda de (0 = início, 1 = término)
Data atual - 1
-Comentários
-Custo 1
Custo - linha de base 1
Custo - real 1
-Trabalho 1
Trabalho de-linha de base 1
Trabalho real - 1
-Trabalho 1
-Duração 1
Linha de base - duração 1
Duração real - 1
-Porcentagem concluída *
Iniciar - linha de base 1
Concluir - linha de base 1
Iniciar - real 1
Concluir - real 1
-Inicie a variação 1
-Término variação 1
-Assunto
-Autor
-Palavras-chave

* Esses campos são calculados pelo Microsoft Project, portanto importados valores serão ignorados.

Exemplo: 30, exposição de relógios, Museu Nacional, Michael Edwards, padrão, 1/2/95

Neste exemplo, a exibição de relógios projeto para o National Museum é gerenciado por Michael Edwards, usa o calendário padrão e inicia em 2 de janeiro de 1995.

3.0 Formatos e MPX 1.0: campos não no Microsoft Project versão 1.0 ou 3.0 não são gravados quando você cria um arquivo no formato 3.0 ou MPX 1.0.

definição de tabela de recursos do texto - 40    Este registro lista os recursos campos, na ordem, que estão sendo importadas ou exportadas. Para arquivos importados, os nomes devem correspondem aos nomes de campo usados no Microsoft Project. Para arquivos exportados, este registro é proveniente de tabela de exportação de recursos. Você deve usar este registro ou o registro de definição de tabela de recursos numérico descrito a seguir. Ao exportar do Microsoft Project, ambos esses registros estão incluídos. Para obter uma descrição completa dos campos disponíveis, procure Ajuda do Microsoft Project tabela de exportação e vá para o resumo de tabela de exportação (recursos) ou tópico de resumo de tabela de exportação (tarefa).

Para este registro, lista os nomes dos campos de recurso que desejar, separando-as com o caractere separador de lista.

Exemplo: 40, nomes, máximas unidades, taxa padrão

Este exemplo especifica que cada registro de recurso no arquivo contém o nome do recurso, unidades máximas e taxa padrão.

Observação
Para arquivos importados, se você não mesclar o novo arquivo com o projeto aberto e ID é o primeiro campo listado após o número de registro no registro de texto ou numérico definição de tabela de recursos, os registros de recursos são importados com o mesmo número de identificação, conforme indicado no registro. Por exemplo, se importado o primeiro registro de recurso tem um número de identificação de 1 e o segundo registro de recursos importados possui um número de identificação de 3, os registros são importados para o Microsoft Project como recursos 1 e 3, deixando o recurso 2 em branco. Se você fizer a mesclagem e o campo ID exclusiva é o primeiro campo ou o seguinte campo segundo o campo ID, o Microsoft Project terá uma aparência de um registro com a mesma identificação exclusiva e substituir as informações existentes com as novas informações. Se nenhuma correspondência for encontrada, um novo registro é adicionado ao final da lista.

3.0 Formatos e MPX 1.0: campos não no Microsoft Project versões 1.0 ou 3.0 não são gravados quando você cria um arquivo no formato MPX 1.0.

Um arquivo MPX deve ter pelo menos duas tarefas e dois campos de recurso.

definição de tabela de recursos numérico - 41    Uso de números em vez de nomes, este registro lista os recursos campos, na ordem, que estão sendo importadas ou exportadas. Isso é um método alternativo para identificar os campos de recurso incluídos em cada registro de recurso e é útil quando definir um arquivo MPX criado por um produto de idioma estrangeiro.

A tabela a seguir mostra os números de campo para todos os campos de recurso no Microsoft Project. Para obter uma descrição completa dos campos disponíveis, procure Ajuda do Microsoft Project tabela de exportação e vá para o tópico de resumo de tabela de exportação (recurso).

Para este registro, lista os números dos campos de recurso que você deseja, separando-as com o caractere separador de lista.
Field                   Number
------------------------------
% Work Complete         26
Accrue At               45
Actual Cost             32
Actual Work             22
Base Calendar           48
Baseline Cost*          31
Baseline Work*          21
Code                    4
Cost*                   30
Cost Per Use            44
Cost Variance*          34
Email Address           11
Group                   3
ID                      40
Initials                2
Linked Fields*          51
Max Units               41
Name                    1
Notes                   10
Objects*                50
Overallocated*          46
Overtime Rate           43
Overtime Work*          24
Peak*                   47
Remaining Cost*         33
Remaining Work*         23
Standard Rate           42
Text1                   5
Text2                   6
Text3                   7
Text4                   8
Text5                   9
Unique ID               49
Work*                   20
Work Variance*          25

* When creating a file to be imported into Microsoft Project, you do not have to 
include this field as it will be ignored.
				
Exemplo: 41,1,41,42

Este exemplo lista os números de campo que correspondem aos campos mostrados no exemplo anterior (nome, unidades máximas e taxa padrão).

3.0 Formatos e MPX 1.0: campos não no Microsoft Project versão 1.0 ou 3.0 não são gravados quando você cria um arquivo no formato 3.0 ou MPX 1.0.

recursos - 50    Esses registros contêm as informações para cada recurso que está sendo importado ou exportado. Cada registro de recurso descreve um recurso. Quando você importa informações, os campos que estão incluídos são definidos pelo registro de definição de tabela de recursos de texto ou o registro de definição de tabela de recursos numérico. Quando você exporta informações, os campos que estão incluídos são aqueles listados na tabela de exportação de recursos.

Para este registro, lista os valores de campo para o recurso, separando-as com o caractere separador de lista.

Exemplo: 50, carpinteiro, 4, $ 10/h

Este exemplo mostra as informações para o recurso carpinteiro que coincida com a definição de tabela de recurso especificada no exemplo anterior. Unidades máximas é quatro e taxa padrão é de r$ 10,00 por hora.

Formato MPX 1.0: campos de texto que são muito longos são truncados quando você cria um arquivo no formato MPX 1.0. Recursos apenas 2000 serão salvos no formato MPX 1.0.

anotações do recurso - 51    Esses registros contêm anotações sobre o registro de recurso imediatamente anterior. Use o caractere ASCII 127 para indicar uma nova linha na anotação. Se a Observação inclui o caractere separador de lista, coloque a anotação entre aspas.

Formato MPX 1.0: se a anotação é muito longa, será truncado quando você cria um arquivo no formato MPX 1.0.

definição de calendário de recurso - 55    Esses registros definem os dias de trabalho para o recurso especificado no registro de recurso imediatamente anterior. Para arquivos importados, se não houver nenhuma entrada para o campo nome do calendário base, o padrão é usado. Nenhuma entrada para o dia específico indica que o dia é definido para o padrão (2). Se não houver nenhum registro de definição de calendário de recursos, padrão é usado como o calendário base para o recurso com padrão usado para os dias. Para cada um dos dias, uma entrada de 0 indica que o dia é um dia não útil, 1 indica que o dia é um dia útil, e 2 Especifica que o padrão é usado. Para obter informações sobre calendários de recursos, procurar Ajuda do Microsoft Project calendário de recursos e vá para o tópico do comando de tempo de trabalho Change.

Os campos incluídos nesse registro são:
Nome de calendário - base
-Domingo
Segunda-
-Terça-feira
-Quarta-feira
-Quinta-feira
-Sexta-feira
-Sábado

Exemplo: 55, padrão, 2, 2, 2, 2, 2, 0, 2

Este exemplo especifica que o recurso definido imediatamente anterior deste registro (nesse caso, carpinteiro) tem o mesmo trabalho dias e horas como o calendário base padrão para domingo a quinta-feira e sábado, mas não funciona nas sextas-feiras.

horário do calendário do recurso - 56    Esses registros definem horas de trabalho para o recurso que diferem do calendário base usado pelo recurso. Esses registros se aplicam ao registro de definição de calendário de recursos imediatamente anterior deste registro. Até sete desses registros pode seguir cada registro de definição de calendário de recursos.

Os campos incluídos nesse registro são:
-Dia da semana (1-7, onde 1 = domingo e 7 = Sábado)
-Do horário 1
-Ao horário 1
-Do horário 2
-Ao horário 2
-Do horário 3
-Ao horário 3

Exemplo: 56,3, 7: 00, 11: 00, 12: 00, 4: 00

Este exemplo especifica que no terças-feiras, o recurso imediatamente anterior (nesse caso, carpinteiro) funciona da 7: 00 às 4: 00. com uma hora de 11: 00 às 12: 00.

exceção de calendário de recurso - 57    Esses registros definem as exceções aos dias e horas especificadas nos dois tipos de registros anteriores. Até 250 desses registros pode seguir cada registro de definição de calendário de recursos. Esses registros devem estar listados em ordem cronológica. Se a exceção é apenas um dia, você poderá deixar o campo Data vazia. Se não vezes são indicados, serão usados os horários padrão de 8: 00 às 12: 00 e 13: 00 às 17: 00.

Os campos incluídos nesse registro são:
-Desde a data
-A data
-Folga/trabalho (0 = não útil, 1 = trabalhando, 2 = padrão)
-Do horário 1
-Ao horário 1
-Do horário 2
-Ao horário 2
-Do horário 3
-Ao horário 3

Exemplo: 57,11/9/95,11/13/95,0

Este exemplo especifica que este recurso (neste caso, carpinteiro) não funciona de 9 de novembro de 1995, 13 de novembro de 1995.

Formato MPX 1.0: como são permitidas somente 50 exceções no Microsoft Project versão 1.0, todas as exceções após 50 primeiro será ignorado quando você cria um arquivo no formato MPX 1.0.

definição de tabela de tarefas do texto - 60    Este registro de lista tarefa campos, na ordem, que estão sendo importadas ou exportadas. Para arquivos importados, os nomes devem correspondem aos nomes de campo usados no Microsoft Project. Se o arquivo está sendo exportado, este registro vêm da tabela exportar tarefas. Você pode usar este registro ou o registro de definição de tabela de tarefas numérico descrito a seguir, mas uma ou a outra é necessária. Ao exportar do Microsoft Project, ambos esses registros estão incluídos. Para obter uma descrição completa dos campos disponíveis, procure Ajuda do Microsoft Project tabela de exportação e vá para o resumo de tabela de exportação (recursos) ou tópico de resumo de tabela de exportação (tarefa).

Campos que são calculados pelo Microsoft Project, como agendadas de início e término programado, serão ignorados se importado. Se você tiver tarefa início ou término datas que são corrigidas, use os campos tipo de restrição e data da restrição.

Para este registro, lista os nomes dos campos de tarefa que você deseja, separando-as com o caractere separador de lista.

Exemplo: 60, nome, duração, Predecessoras

Este exemplo especifica que cada registro de tarefa no arquivo de contém o nome da tarefa, duração e Predecessoras.

Observação
Para arquivos importados, se você não mesclar o novo arquivo com o projeto aberto e ID da tarefa for o primeiro campo listado após o número de registro no registro de texto ou numérico definição de tabela de tarefas, os registros de tarefas são importados com o mesmo número de identificação tarefa conforme indicado no registro. Por exemplo, se o primeiro registro de tarefa importada tem um número de identificação de tarefa de 1 e o segundo registro tarefa importada tem um número de identificação de tarefa de 3, os registros serão importados para o Microsoft Project como tarefa 1 e a tarefa 3, deixando a tarefa 2 em branco. Se você fizer a mesclagem e o campo ID exclusiva é o primeiro campo ou o seguinte campo segundo campo Identificação de tarefa, o Microsoft Project terá uma aparência de um registro com a mesma identificação exclusiva e substituir as informações existentes com as novas informações. Se nenhuma correspondência for encontrada, um novo registro é adicionado ao final da lista. Se você mescla em identificações exclusivas e deseja manter as relações corretas, incluir Predecessoras com identificação exclusiva como um campo a ser importado e remova as predecessoras.

Se você mesclar no novo arquivo, você deve incluir registro 75 se você desejar manter as atribuições de recursos. Se você não fizer isso, as atribuições de recursos serão excluídas.

3.0 Formatos e MPX 1.0: campos não no Microsoft Project versão 1.0 ou 3.0 não são gravados quando você cria um arquivo no formato 3.0 ou MPX 1.0. O campo de prioridades na versão 4.0 e 4.1 mapeado para as versões 1.0 e 3.0 da seguinte maneira: nível não e True se tornar maior; muito alta, superior e alta tornam-se alta; médio é médio; muito baixa, baixa e inferior ficam baixa; e inferior é mais baixa.

Um arquivo MPX deve ter pelo menos duas tarefas e dois campos de recurso.

definição de tabela de tarefas numérico - 61    Usando números em vez de nomes, este registro de lista tarefa campos, na ordem, que estão sendo importadas ou exportadas. Isso é um método alternativo para identificar os campos de tarefa incluídos em cada registro de tarefa e é útil quando definir um arquivo MPX criado por um produto de idioma estrangeiro.

A tabela a seguir mostra os números de campo para todos os campos de tarefa no Microsoft Project. Para obter uma descrição completa dos campos disponíveis, procure ajuda a tabela de exportação e vá para o tópico de resumo de tabela de exportação (tarefas).

Para este registro, lista os números dos campos de tarefa que você deseja separados pelo caractere separador de lista.

Field                   Number
------------------------------
% Complete              44
% Work Complete         25
Actual Cost             32
Actual Duration         42
Actual Finish           59
Actual Start            58
Actual Work             22
Baseline Cost           31
Baseline Duration       41
Baseline Finish         57
Baseline Start          56
Baseline Work           21
BCWP                    86
BCWS                    85
Confirmed               135
Constraint Date         68
Constraint Type         91
Contact                 15
Cost                    30
Cost1                   36
Cost2                   37
Cost3                   38
Cost Variance*          34
Created*                125
Critical*               82
CV*                     88
Delay                   92
Duration                40
Duration1               46
Duration2               47
Duration3               48
Duration Variance*      45
Early Finish*           53
Early Start*            52
Finish                  51
Finish1                 61
Finish2                 63
Finish3                 65
Finish4                 127
Finish5                 129
Finish Variance*        67
Fixed                   80
Fixed Cost              35
Flag1                   110
Flag2                   111
Flag3                   112
Flag4                   113
Flag5                   114
Flag6                   115
Flag7                   116
Flag8                   117
Flag9                   118
Flag10                  119
Free Slack*             93
Hide Bar                123
ID                      90
Late Finish*            55
Late Start*             54
Linked Fields*          122
Marked                  83
Milestone               81
Name                    1
Notes                   14
Number1                 140
Number2                 141
Number3                 142
Number4                 143
Number5                 144
Objects*                121
Outline Level           3
Outline Number          99
Predecessors            70
Priority                95
Project                 97
Remaining Cost          33
Remaining Duration      43
Remaining Work          23
Resource Group*         16
Resource Initials       73
Resource Names          72
Resume                  151
Resume No Earlier Than  152
Rollup                  84
Start                   50
Start1                  60
Start2                  62
Start3                  64
Start4                  126
Start5                  128
Start Variance*         66
Stop                    150
Subproject File         96
Successors              71
Summary*                120
SV*                     87
Text1                   4
Text2                   5
Text3                   6
Text4                   7
Text5                   8
Text6                   9
Text7                   10
Text8                   11
Text9                   12
Text10                  13
Total Slack*            94
Unique ID               98
Unique ID Predecessors  74
Unique ID Successors    75
Update Needed           136
WBS                     2
Work                    20
Work Variance*          24

* When creating a file to be imported into Microsoft Project, you do not have to 
include this field as it will be ignored. If you have start or finish dates that are 
fixed, use the Constraint Type and Constraint Date fields.
				
Exemplo: 61,1,40,70

Este exemplo lista os números de campo que correspondem aos campos mostrados no exemplo anterior (nome, duração e predecessoras).

MPX 1.0 e formato 3.0: campos não no Microsoft Project versão 1.0 ou 3.0 não são gravados quando você cria um arquivo no formato 3.0 ou MPX 1.0.

tarefa - 70    Esses registros contêm as informações para cada tarefa que está sendo importado ou exportado. Cada registro de tarefa descreve uma tarefa. Quando você importa informações, os campos que estão incluídos são definidos pelo registro de definição de tabela de tarefas de texto ou o registro de definição de tabela de tarefas numérico. Quando você exporta informações, os campos que estão incluídos são aqueles listados na tabela de exportação de tarefa.

Para este registro, lista os valores de campo para a tarefa, separando-as com o caractere separador de lista.

Exemplo: 70, derramar cimento, d 6

Este exemplo mostra as informações para a tarefa "Sólido cimento" que coincida com a definição de tabela de tarefa especificada no exemplo anterior. A duração da tarefa é de 6 dias.

Formato MPX 1.0: estruturar maiores do que cinco são salvos como nível cinco níveis. Campos de texto são muito longos são truncados. Tarefas somente 2000 são salvas.

tarefa anotações - 71    Esses registros contêm anotações sobre o registro de tarefa imediatamente anterior. Use o caractere ASCII 127 para indicar uma nova linha na anotação. Se a Observação inclui o caractere separador de lista, coloque a anotação entre aspas.

Formato MPX 1.0: se a anotação é muito longa, será truncado quando você cria um arquivo no formato MPX 1.0.

recorrente tarefa - 72    Esses registros indicam se a tarefa é uma tarefa recorrente.

Os campos incluídos neste registro se a tarefa for uma tarefa recorrente pai são:
-Início das ocorrências como digitado na caixa de diálogo informações de tarefa recorrente.
-Término data inserida na caixa de diálogo informações de tarefa recorrente.
-Duração de cada ocorrência.
Tipo de duração-(dia, mês, etc.).
-Número de ocorrências.
-O tipo escolhido. (1 DAILY, 4 - WEEKLY, 8 - MONTHLY, 16 - ANUALMENTE) na caixa de diálogo informações de tarefa recorrente.
-O índice de combinação na caixa de diálogo diário (1 para cada, 2 para todos os outro etc..).
-O índice de combinação na caixa de ponto.
-O índice de combinação (primeiro, segundo, terceiro...) na caixa mensal.
-O índice de combinação (segunda-feira, terça-feira...) na caixa mensal.
-A combinação índice (cada, todos os outros) se inferior botão de opção é selecionado na caixa mensal.
-O valor do dia na caixa mensal.
-A combinação índice (cada, todos os outros...) se botão de opção superior é selecionado na caixa mensal.
-O índice de combinação (primeiro, segundo...) na caixa anual.
-O índice de combinação (segunda-feira,...) na caixa anual.
-A combinação de índice (janeiro, fevereiro...) na caixa anual.
-A data mostrada na caixa anual.

Se a tarefa for uma tarefa recorrente filho, o campo incluído neste registro será:
IDENTIFICAÇÃO - exclusiva do pai

Exemplo: 72,1

Este exemplo especifica que a tarefa é uma tarefa recorrente filho e que a tarefa recorrente pai possui 1 de identificação exclusivo.

atribuição de recurso - 75    Esses registros listam informações sobre os recursos atribuídos à tarefa que foi definida no registro de tarefas anterior. Se você estiver mesclando arquivos, e você desejar obter informações de atribuição de recursos mantidos, você precisará incluir as informações no arquivo MPX. Se você mesclar, todas as atribuições existentes em tarefas mescladas serão excluídas. Se você estiver mesclando arquivos com base em identificações exclusivas, recursos são atribuídos usando o recurso exclusivo identificações, em vez de identificações.

Os campos incluídos nesse registro são:
-ID
-Unidades
-Trabalho
Trabalho - planejado
Trabalho real-
Trabalho de horas extras-
-Custo
Custo - planejado
Custo - real
-Início 1
-Término 1
-Atraso
IDENTIFICAÇÃO exclusiva do-recurso

* Como esses campos são calculados pelo Microsoft Project, valores importados são ignorados.

Exemplo: 75,3,0.5, 40 h

Este exemplo especifica que o recurso com número de identificação 3 ser atribuído à tarefa imediatamente anterior. Se os recursos de entrada não tiverem números de identificação, o recurso de entrada terceiro é atribuído. Neste exemplo, o recurso é atribuído à tarefa "Cimentar cimento" para 40 horas de trabalho, com unidades de 0,5.

Formato MPX 1.0: atraso o campo será ignorado se você criar um arquivo no formato MPX 1.0.

Campos de grupo de trabalho de atribuição de recurso - 76    Esses registros listam as informações que são armazenadas com cada atribuição para os recursos de grupo de trabalho do Microsoft Project 4.0 e 4.1. Se você estiver usando os recursos de grupo de trabalho que você precisa para incluir esse registro para garantir que nenhuma informação será perdida.

Os campos incluídos nesse registro são:
IDENTIFICAÇÃO exclusiva da mensagem-
-Confirmado (0 = False, 1 = True)
-Resposta pendente (0 = False, 1 = True)
-Atualizar Iniciar (data)
-Atualizar concluir (data)
Identificação do Schedule +-

Exemplo: 76,1,0,1,6/1/95,6/2/95

Este exemplo especifica que a atribuição de recurso especificada no registro de atribuição acima (75) tem mensagem unique ID 1, não confirmou a atribuição, não respondeu à última mensagem enviada e foi notificada que a tarefa início e término datas são de 1/6/95 e 2/6/95.

nomes de projeto - 80    Esses registros listar todos os nomes de vínculo DDE que são armazenados no projeto.

Os campos incluídos nesse registro são:
-Nome
-Descrição

Exemplo: 80,DDE_Link_T1,"T((1,3,5),(Name,Duration))"

Este exemplo lista o vínculo DDE chamado DDE_Link_T1 e sua descrição. Para obter mais informações sobre o DDE, consulte a Ajuda para DDE e vá para o tópico de definição de intercâmbio dinâmico de dados (DDE). Como o caractere separador de lista é incluído a descrição, o campo está entre aspas.

Formato MPX 1.0: se você estiver salvando no formato MPX 1.0, este registro não será gravado.

DDE e OLE cliente links - 81    Esses registros lista todos os vínculos DDE para o projeto.

-Fonte
-Vincular para

Exemplo: 81,Winword|d:\winword\MPX.doc!DDE_Link1,"T(1,Name)"

Neste exemplo, Winword|d:\winword\MPX.doc!DDE_Link1 é o argumento link de e T(1,Name) é o argumento link em. Como o caractere separador de lista é incluído no link para, o campo está entre aspas. OLE cliente links sejam distinguem vínculos do cliente DDE, definindo o primeiro caractere como ":". Por exemplo: 81,:\LINK_1,"T(2,1)", o":" no início do link de argumento indica um vínculo OLE.

Formato MPX 1.0: se você estiver salvando no formato MPX 1.0, este registro não será gravado.

comentários - 0    Esses registros podem ser usados para adicionar comentários para o arquivo e podem aparecer em qualquer posição no arquivo. Cada registro de comentários deve começar com "0".

Propriedades

ID do artigo: 270139 - Última revisão: sábado, 27 de janeiro de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Project 2000 Standard Edition
  • Microsoft Project 98 Standard Edition
  • Microsoft Project 4.1 Standard Edition
  • Microsoft Project 4.1a
  • Microsoft Project 4.0 Standard Edition
  • Microsoft Project 4.0 for Macintosh
Palavras-chave: 
kbmt kbinfo KB270139 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 270139

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com