Email rimane nella posta in uscita quando si usa il valore del Registro di sistema DelegateSentItemsStyle

Numero KB originale: 2703723

Sintomi

Quando si invia un messaggio di posta elettronica da una cassetta postale condivisa, il messaggio di posta elettronica inviato rimane nella posta in uscita fino a quando non si esegue manualmente un'operazione di invio/ricezione.

Causa

Questo problema si verifica quando si verificano tutte le condizioni seguenti:

  • Il profilo di Outlook è configurato in modalità online (non nella cache).
  • Il valore del DelegateSentItemsStyle Registro di sistema è impostato su 1.

Risoluzione

È possibile risolvere questo problema usando uno dei metodi seguenti. Se questi metodi non sono accettabili, vedere la sezione Soluzione alternativa per altre opzioni.

Metodo 1 - Modificare il valore di DelegateSentItemsStyle su 0 nel Registro di sistema

Se si imposta DelegateSentItemsStyle=0 nel Registro di sistema, i messaggi di posta elettronica inviati da una cassetta postale condivisa verranno copiati nella cartella Posta inviata e non nella cartella Posta inviata della cassetta postale condivisa.

Importante

Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

  1. Chiudere Outlook.

  2. Avviare l'editor del Registro di sistema Per effettuare questa operazione, applicare una delle procedure descritte di seguito in base alla versione di Windows in uso.

    Windows 8 e Windows 10: premere Tasto Windows+R per aprire una finestra di dialogo Esegui. Digitare regedit.exe, quindi fare clic su OK.

    Windows 7 o Windows Vista: selezionare Start, digitare regedit nella casella Avvia ricerca e quindi premere INVIO. Se viene richiesto di immettere la password amministratore o di confermare l'operazione, digitare la password o selezionare Consenti.

    Windows XP: selezionare Start, selezionare Esegui, digitare regedit e quindi selezionare OK.

  3. Individuare e selezionare la seguente chiave del Registro di sistema:

    HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\Preferences

    Nota

    In questo percorso chiave il segnaposto <x.0> rappresenta 16,0 per Outlook 2016, Outlook per Microsoft 365 e Outlook 2019, 15.0 per Outlook 2013, 14.0 per Outlook 2010, 12.0 per Outlook 2007 e 11.0 per Outlook 2003.

  4. Selezionare il DelegateSentItemsStyle valore.

  5. Dal menu Modifica, selezionare Modifica.

  6. Digitare 0, quindi selezionare OK.

  7. Uscire dall'editor del Registro di sistema.

  8. Avviare Outlook.

Metodo 2- Modificare il profilo in modalità cache

Se è necessario disporre della funzionalità offerta dal valore del DelegateSentItemsStyle Registro di sistema (=1), l'altra opzione consiste nel modificare il profilo dalla modalità online alla modalità memorizzata nella cache.

Outlook 2010 e versioni successive

  1. Nella scheda File selezionare Impostazioni account e quindi selezionare Impostazioni account.
  2. Nella scheda Posta elettronica selezionare l'account Exchange Server, selezionare Modifica e quindi abilitare l'opzione Usa modalità cache.
  3. Selezionare Avanti e quindi Fine.
  4. Uscire e riavviare Outlook.

Outlook 2007

  1. Nel menu Strumenti selezionare Impostazioni account.
  2. Nella scheda Posta elettronica selezionare l'account Exchange Server e quindi selezionare Modifica.
  3. In Server di Microsoft Exchange selezionare la casella di controllo Usa modalità cache .
  4. Selezionare OK.
  5. Uscire e riavviare Outlook.

Outlook 2003

  1. Nel menu Strumenti selezionare Account di posta elettronica.
  2. Nella finestra di dialogo Account di posta elettronica selezionare Visualizza o modifica account di posta elettronica esistenti e quindi selezionare Avanti.
  3. Selezionare l'account Exchange Server e quindi selezionare Modifica.
  4. Nella finestra di dialogo Account di posta elettronica selezionare la casella di controllo Usa modalità cache e quindi selezionare Avanti.
  5. Selezionare OK e quindi riavviare Outlook.

Soluzione alternativa

Se i metodi forniti nella sezione Risoluzione non sono accettabili e la cassetta postale si trova in Microsoft Exchange Server 2010 Service Pack 2 Aggiornamento cumulativo 4 o versione successiva o Exchange Server 2013 Aggiornamento cumulativo 9 o versione successiva o Microsoft 365 Exchange Online, l'amministratore di Exchange può configurare un comportamento simile nel server. Queste configurazioni non richiedono l'abilitazione della DelegateSentItemsStyle chiave del Registro di sistema, pertanto il problema non si verificherà.

aggiornamento cumulativo 4 o versione successiva di Microsoft Exchange Server 2010 Service Pack 2

L'aggiornamento cumulativo 4 per Exchange Server 2010 Service Pack 2 ha introdotto un nuovo cmdlet PowerShell di Exchange per configurare la cartella Posta inviata nella quale viene copiato un messaggio. Poiché questa nuova funzionalità viene gestita dal server Exchange, Outlook può essere configurato per la modalità online o memorizzata nella cache di Exchange. Tuttavia, la funzionalità del server Exchange funziona solo se il valore del Registro di sistema di Outlook DelegateSentItemsStyle è disabilitato.

Per altre informazioni sul Set-MailboxSentItemsConfiguration cmdlet, vedere I messaggi inviati usando le autorizzazioni "Invia come" e "Invia per conto" vengono copiati solo nella cartella Posta inviata del mittente in un ambiente Exchange Server 2010.

Microsoft Exchange Server 9 o versione successiva dell'aggiornamento cumulativo 2013 o Microsoft 365 Exchange Online

L'aggiornamento cumulativo 9 per Exchange Server 2013 ha introdotto una nuova funzionalità che consente agli amministratori di configurare la cartella Elemento inviato in cui viene copiato un messaggio. Poiché questa nuova funzionalità viene gestita dal server Exchange, Outlook può essere configurato per la modalità online o memorizzata nella cache di Exchange. Si noti che se si abilita questa funzionalità e si abilita contemporaneamente il DelegateSentItemsStyle valore del Registro di sistema con un profilo di Outlook memorizzato nella cache, due copie dell'elemento inviato verranno salvate nella cartella Posta inviata delle cassette postali condivise.

Per altre informazioni su questa funzionalità, vedere Ottenere un maggiore controllo sugli elementi inviati quando si usano cassette postali condivise.

Ulteriori informazioni

Il DelegateSentItemsStyle valore del Registro di sistema viene archiviato nel percorso seguente nel Registro di sistema di Windows:

HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\Preferences

Nota

In questo percorso del Registro di sistema x.0 <> corrisponde alla versione di Outlook (Outlook 2003 = 11.0, Outlook 2007 = 12.0, Outlook 2010 = 14.0, Outlook 2013 = 15.0, Outlook 2016, Outlook per Microsoft 365 e Outlook 2019 = 16.0).

La funzionalità fornita dal valore del DelegateSentItemsStyle Registro di sistema è descritta in Quando si invia un messaggio di posta elettronica da una cassetta postale condivisa in Outlook 2007, il messaggio inviato non viene salvato nella cartella Posta inviata della cassetta postale condivisa.