Event ID 10007 error logged in Application event log after uninstalling an application

Article ID: 2704186 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You have a computer running Windows 7 or Windows Server 2008 R2.
  • An application is installed that uses the Microsoft Windows Installer 4.0 or 5.0 for installation and servicing on Windows.
  • You uninstall the application.

In this scenario, after the uninstall has finished, you may see an error similar to the following logged in the Windows Application event log:

Log Name: Application
Source: Microsoft-Windows-RestartManager
Date: Date
Event ID: 10007
Task Category: None
Level: Error
User: UserGUID
Computer: ComputerName

Description: Application or service 'ApplicationName' could not be restarted.

CAUSE

This event log error occurs when Restart Manager attempts to restart the application or service after it has already been uninstalled. By default, applications that use Windows Installer 4.0 or 5.0 for installation and servicing on Windows automatically use Restart Manager.

RESOLUTION

This event error can be safely ignored.

MORE INFORMATION

For more information on Restart Manager or the Event ID 10007, click on one of the links below.

Restart Manager
http://msdn.microsoft.com/en-us/library/windows/desktop/cc948910(v=vs.85).aspx

Using Windows Installer with Restart Manager
http://msdn.microsoft.com/en-us/library/windows/desktop/aa372466(v=vs.85).aspx

Event ID 10007 - Application or Service Restart Status
http://technet.microsoft.com/en-us/library/dd393101(v=ws.10).aspx


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2704186 - Last Review: April 21, 2012 - Revision: 2.0
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
KB2704186

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