Inkonsistente Suchergebnisse, nachdem ein Inhaltsindex ist neu in Exchange Server erstellt.

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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie installieren 2007 für Microsoft Exchange Server oder Microsoft Exchange Server 2010.
  • Sie erstellen den Inhaltsindex für eine Datenbank neu.
  • Führen Sie eine Suche auf einem Clientcomputer. Beispielsweise führen Sie eine Suche mithilfe von Microsoft Outlook, Microsoft Outlook-Webanwendung oder Windows Mobile.
  • Sie führen eine zweite Suche mit den gleichen Suchbegriff.
  • Sie führen eine dritte Suche mit den gleichen Suchbegriff.
In diesem Szenario möglicherweise inkonsistente Ergebnisse, die bei jeder Suche zurückgegeben werden. Z. B. wenn die Datenbank mit 10 Instanzen für den Suchbegriff enthält, bei der erste Suche möglicherweise zwei Instanzen zurück, die zweite Suche möglicherweise acht Instanzen zurück, und die dritte Suche möglicherweise 10 Instanzen zurück.

Ursache

Dieses Problem tritt auf, wenn der Microsoft Exchange-Suchindizierungsdienst gestartet wird, wenn der Index, der neu erstellt werden, gelöscht wird.

Lösung

Um dieses Problem zu vermeiden, beenden Sie den Microsoft Exchange-Suchindizierungsdienst beim Löschen des Indexes neu erstellt werden.

Hinweis Es wird empfohlen, dass Sie das Skript Resetsearchindex, beenden Sie den Dienst Microsoft Exchange-Suchindizierung, den alten Index zu löschen und starten Sie den Dienst ausführen. Dies zwingt die Exchange Server den Volltext-Indexkatalog neu erstellen.

Hinweis Das Resetsearchindex-Skript befindet sich im Ordner "\Program Files\Microsoft\Exchange Server\Scripts\".

Weitere Informationen

Das Problem, das im Abschnitt "Problembeschreibung" erwähnte tritt auf, weil der Microsoft Exchange-Suchindizierungsdienst einen Cache von Eigenschaftszuordnungen für bestimmte Elemente verwaltet, die im Index enthalten sind. In der Regel ist eine Teilmenge der Eigenschaften die gleiche Eigenschaft-ID zugewiesen.

Jedoch können die Eigenschaften in Funktion sein, wenn der Dienst Microsoft Exchange-Suchindizierung nicht neu gestartet wird, bevor der Index neu erstellt wird. Microsoft Exchange (Suchen), daher können allgemeine Eigenschaften an anderen Orten gebracht. Dies bewirkt, dass die Symptome, die im Abschnitt "Problembeschreibung" erwähnt werden.

Informationsquellen

Weitere Informationen dazu, wie Sie die Index-Volltextkatalog in Exchange Server neu erstellen 2007 finden Sie auf die folgende TechNet-Website:

http://technet.Microsoft.com/en-us/library/aa995966 (v=exchg.80) aspx


Eigenschaften

Artikel-ID: 2704862 - Geändert am: Donnerstag, 16. August 2012 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbprb kbtshoot kbmt KB2704862 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2704862
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