Klienti vzdálené plochy Protocol nemůže připojit k serveru Terminálové služby

Překlady článku Překlady článku
ID článku: 270588 - Produkty, které se vztahují k tomuto článku.
Poznámka
Tento článek se týká systému Windows 2000. Podporu pro systém Windows 2000 končí na 13. července 2010.Windows 2000 End-of-Support Solution Center je výchozí bod pro plánování strategie přenesení ze systému Windows 2000. Další informace v tématu Microsoft Support Lifecycle Policy.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Klienti Terminálové služby pravděpodobně připojit k počítači se systémem Windows 2000 se spuštěnou Terminálovou službou.

Při použití modulu Konfigurace Terminálové služby snap-in (Tscc.msc) přenosu se zdá být přítomno a pracovní (RDP-TCP). Však při zobrazení přenos pomocí Správce Terminálové (Tsadmin.exe) RDP-TCP naslouchání je hlášena jako "Dolů 65536."

Příčina

Tomuto problému může dojít, pokud spuštění serveru pomocí možnosti Poslední známá funkční konfigurace více než jednou. Pokud server více než jednou má byl spuštěn do poslední známé funkční konfigurace, klíč registru
ControlSet001
odstraněna. Následující hodnota registru je však pevně použít
ControlSet001
klíč registru:
Klíč:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\


Název hodnoty:
\Device\Video0

Typ hodnoty:
REG_SZ

Hodnota data:
\REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0

Řešení

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které sdělit, jak upravit registr. Po nesprávné úpravě registru však mohou nastat závažné problémy. Postupujte proto pečlivě podle uvedených kroků. Pro zvýšení bezpečnosti registr zálohujte jestě před jeho úpravami. Potom můžete v případě potíží registr obnovit. Další informace o zálohování a obnovení registru naleznete následujícím článku znalostní v databáze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows 2000. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
260910Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000
Řešení těchto potíží:
  1. Spusťte program Editor registru (Regedt32.exe).
  2. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\
    Poznámka: Pokud máte tento klíč, vytvořte jej pomocí Editoru registru.
  3. Proveďte jednu z následujících akcí:
    • Pokud jste neměli vytvořit klíč v kroku 2, změnit následující hodnotu
      Název:
      \Device\Video0

      Typ:
      REG_SZ

      Hodnota:
      \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
      následující:
      Název:
      \Device\Video0

      Typ:
      REG_SZ

      Hodnota:
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
    • Pokud bylo nutné vytvořit klíč registru v kroku 2 přidejte následující hodnotu:
      Název podklíče:
      RDPDD

      Název:
      \Device\Video0

      Typ:
      REG_SZ

      Hodnota:
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
  4. Po změně (nebo vytvoření) hodnotu, restartujte počítač se spuštěnou Terminálovou službou.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl poprvé opraven v systému Windows 2000 Service Pack 2.

Vlastnosti

ID článku: 270588 - Poslední aktualizace: 1. března 2007 - Revize: 3.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Klíčová slova: 
kbmt kbbug kbenv kbtermserv KB270588 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:270588

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com