Clients de protocole bureau distant ne peuvent pas se connecter à serveur des Services Terminal Server

Traductions disponibles Traductions disponibles
Numéro d'article: 270588 - Voir les produits auxquels s'applique cet article
Avertissement
Cet article s'applique à Windows 2000. Prise en charge pour Windows 2000 s'achève le 13 juillet 2010,. Le Windows 2000 End-of-Support Solution Center est un point de départ pour planifier votre stratégie de migration à partir de Windows 2000. Pour plus d'informations, consultez la Microsoft Support Lifecycle Policy.
Agrandir tout | Réduire tout

Symptômes

Les clients des Services Terminal Server peuvent ne pas pouvoir vous connecter à un ordinateur fonctionnant sous Windows 2000 exécute les Services Terminal Server.

Lorsque vous utilisez la configuration des Services Terminal Server snap-dans (TSCC.msc), le transport (RDP-TCP) semble présents et qu'il fonctionne. Toutefois, lorsque vous afficher le transport à l'aide du Gestionnaire des Services Terminal Server (TSAdmin.exe), RDP-TCP port d'écoute est signalé comme «Down 65536».

Cause

Ce problème peut se produire si le serveur a été démarré à l'aide de l'option Dernière bonne configuration connue plusieurs fois. Lorsque le serveur a été démarre plusieurs fois la dernière bonne configuration connue, la clé de Registre
ControlSet001
est supprimée. Toutefois, la valeur de Registre suivante est codée en dur pour utiliser la clé de Registre
ControlSet001
:
Clé :
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\


Nom de valeur :
\Device\Video0

Type valeur :
REG_SZ

Données de la valeur :
\REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0

Résolution

Important Cette section, la méthode ou la tâche contient vous explique comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous que vous procédez comme suit. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre en cas de problème. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
322756Comment faire pour sauvegarder et restaurer le Registre de Windows

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows 2000. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
260910Comment faire pour obtenir le dernier Service Pack de Windows 2000
Pour résoudre ce problème :
  1. Démarrez l'Éditeur du Registre (Regedt32.exe).
  2. Recherchez et cliquez sur la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\VIDEO\rdpdd\
    Remarque Si vous n'avez pas cette clé, utilisez l'Éditeur du Registre pour le créer.
  3. Effectuez l'une des opérations suivantes :
    • Si vous n'aviez pas créer la clé dans l'étape 2, modifiez la valeur suivante
      Nom :
      \Device\Video0

      Type :
      REG_SZ

      Valeur :
      \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
      à la suivante :
      Nom :
      \Device\Video0

      Type :
      REG_SZ

      Valeur :
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
    • Si vous deviez créer la clé de Registre dans l'étape 2, ajoutez la valeur suivante :
      Nom de la sous-clé :
      RDPDD

      Nom :
      \Device\Video0

      Type :
      REG_SZ

      Valeur :
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
  4. Après avoir modifié (ou créez) la valeur, redémarrez l'ordinateur exécutant les Services Terminal Server.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé dans Windows 2000 Service Pack 2.

Propriétés

Numéro d'article: 270588 - Dernière mise à jour: jeudi 1 mars 2007 - Version: 3.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Mots-clés : 
kbmt kbbug kbenv kbtermserv KB270588 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 270588
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com