ไคลเอนต์โพรโทคอลเดสก์ท็อประยะไกลไม่สามารถเชื่อมต่อไปยังเซิร์ฟเวอร์บริการเทอร์มินัล

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 270588 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
หมายเหตุ
บทความนี้สามารถใช้ได้กับ Windows 2000การสนับสนุนสำหรับสิ้นสุดของ Windows 2000 ในเดือน 13 กรกฎาคม 2010กระบวนการศูนย์โซลูชัน windows 2000 สิ้นสุดของบริการเป็นจุดเริ่มต้นสำหรับการวางแผนเชิงกลยุทธ์การย้ายข้อมูลระบบของคุณจาก Windows 2000 สำหรับข้อมูลเพิ่มเติมให้ดูนโยบาย Lifecycle ฝ่ายสนับสนุนของ Microsoft.
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

ไคลเอ็นต์บริการเทอร์มินัลอาจไม่สามารถเชื่อมต่อกับคอมพิวเตอร์ที่ใช้ Windows 2000 ที่กำลังเรียกใช้บริการเทอร์มินัล

เมื่อคุณใช้การกำหนดค่าบริการเทอร์มินัลสแน็ปอิน (Tscc.msc), การขนส่ง (RDP Tcp) ปรากฏขึ้นเพื่อ ให้การนำเสนอ และการทำงาน อย่างไรก็ตาม เมื่อคุณดูการขนส่ง โดยใช้โปรแกรมจัดการบริการเทอร์มินัล (Tsadmin.exe), RDP TCP ฟังรายงานเป็น "ลง 65536

สาเหตุ

ปัญหานี้อาจเกิดขึ้นได้หากมีการ booted เซิร์ฟเวอร์ โดยใช้การLast Known Good Configuration (ค่าคอนฟิกปกติล่าสุดที่รู้จัก)ตัวเลือกมากกว่าหนึ่งครั้ง เมื่อเซิร์ฟเวอร์ได้ถูก booted ลงในการกำหนดค่าที่ดีที่รู้จักที่สุดท้ายมากกว่าหนึ่ง การ
ControlSet001
ลบคีย์รีจิสทรี อย่างไรก็ตาม ค่ารีจิสทรีต่อไปนี้เป็นฮาร์ดดิสก์แบบ coded ใช้นั้น
ControlSet001
คีย์รีจิสทรี:
คีย์::
Server\VIDEO\rdpdd\ HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal


ชื่อค่า::
\Device\Video0

ชนิดค่า:
Reg_SZ

ข้อมูลค่า::
\REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0

การแก้ไข

สิ่งสำคัญนี้ส่วน วิธี หรืองานประกอบด้วยขั้นตอนที่บอกวิธีการแก้ไขรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322756วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows

เมื่อต้องการแก้ไขปัญหานี้ ขอรับ service pack ล่าสุดสำหรับ Windows 2000 สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
260910วิธีการขอรับ Service Pack ล่าสุดของ Windows 2000
เมื่อต้องการแก้ไขปัญหานี้:
  1. เริ่มการทำงานของโปรแกรม Registry Editor (Regedt32.exe)
  2. ค้นหา และคลิกรีจิสทรีคีย์ต่อไปนี้:
    Server\VIDEO\rdpdd\ HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal
    หมายเหตุ:ถ้าคุณไม่มีคีย์นี้ ใช้ Registry Editor เพื่อสร้างดังกล่าว
  3. เลือกทำอย่างใดอย่างหนึ่งต่อไปนี้::
    • ถ้าคุณไม่มีการสร้างคีย์การในขั้นตอนที่ 2 เปลี่ยนค่าต่อไปนี้
      ชื่อ::
      \Device\Video0

      ประเภท::
      Reg_SZ

      ค่า:
      \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
      เมื่อต้องการต่อไปนี้:
      ชื่อ::
      \Device\Video0

      ประเภท::
      Reg_SZ

      ค่า:
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
    • ถ้าคุณมีการสร้างคีย์รีจิสทรีในขั้นตอนที่ 2 เพิ่มค่าต่อไปนี้:
      ชื่อคีย์ย่อย:
      rdpdd

      ชื่อ::
      \Device\Video0

      ประเภท::
      Reg_SZ

      ค่า:
      \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
  4. หลังจากที่คุณเปลี่ยนแปลง (หรือสร้าง) ค่า เริ่มต้นคอมพิวเตอร์ที่กำลังเรียกใช้บริการเทอร์มินัล

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วนเริ่มต้นของเอกสารนี้ก่อนมีแก้ไขปัญหานี้ใน Windows 2000 Service Pack 2

คุณสมบัติ

หมายเลขบทความ (Article ID): 270588 - รีวิวครั้งสุดท้าย: 8 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbbug kbenv kbtermserv kbmt KB270588 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:270588

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com