Article ID: 270592 - Last Review: January 27, 2007 - Revision: 5.5

Setup Is Unable to Register Tasks or Cannot Find the Work Services File

This article was previously published under Q270592
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry
-or-
322756  (http://support.microsoft.com/kb/322756/EN-US/ ) HOW TO: Back Up, Edit, and Restore the Registry in Windows XP

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SYMPTOMS

When you try to remove any of the programs listed at the beginning of this article, you may receive either of the following error messages:
Setup is unable to register tasks.
-or-
Cannot find the Work Services file.
You may also receive a message stating that the Workssvc.dll file is missing.

If you reinstall the affected program, the issue is not resolved.

CAUSE

This behavior can occur if any of the following conditions are true:
  • The .msi files for the program are missing, damaged, or in the wrong location.
  • The .dll files for the program are missing, damaged, or in the wrong location.
  • The folders for the program are missing or in the wrong location.
  • The entries for the program in the Windows registry are damaged.
Note Any of these conditions can occur if you tried to remove Works or a Works Suite program by deleting the folder in which the program is installed instead of by using the Add/Remove Programs tool in Microsoft Windows Control Panel.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use the steps in the following article to clean boot and manually remove all portions of Works:
816273  (http://support.microsoft.com/kb/816273/ ) "Setup Is Unable to Remove Earlier Version" Error Message When You Try to Install Works 7.0 or Works Suite 2003
If you have Picture It! 2001 (any version) also download and run the Picture It! Publishing 2001 Utility as appropriate to your version of Windows to remove that program's folders and registry keys.

Microsoft Windows Millennium Edition (Me), Microsoft Windows 95 and Microsoft Windows 98

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download the Picture It! Publishing 2001 Utility to Remove Program Folders and Registry Keys (95/98/ME) package now. (http://download.microsoft.com/download/pictureitsilver2001/utility/1/winme/en-us/pip2k1kl.exe)

Microsoft Windows 2000 and Microsoft Windows XP

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download the Picture It! Publishing 2001 Utility to Remove Program Folders and Registry Keys package now. (http://download.microsoft.com/download/pictureitsilver2001/utility/1/nt5/en-us/pipwin2k.exe)

After you have all versions of Works and any 2001 version of Picture It! removed, insert the Works CD and follow instructions on screen to install Works. After Works is installed, if you removed any 2001 version of Picture It!, you should reinstall it now (if you want to).

APPLIES TO
  • Microsoft Works 7.0
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2002
  • Microsoft Works Suite 2001
  • Microsoft Works 6.0
  • Microsoft Works Suite 2000
  • Microsoft Works 2000 Standard Edition
  • Microsoft Picture It! Publishing 2002 Platinum Edition
  • Microsoft Picture It! Publishing 2002 Gold
Keywords: 
kbdownload kberrmsg kbgraphxlinkcritical kbprb KB270592
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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