Error message after you run the MOSDAL Support Toolkit: "The AD FS Metadata Exchange (MEX) document did not contain the SecurityTokenService section"

Article ID: 2707345 - View products that this article applies to.

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PROBLEM

After you run the Microsoft Online Services Diagnostics and Logging (MOSDAL) Support Toolkit, the Active Directory Federation Services (AD FS), the following error message is logged in the ADFSDiagnostic.txt diagnostics log file:
The AD FS Metadata Exchange (MEX) document did not contain the SecurityTokenService section.
Note The log file is located in the \Admin_Applications\SSO_Diagnostic_Tests\ folder.

Additionally, when you try to sign in to Office 365 resources by using single sign-on (SSO)-enabled user ID credentials, rich client application authentication fails when it tries to access services.

CAUSE

An issue occurred with the AD FS 2.0 service that prevented it from functioning as expected.

SOLUTION

To resolve this issue, restart the AD FS 2.0 service. If that doesn't resolve the issue, contact Office 365 Support.

MORE INFORMATION

Still need help? Go to the Office 365 Community website.

Properties

Article ID: 2707345 - Last Review: May 31, 2013 - Revision: 8.0
Applies to
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Windows Azure Active Directory
Keywords: 
o365 o365a mosdal4.5 o365022013 after upgrade o365062011 pre-upgrade o365e o365m KB2707345

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